3.0.4.2 Böses Update, mailkonten werden nicht mehr korrekt angelegt.. :S

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von spencky88, 10. Jan. 2012.

  1. spencky88

    spencky88 Member

    Servus :)
    erstmal schön das wieder ein neues Update kam.
    Jetzt allerdings habe ich ein schlechtes Problemchen.

    Code:
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    51A4EC326      1113 Tue Jan 10 15:03:02  root@server1.XYZ.de
    (temporary failure. Command output: sh:  /var/vmail/XYZ/mail/ispconfig_mailsize: No such file or  directory /usr/bin/maildrop: Unable to create a dot-lock at  /var/vmail/XYZ/mail/4925.0.server1.)
                                             mail@XYZ.de
    
    Wenn ich im var/mail Ordner schaue sehe ich das die Berechtigungen nicht mehr stimmen, und roundcube sagt mir auf einmal (nur bei neu angelegten konten) das die verbindung zum IMAP nicht mehr hergestellt werden kann.... bestehende e-mail konten funktionieren allerdings 1A ;)

    würde mich freuen wenn wer helfen kann :)

    PS.
    Das steht im Mail - Protokoll
    Code:
    Jan 10 15:14:22 server1 postfix/master[2910]: daemon started -- version 2.7.1, configuration /etc/postfix
    Jan 10 15:14:22 server1 postfix/qmgr[2921]: C7742C4AD: from=, size=1146, nrcpt=1 (queue active)
    Jan 10 15:14:23 server1 postfix/qmgr[2921]: A706FC4B6: from=, size=1119, nrcpt=1 (queue active)
    Jan 10 15:14:23 server1 postfix/qmgr[2921]: 44E53C4B2: from=, size=1116, nrcpt=1 (queue active)
    Jan 10 15:14:23 server1 postfix/qmgr[2921]: 3C0DEC4B0: from=, size=1116, nrcpt=1 (queue active)
    Jan 10 15:14:23 server1 maildrop[2981]: Unable to create a dot-lock at /var/vmail/XYZ.de/test2/2981.0.server1.
    Jan 10 15:14:23 server1 maildrop[2980]: Unable to open mailbox.
    Jan 10 15:14:23 server1 postfix/pipe[2977]: 44E53C4B2: to=, relay=maildrop, delay=4880, delays=4880/0.11/0/0.47, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/XYZ.de/test2/2981.0.server1. )
    Jan 10 15:14:23 server1 postfix/pipe[2971]: C7742C4AD: to=, relay=maildrop, delay=63265, delays=63264/0.31/0/0.48, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to open mailbox. )
    Jan 10 15:14:23 server1 maildrop[3017]: Unable to create a dot-lock at /var/vmail/XYZ.de/test2/3017.0.server1.
    Jan 10 15:14:23 server1 maildrop[3016]: Unable to open mailbox.
    Jan 10 15:14:23 server1 postfix/pipe[2977]: A706FC4B6: to=, relay=maildrop, delay=442, delays=441/0.64/0/0.06, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to open mailbox. )
    Jan 10 15:14:23 server1 postfix/pipe[2971]: 3C0DEC4B0: to=, relay=maildrop, delay=58941, delays=58941/0.43/0/0.07, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/XYZ.de/test2/3017.0.server1. )
    mfg :) der neue
     
    Zuletzt bearbeitet: 10. Jan. 2012
  2. Till

    Till Administrator

    Ruf folgenden Befehl auf, um alle Rechte zurückzusetzen:

    chown -R vmail:vmail /var/vmail

    Habe das Anlegen neuer Konten gerade bei mir getestet und alle haben die richtigen Rechte. Vielleicht steht bei Dir ja unter System > Server Config > Mail ein falscher User drin. Richtig ist User und Gruppe vmail.
     
  3. spencky88

    spencky88 Member

    ne sorry, klappt nicht....
    der befehl wird genommen , passiert aber nichts...


    Code:
    root@server1:/var/vmail/DOMAIN.de# ls -l
    insgesamt 16
    drwx------  9 vmail vmail 4096  9. Sep 12:00 support
    drwx------ 10 vmail vmail 4096 28. Apr 2011  test
    drwxr-xr-x  3 vmail vmail 4096 10. Jan 15:49 test123
    drwx------ 12 vmail vmail 4096 10. Jan 13:44 webmaster
    
    TEST123 wurde neu angelegt..... :( ich verzweifel
     
  4. Till

    Till Administrator

    Die Rechte "drwxr-xr-x" sollten ok sein, habe ich auf meinem Server hier auch und da funktioniert es.
     
  5. Till

    Till Administrator

    Poste bitte mal die Ausgabe von:

    df -h
     
  6. spencky88

    spencky88 Member

    TIIIIIIIIIIIILL du bist mein held :D

    es war alles soweit ok ich habe nur vor lauter bäumen den wald nicht gesehen ;)
    das update hat wohl den dienst vertauscht , ich arbeite (normal) mit courier , aber es stand plötzlich auf dovecot,

    jetzt gehts wieder :D das is ja der hit in tüten. gut das du mir gesagt hast ich soll mal in die config schauen, hab ich total vergessen.... scheiß arbeitsstress.... jetztr gehn ma erstmal zum chef und beantragen eine masseurin :D

    vielen lieben dank!!

    (EDIT) Hier noch deine ausgabe

    Code:
    root@server1:/var/vmail/DOMAIN# df -h
    Dateisystem           Size  Used Avail Use% Eingehängt auf
    /dev/sda1             916G  302G  568G  35% /
    tmpfs                 1,8G     0  1,8G   0% /lib/init/rw
    udev                  1,7G  172K  1,7G   1% /dev
    tmpfs                 1,8G     0  1,8G   0% /dev/shm
    
     
  7. Till

    Till Administrator

    Schau mal mit:

    which dovecot

    nach, ob da nicht ein dovecot bei Dir neben courier installiert ist. Sollte das der Fall sein, solltest Du dovecot mal entfernen.
     
  8. spencky88

    spencky88 Member

    klaro, ist mit installiert ;)
    hau ich gleich direkt mal raus :D
     
  9. Till

    Till Administrator

    Teste bitte mal ob der Dir der Updater den smtp-auth jetzt auch auf dovecot umgebogen hat. Sollte das der Fall sein, brauchst Du lediglich die main.cf Datei aus der etc.tar.gz Datei aus dem Backup in /var/backup zurück zu kopieren bzw. an sich sollte auch die alte main.cf auch noch mit angehängter ~ im /etc/postfix/ Verzeichnis liegen.
     

Diese Seite empfehlen