8.04 lts -> 10.04 lts

Dieses Thema im Forum "Server Administration" wurde erstellt von hahni, 30. Apr. 2010.

  1. hahni

    hahni Active Member

    Hallo zusammen,

    würde gerne von 8.04 LTS auf 10.04 LTS upgraden. Befürchte aber, dass es da auch wieder Probleme geben könnte wie seinerzeit von 6.04 LTS auf 8.04 LTS (App-Armor etc.).

    Hat schon jemand ein Upgrade durchgeführt? Bisher habe ich immer die "sources.list" überarbeitet und das upgrade durchgeführt. In der Upgrade-Anleitung steht aber:

    --

    1. Install update-manager-core if it is not already installed:
      sudo apt-get install update-manager-core
    2. edit /etc/update-manager/release-upgrades and set Prompt=lts
    3. Launch the upgrade tool:
      sudo do-release-upgrade --devel-release
    4. Follow the on-screen instructions.
    --

    Welcher Weg ist der vorteilhaftere und sinnvollere?

    Viele Grüße

    Hahni
     
  2. hahni

    hahni Active Member

    Das Update auf 10.04 LTS hat mit oben beschriebenen Anweisungen hervorragend geklappt. Nur die neue Version von postgrey will nicht:

    --
    root@server:/# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be upgraded:
    postgrey
    1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/57.0kB of archives.
    After this operation, 24.6kB of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Preconfiguring packages ...
    (Reading database ... 75945 files and directories currently installed.)
    Preparing to replace postgrey 1.31-2 (using .../postgrey_1.32-4_all.deb) ...
    Stopping postfix greylisting daemon: postgrey.
    db4.7_upgrade: Program version 4.7 doesn't match environment version 4.8
    db4.7_upgrade: DB_ENV->open: DB_VERSION_MISMATCH: Database environment version mismatch
    dpkg: error processing /var/cache/apt/archives/postgrey_1.32-4_all.deb (--unpack):
    subprocess new pre-installation script returned error exit status 1
    Starting postfix greylisting daemon: postgrey.
    Errors were encountered while processing:
    /var/cache/apt/archives/postgrey_1.32-4_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    --

    Was tun?
     
  3. Till

    Till Administrator

  4. hahni

    hahni Active Member

    Hallo Till,

    ich habe die ganzen Datenbanken gelöscht. Dann hat es auch funktioniert. Ich denke, dass man damit als Workaround auch leben kann.

    Dass aber rkhunter nun einen "Xzibit Rootkit" meldet (als Fehlalarm), ist viel ärgerlicher.

    Viele Grüße

    Hahni
     
  5. hahni

    hahni Active Member

    Seit dem Update von 8.04LTS auf 10.04LTS kann ich leider kein ISPConfig mehr aktualisieren:

    --
    ########## INSTALLATION ##########

    Dateien werden vorbereitet. Bitte warten Sie einen Moment...
    cp: cannot stat `/root/ispconfig/httpd/conf/ssl.*': No such file or directory
    --

    Ich habe mir noch einmal alle Einzel-Schritte des perfekten Ubuntu 10.04LTS-Servers angesehen.

    Die Unterschiede (wie z.B. die Modifikation in /usr/include/stdio.h) nachgezogen. Aber es geht defakto nicht.

    Wenn ich die SSL-Sachen ins /root/isconfig/httpd/conf-Verzeichnis kopiere, kommt die Meldung nicht mehr. Aber das System steigt bei der Installation trotzdem aus.

    Welche Dateien aus dem conf-Ordner werden noch benötigt? Faktisch ist dieser nämlich derzeit leer. Aber ich habe noch ein Backup, welches 1 Woche alt ist.

    Woran könnte dies noch liegen? Das ISPConfig-Verzeichnis existiert auch. Zudem werden keine Mails mehr zugestellt, während der Versand funktioniert.

    Woran könnten die beiden Sachen liegen?
     
    Zuletzt bearbeitet: 4. Mai 2010
  6. Till

    Till Administrator

    Ohne gepostete Fehlermeldungen vom Kompiliervorgang und aus dem mail log kann ich dazu garnichts sagen.
     
  7. hahni

    hahni Active Member

    Der hat mittlerweile geklappt. Ich habe den Symlink zur Bash noch einmal neu gesetzt und das conf-Verzeichnis aus einem Backup zurück kopiert.

    Allerdings klappt der Abruf der Mails nicht:
    Wenn ich keine Authentifizierung habe: HELO COMMAND REJECTED
    Wenn ich Passwort manuell eingebe: Authentifizierungsmethode wird nicht unterstützt.
    Wenn ich habe „Wie Posteingang“: Ein Popup, welches nach der Kennung fragt.
     
  8. Till

    Till Administrator

    Da schein ein sasl Konfigurationsfehler vorzuliegen. Gehe nochmal alle Schritte der Emailkonfiguration aus dem perfect setup für die neue ubuntu version durch bzw. führe sie erneut aus.
     
  9. hahni

    hahni Active Member

  10. Till

    Till Administrator

    Dann mach doch bitte mal das, was ich in #6 gepostet habe. Ohne exakte und vollständige Log Messages kann ich nur raten, was das Problem ist.
     
  11. hahni

    hahni Active Member

    Leider weiß ich nicht, welche Logs ich dir schicken könnte. Fakt ist: "telnet localhost 25" gibt gleiche Ausgabe zurück wie im HowTo. Die anderen Sachen für POP3 habe ich auch noch einmal alle durchgeführt.
     
  12. Till

    Till Administrator

    Ist ein mail problem, also mail.log.
     
  13. hahni

    hahni Active Member

    Hier z.B. ein Login(-versuch):

    --
    May 5 14:29:04 server couriertcpd: Connection, ip=[::ffff:94.195.121.167]
    May 5 14:29:04 server couriertcpd: LOGIN, user=web76_mail, ip=[::ffff:94.195.121.167], port=[52225]
    May 5 14:29:04 server couriertcpd: LOGOUT, user=web76_mail, ip=[::ffff:94.195.121.167], port=[52225], top=0, retr=0, rcvd=29, sent=97, time=0
    --
     
  14. Till

    Till Administrator

    Das ist der funktionierende Login desUsers web76_mail und kein Fehlerhafter Login. Versuch nochmal das versenden mit Authentifizierung und poste dann die Fehlermeldungen die Du für diese Aktion im Log erhältst.
     
  15. hahni

    hahni Active Member

    Ich habe noch einmal die Schritte durchgeführt. Nun steht da, dass der Dienst nicht gestartet werden kann:
    --
    /etc/init.d/saslauthd start
    Starting SASL Authentication Daemon: (failed).
    --

    Konfiguration:
    --
    # Settings for saslauthd daemon
    # Please read /usr/share/doc/sasl2-bin/README.Debian for details.
    #

    # Should saslauthd run automatically on startup? (default: no)
    START=yes

    # Description of this saslauthd instance. Recommended.
    # (suggestion: SASL Authentication Daemon)
    DESC="SASL Authentication Daemon"

    # Short name of this saslauthd instance. Strongly recommended.
    # (suggestion: saslauthd)
    NAME="saslauthd"

    # Which authentication mechanisms should saslauthd use? (default: pam)
    #
    # Available options in this Debian package:
    # getpwent -- use the getpwent() library function
    # kerberos5 -- use Kerberos 5
    # pam -- use PAM
    # rimap -- use a remote IMAP server
    # shadow -- use the local shadow password file
    # sasldb -- use the local sasldb database file
    # ldap -- use LDAP (configuration is in /etc/saslauthd.conf)
    #
    # Only one option may be used at a time. See the saslauthd man page
    # for more information.
    #
    # Example: MECHANISMS="pam"
    MECHANISMS="pam"

    # Additional options for this mechanism. (default: none)
    # See the saslauthd man page for information about mech-specific options.
    MECH_OPTIONS=""

    # How many saslauthd processes should we run? (default: 5)
    # A value of 0 will fork a new process for each connection.
    THREADS=5

    # Other options (default: -c -m /var/run/saslauthd)
    # Note: You MUST specify the -m option or saslauthd won't run!
    #
    # See /usr/share/doc/sasl2-bin/README.Debian for Debian-specific information.
    # See the saslauthd man page for general information about these options.
    #
    # Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
    #OPTIONS="-c -m /var/run/saslauthd"
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
    --
     
    Zuletzt bearbeitet: 5. Mai 2010
  16. hahni

    hahni Active Member

    sasl lässt sich nun wieder starten. statt "OPTIONS" muss "PARAMS" verwendet werden. Das ist leider im Tut von Falko falsch.

    Aber als Meldung erscheint leider noch immer:
    --
    Vom Server wird keine dieser Authetifizierungsmethoden unterstützt
    --
     
  17. hahni

    hahni Active Member

    Wenn ich "telnet localhost 25" eingebe, erscheint nicht - wie im TUT angegeben - "250-AUTH LOGIN PLAIN".

    Das scheint auch das Problem zu sein, weswegen ich nicht verschicken kann an dem Server. Doch was ist da falsch gelaufen?
     
  18. hahni

    hahni Active Member

    Der Parameter "smtpd_tls_auth_only = no" statt in der "main.cf" bei mir auf "smtpd_tls_auth_only = yes". Jetzt funktioniert es...
     

Diese Seite empfehlen