Add Email-User by remote api with a bit of headache

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von AceLine, 2. Juli 2013.

  1. AceLine

    AceLine Member

    Hi Till, Hi Falco,
    Hi Forumianers,

    Ich bin mir sicher, dass es nur eine Kleinigkeit ist, vielleicht könnt Ihr mir ja einen Wink mit dem Zaunpfahl in die reichtige Richtung geben:

    Ich füge mit der Remote-API von ispConfig3 einen neuen Mail-User hinzu. Die API-Doku erklärt alles perfekt... Die Mailbox wird problemlos angelegt.
    Da gibt es nur ein verflixtes Problem:

    Der neu generierte User kann sich in seine Mailbox per RC-Mail nicht einloggen, solange ich nicht mindestens einmal in den ispConfig-Settings die Mailbox des Users geöffnet habe, dort irgendwas mache (z.B. den Spamfilter auf Normal stellen) und dann auf Speichern klicke.

    Nach dieser Aktion kann sich der User problemlos einloggen...

    Ich nutze die Auto-Login Funktionalität in Roundcube. Sobald der User seinen Webmail-Link klickt, sollte eigentlich sofort die Mailbox aufgehen. Das funktioniert auch, zumindest nach den oben beschriebenen Schritten. Davor sieht es so aus:

    Das Login-Formular erscheint und die rote Statusbox sagt: "Your session is invalid or expired."
    Wenn ich dann versuche mich manuell einzuloggen, sagt die rote Statusbox: "Connection to storage server failed."

    Wie gesagt: Nach den beschriebenen Schritten funktioniert alles perfekt.

    Bitte helft mir dieses Problem zu lösen...


    Beste Grüße an alle,

    Ingmar (aka AceLine)
     
    Zuletzt bearbeitet: 2. Juli 2013
  2. Till

    Till Administrator

  3. AceLine

    AceLine Member

  4. Till

    Till Administrator

    Vergleiche mal den Datensatz in der mail_user Tabelle nachdem Du es mit dem remote api eingefügt hast und dann nachdem Du ihn in ispconfig geändert hast. Irgendein Parameter muss im $params array falsch oder nicht gesetzt sein.
     
  5. AceLine

    AceLine Member

    Hi Till,

    das war die richtige Antwort... :) allerdings verstehe ich nicht warum uid und gid exakt 5000 sein muss (Standardwert)...!?

    Der Fehler lag darin, dass ich dachte, man müsse dafür sorgen dass uid und gid nicht doppelt vorkommen. Darum habe ich immer beim Erstellen zu den 5000 des Standardwerts noch die uid des Users aus meinem System hinzugefügt. Somit war z.B. beim letzten Versuch die uid und die gid auf 5095 für meinen User mit der uid 95 angelegt worden.

    Jedenfalls geht es jetzt und ich habe gelernt, dass die uid und die gid jedenfalls auf dem Standardwert bleiben müssen.

    Liebe Grüße,

    Ingmar (aka AceLine)
     
  6. Till

    Till Administrator

    Es handelt sich um ein Mailsystem auf Bais von virtuellen Usern dass unter dem Systemuser vmail läuft. Der Systemuser vmail hat uid und gid 5000, wenn Du eine andere Uid nimmst dann kann die Mailbox nicht funktionieren da der Account keinen Zugriff auf die Ordner hat.
     
  7. AceLine

    AceLine Member

    Vielen Dank!!! Alles Gute weiterhin für Euer Team!

    Lg. Ingmar
     

Diese Seite empfehlen