AddHandler cgi-script wird nicht angelegt

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von frosch95, 11. Dez. 2008.

  1. frosch95

    frosch95 New Member

    Hallo,
    bei einer Webseite habe ich nachträglich CGI-Skripte über ISPConfig erlaubt.
    Die Skripte werden aber nicht gefunden. Nun habe ich in der Vhosts_ispconfig.conf nachgeschaut und gesehen, dass bei diesem VHost die AddHandler cgi-script Einträge fehlen.

    Wo kann ich nachsehen, was schiefgeht? Oder täusche ich mich, dass der Handler im Vhost Eintrag der Domain vorhanden sein muss?

    Vielen Dank für die Hilfe, anhängend der Abschnitt der Vhost Datei.
    Andi

    Code:
    <VirtualHost XXX.XXX.XXX.XXX:80>
    ServerName XXX:80
    ServerAdmin webmaster@XXX
    DocumentRoot /var/www/web3/web
    ServerAlias XXX
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web3/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode On
    php_admin_value open_basedir /var/www/web3/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /var/www/web3/phptmp/
    php_admin_value session.save_path /var/www/web3/phptmp/
    Alias /error/ "/var/www/web3/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web3/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web3/user/$1/web/$3
    </VirtualHost>
    
    
     
  2. Till

    Till Administrator

    /home/admispconfig/ispconfig/ispconfig.log
     
  3. frosch95

    frosch95 New Member

    Folgende Fehlermeldung kommt:

    11.12.2008 - 16:42:13 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1265: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
    11.12.2008 - 16:42:14 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2601: WARNING: could not . /etc/apache2/envvars && httpd -t &> /dev/null
    11.12.2008 - 16:42:14 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2615: httpd syntax seems to contain errors, reloading with old configuration
    11.12.2008 - 16:42:14 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2616: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf_11-12-08_16-42-14
    11.12.2008 - 16:42:14 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2617: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf~ /etc/apache2/vhosts/Vhosts_ispconfig.conf

    Die Datei envvars ist vorhanden, aber bis auf Kommentare ist die leer. liegt es daran? Oder ist der Aufruf falsch?

    Ich habe ein Ubuntu 6.06 als System.

    Vielen Dank,
    Andi
     
  4. frosch95

    frosch95 New Member

    Hat sich erledigt, in den Apache Direktiven eines anderen Webs war ein Fehler.

    Danke!
     

Diese Seite empfehlen