Alle Domains zeigen auf eine aktivierte SSL Domain

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von daniel.weber, 13. Nov. 2014.

  1. daniel.weber

    daniel.weber New Member

    Hallo zusammen,

    habe seit einigen Tagen folgendes Phänomen:
    Kunde A aktiviert in seiner Webseite SSL, vorher wird ein entsprechendes SSL-Zertifikat erstellt. Klappt soweit alles ganz gut.
    Nun hat Kunde B eine Webseite bei der SSL nicht aktiviert ist, ruft Kunde B diese Webseite via https... auf verweist diese auf die Webseite von Kunde A.

    Was läuft hier falsch?
    Grüße
    Daniel
     
  2. Till

    Till Administrator

    Ein Webserver verhält sich wie folgt: wenn kein passender vhost (domain, port, IP) Kombination gefunden wird, dann wird der erste vhost angezeigt den er auf dem Port findet. Hast Du also Webseite a und b auf einer IP und a hat ssl, b aber nicht, dann existiert b nicht auf port 443 und es muss a angezeigt werden.

    Es gibt folgende Lösungen:

    1) Alle Webseiten ohne SSL nutzen eine IP, alle Webseiten mit SSL eine andere. Es gibt auf der 2. IP also keine websites ohne ssl, daher wird immer die korrekte Seite angezeigt.

    2) Jede Webseite hat eine eigene IP.

    3) Du legst einen SSL default vhost an, der alle diese "Irrläufer" auffängt. Das geht so:

    neue Webseite anlegen, als domain nimmst du "000default.tld" und Du aktivierst SSL und erzeugst ein SSL Zertifikat. Die Domain muss nicht im DNS existieren, sie muss nur garantiert im Alphabet vor allen anderen Domains auf dem Server kommen. In diese neue Website legst Du eine index.html Datei mit einer Info, dass die Gesuchte Seite nicht existiert oder etwas ähnliches.
     
  3. daniel.weber

    daniel.weber New Member

    Hallo Till,
    wieder mal ein großes Dankeschön an dich. Lösung 3 war genau die Richtige für mich.
    Gruß
    Daniel
     

Diese Seite empfehlen