AllowOverride All

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von hahni, 21. März 2008.

  1. hahni

    hahni Active Member

    Kann man "AllowOverride AuthConfig" auch für einen einzelnen virtuellen Host in "AllowOverride All" umwandeln, ohne die Konfiguration antasten zu müssen? Wenn ja: wie?
     
  2. o.meyer

    o.meyer Moderator

    Hi hahni,

    jup, das geht in der VHost Konfiguration - hier mal vereinfacht dargestellt:

    Code:
    <VirtualHost 192.168.0.100:80>
    
        ServerName server1.example.com
        ServerAdmin admin@example.com
        DocumentRoot /pfad/zum/document/root
    
        <Directory /pfad/zum/verzeichnis>
    
            AllowOverride All
    
        </Directory>
    
    </VirtualHost>
    Grüße,

    Olli
     
    Zuletzt bearbeitet: 21. März 2008
  3. hahni

    hahni Active Member

    hallo olli,

    aber die virtuellen hosts werden ja immer von isp-config geschrieben! wenn ich jetzt in den config-files rumfummle: bleiben die dann erhalten?

    viele grüße

    hahni
     
  4. Till

    Till Administrator

    Du musst das einfach nur in das Apache direktiven Feld der Webseite einfügen.
     
  5. hahni

    hahni Active Member

    Wo denn das? In der .htaccess?
     
  6. Till

    Till Administrator

    In ISPConfig.
     
  7. hahni

    hahni Active Member

    Das klingt sehr gut! Aber wo kann ich das für den virtuellen Host ändern in ISPConfig? Und was muss genau syntaktisch reingeschrieben werden?
     
  8. hahni

    hahni Active Member

    Wenn ich es direkt auf dem ersten Reiter der betreffenden Webpräsenz eintrage (einfach nur "AllowOverride All"), dann tut sich nix.

    Es geht hier um den Magento Commerce Shop, bei dem das angeblich aktiviert sein muss. Es kommt immer ein "Internal Server Error" :confused:
     
  9. Till

    Till Administrator

    In das apache Direktiven Feld.

    das hängt vom jeweiligen Web und Deiner Serverkonfiguration ab.

    <Directory /pfad/zum/verzeichnis>
    AllowOverride All
    </Directory>

    Generell ist es das obige, Du musst halt nur den Pfad anpassen.
     
  10. hahni

    hahni Active Member

    Huhu Till,

    ein sehr guter Tipp!
    Allerdings habe ich folgende Systemkonfiguration:
    Apache/2.0.55 (Ubuntu) PHP/5.1.2 mod_ssl/2.0.55 OpenSSL/0.9.8a

    Erfordert wird für Magento aber 5.2.0 oder höher. Besteht da eine sinnvolle Möglichkeit, so zu aktualisieren, dass alle Abhängigkeiten weiterhin funktionieren und die Update-Ports auch funktionieren?

    Viele Grüße

    Hahni
     
  11. hahni

    hahni Active Member

    Wäre es möglich, bei einer php 5.1 installation als benutzer folgendes zu hinterlegen, um ein php-cgi 5.2 zum laufen zu bekommen:

    ---
    Action php5-cgi /cgi-bin/php5-cgi
    AddHandler php5
    -cgi .php
    ---
     
  12. Till

    Till Administrator

    Als Admin ja, als Benutzer nein.
     
  13. hahni

    hahni Active Member

    Und wo muss ich es dann als Admin hinterlegen? Auch im Direktivefeld der Webpräsenz?
     
  14. Till

    Till Administrator

    Ja. Alle apache Direktiven müssen dort hinterlegt werden, wenn Sie von ISPConfig in die Vhost Konfiguration eingebunden werden sollen.
     
  15. hahni

    hahni Active Member

    so?

    ---
    <Directory /pfad/zum/verzeichnis>
    AllowOverride All
    Action php5-cgi /cgi-bin/php5-cgi
    AddHandler php5
    -cgi .php
    </Directory>
    ---
     
  16. Till

    Till Administrator

    Nein. Die Zeilen Action und Addhabdler müssen außerhalb der Directory Direktive stehhen. Schau mal in die apache Doku, da steht für alle Direktiven drin, ob sie innerhalb des vhosts oder innerhalb einer Directory Direktive stehen müssen.
     
  17. hahni

    hahni Active Member

    ---
    <Directory /pfad/zum/verzeichnis>
    AllowOverride All
    </Directory>

    Action php5-cgi /cgi-bin/php5-cgi
    AddHandler php5
    -cgi .php
    ---

    Also so?
     
  18. hahni

    hahni Active Member

    wenn ich es so einfüge wie üben beschrieben (mit relativen und absoluten pfaden), geht bei magento auch nix! die action-handler scheint er nicht zu erkennen! wenn ich magento zum laufen bekomme, ist eigentlich ein howto dafür erforderlich ;)
     
  19. hahni

    hahni Active Member

    da im log der webpräsenz immer der fehler

    ---
    [Wed Mar 26 20:14:30 2008] [alert] [client 91.67.128.29] /var/www/web82/web/.htaccess: Invalid command 'Action', perhaps mis-spelled or defined by a module not included in the server configuration
    ---

    steht, kann schon mal folgender eintrag in der .htaccess auch nicht stimmen:

    ---
    Action php5-cgi /cgi-bin/php5-cgi
    AddHandler php5-cgi .php
    ---

    oder möglicherweise nicht die direktive, die ich für das web festgelegt habe? magento ist echt haarig :mad:
     
  20. hahni

    hahni Active Member

    <Directory /var/www/web82/cgi-bin/>
    Options ExecCGI
    AllowOverride None
    </Directory>

    bringt auch nix!
     

Diese Seite empfehlen