Anmeldung per ssl

#1
Hallo,

ich habe das Problem, dass bei meinem ISPConfig v3 die Anmeldung mit ssl und Port 81 nicht funktioniert. Das sehe ich ein, ich habe den Port auch nie irgendwo angegeben, und schätze, dass sich die Hinweise, die man im Forum findet auf Version 2 beziehen.

Weiters funktioniert auch https://www.ereuter.at:8080 nicht. Da wird das Zertifikat nicht richtig geladen(Fehlercode: ssl_error_rx_record_too_long).

Die Domain habe ich keinem Kunden zugewiesen, damit er das
Unter https://www.ereuter.at/ispconfig funktioniert es wunderbar und es wird das Zertifikat aus /etc/ssl/... genommen - Ich habe es in /etc/apache2/sites-enabled/default-ssl verlinkt und entsprechend angepasst.

Jetzt wollte ich wissen, ob es sinnvoll ist, das so zu machen, oder ob das ein Problem sein könnte. Schließlich muss es doch einen Grund haben, warum ISPConfig standardmäßig auf einem eigenen Port läuft.

Beste Grüße

Elisabeth
 

Till

Administrator
#2
Weiters funktioniert auch https://www.ereuter.at:8080 nicht. Da wird das Zertifikat nicht richtig geladen(Fehlercode: ssl_error_rx_record_too_long).
Das ist auch ganz normal, es gibt garkeinen SSL vhost für port 8080.

Die Domain habe ich keinem Kunden zugewiesen, damit er das
Unter https://www.ereuter.at/ispconfig funktioniert es wunderbar und es wird das Zertifikat aus /etc/ssl/... genommen - Ich habe es in /etc/apache2/sites-enabled/default-ssl verlinkt und entsprechend angepasst.

Jetzt wollte ich wissen, ob es sinnvoll ist, das so zu machen, oder ob das ein Problem sein könnte. Schließlich muss es doch einen Grund haben, warum ISPConfig standardmäßig auf einem eigenen Port läuft.
Das sollte man aus Sicherheitsgründen nicht so machen. Jetzt läuft ISPConfig nämlich zusammen mit diversen anderen Webanwendungen in einem vhost und wenn in einer der Anwendungen ein Sicherheitsproblem auftritt wie z.B. zuletzt bei phpmyadmin dann würde der Angreifer auch Zugriff auf die Serverkonfiguration erhalten und könnte sich möglciherweise darüber root Rechte aneignen.
 

Werbung