apache 2.2.3 / mod_proxy / mod_proxy_balancer

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von modern, 12. Nov. 2008.

  1. modern

    modern New Member

    Hallo,

    ich versuche grade einen Balancer (siehe Howto) einzurichten:

    Hier die Mod Rewrite Konfiguration auf dem einen Webserver:

    Code:
    RewriteEngine On
            RewriteRule .* - [CO=SESSIONID:balancer.http1:123.456.789.1/unterverzeichnis]
    
    (damit Sessions richtig gehandet werden)

    Hier die Konfiguration des Proxyservers:

    Code:
     
    #######################
    #######################
    # Hier nun die neue Konfiguration für den Balancer:
    # Initial Config 09.11.2008
    #
    <Proxy 123.456.789.3:80>
             Order deny,allow
           Allow from all
    </Proxy>
    
    ProxyPass /balancer-manager !
    [U]ProxyPass / balancer://nlb/ stickysession=SESSIONID nofailover=on[/U]
    ProxyPassReverse / http://123.456.789.1/unterverzeichnis/
    ProxyPassReverse / http://123.456.789.2/unterverzeichnis/
    
    <Proxy balancer://nlb>
      BalancerMember http://123.456.789.1/unterverzeichnis route=http1
      BalancerMember http://123.456.789.2/unterverzeichnis route=http2
      ProxySet lbmethod=byrequests
    </Proxy>
    
           <Location /balancer-manager>
             SetHandler balancer-manager
             Order deny,allow
             Allow from all
           </Location>
    
    
    ########################
    ########################
     
    
    Ich erhalte folgende Fehlermeldung:

    Code:
     
    www2:~# apache2ctl restart
    Syntax error on line 26 of /etc/apache2/sites-enabled/vhost.de.conf:
    ProxyPass Can't find 'byrequests' lb method
    www2:~#
     
    
    Das ist die unterstrichen dargestellte Zeile.

    Jemand eine Idee?

    Viele Grüße

    modern
     
  2. Till

    Till Administrator

    Das Apache Modul: mod_proxy_balancer ist nicht geladen.
     
  3. modern

    modern New Member

    Hallo Till,

    Code:
     
    www-wall:~# a2enmod proxy_balancer
    This module is already enabled!
    www-wall:~#
     
    
    anscheined schon.

    Viele Grüße

    modern
     
    Zuletzt bearbeitet: 13. Nov. 2008
  4. Till

    Till Administrator

    Laut der Apache Fehlermeldung aber scheinbar nicht. Sie Dir bitte mal die Dateien im mods-enabled Verzeichnis an, ob der wirklich geladen wird und ob da auch nichts auskommentiert ist.
     
  5. modern

    modern New Member

    Hallo Till,

    es war zwar aktiv, aber in der mod_proxy_balancer.load auskommentiert. :eek:

    ...

    Ok, jetzt klappt es!

    Nur der Balancer Manager zeigt nichts an:

    Code:
     
    [B]Load Balancer Manager for Server.blabla.de[/B]
    
    Server Version: Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c Server Built: Sep 6 2008 09:52:20 
    Viele Grüße
     
  6. modern

    modern New Member

    Wenn ich den Balancer Manager in den Virtual Host Container
    reinschreibe:

    Code:
     
    [B]Forbidden[/B]
    
    You don't have permission to access /balancer-manager on this server.
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
     
    
    nehme ich das im Default Host mit auf, bleibt der Balancer Manager leer.

    Woran könnte das liegen?

    Viele Grüße

    modern
     
  7. modern

    modern New Member

    Hallo,

    falls mal jemand das gleiche Problem hat:

    Der Eintrag des Balancer Manger funktioniert nur, wenn er im selber
    VHost Container steht.

    Viele Grüße

    Eicke
     

Diese Seite empfehlen