Apache auf richtigen Unterordner zeigen lassen??

Dieses Thema im Forum "Server Administration" wurde erstellt von zedriq, 31. Aug. 2010.

  1. zedriq

    zedriq New Member

    Hallo zusammen,

    irgendwie schaffe ich es nicht auf den richtigen Unterordner zu verweisen. Der Apache ist installiert und bei Eingabe der IP zeigt er auch das obligatorische It works! an, welches bekanntlicherweise in Form einer index.html im Unterordner /usr/share/apache2/default-site liegt.

    Die anzusprechende Webseite liegt aber im Unterordner /home/test/v2.

    Wo muss ich dies nun konfigurieren, damit ich bei Eingabe der IP/Alias auf automatisch auf dieses Unterverzeichnis verweise.

    Dazu noch eine Frage am Rande: Die Webseite basiert auf Nuke 7.8. Muss ich in Nuke auch etwas einstellen, damit Nuke weiss, in welchem Unterordner (und abwärts) es sich bewegen muss?

    Bitte um Hilfe, da ich echt nicht weiterkomme. :(
     
  2. csiebert

    csiebert Member

    hast du denn schon einen vhost dafür angelegt?
     
  3. zedriq

    zedriq New Member

    hmm...stelle die frage hier nur in vertretung, daher kann ich nicht sagen ob oder ob nicht... :rolleyes:

    sorry for that.

    gehen wir mal davon aus, dass nicht...

    wie/wo legt man diesen denn an?

    lg, zed
     
  4. csiebert

    csiebert Member

    ausgehend davon, dass du kein ispconfig verwendest, legst du sie in dem ordner an, in dem deine apache-konfig sie erwartet. bei debian ist das /etc/apache2/sites-available

    nimm dir einfach die konfiguration default und passe sie deinen bedürfnissen an. anschließend einen symlink im ordner /etc/apache2/sites-enabled erstellen, a2ensite vhost erledigt dies automatisch für dich. anschließend /etc/init.d/apache2 reload ausführen, und schon läufts...

    gruß, chris
     
  5. zedriq

    zedriq New Member

    danke vielmals! :)
    das klingt schonmal vielversprechend und leite ich erstmal so weiter.

    ich melde mich bei bedarf wieder.

    lg, zed
     
  6. zedriq

    zedriq New Member

    Nach längerer Zeit haben wir endlich mal Zeit finden können, und der Angelegenheit annehmen zu können. Leider funktioniert es immer noch nicht. :rolleyes:

    Scheinbar liegt es an einem Aufruf in der mainfile.php, wobei ich mir nicht vorstellen kann, warum es auf dem bestehenden Server mit demselben Aufruf funktionieren sollte... :mad:

    Code:
    if (defined('FORUM_ADMIN')) {
        require_once("../../../config.php");
        require_once("../../../db/db.php");
    } elseif (defined('INSIDE_MOD')) {
        require_once("../../config.php");
        require_once("../../db/db.php");
    } else {
        require_once("config.php"); 
        require_once("db/db.php");
        /* FOLLOWING TWO LINES ARE DEPRECATED BUT ARE HERE FOR OLD MODULES COMPATIBILITY */
        /* PLEASE START USING THE NEW SQL ABSTRACTION LAYER. SEE MODULES DOC FOR DETAILS */
        require_once("includes/sql_layer.php");
        $dbi = sql_connect($dbhost, $dbuname, $dbpass, $dbname);
    }
    in der folgenden Zeile bricht er aus unerfindlichen Gründen einfach ab.

    Code:
        require_once("db/db.php");
    Leider stehen wir grad (auch wahrscheinlich der Uhrzeit wegen) auf dem Schlauch.

    Hier der Link:
    http://109.230.210.240/index.php

    Kann sich hier jemand vorstellen, woran es liegen mag?? :confused:
     
    Zuletzt bearbeitet: 21. Okt. 2010
  7. F4RR3LL

    F4RR3LL Member

    Wie schaut denn die entsprechende vhost config aus ?
     
  8. zedriq

    zedriq New Member

    aktuelle vhost config

    hier die aktuelle vhost config:

    Code:
    <VirtualHost *:80>
        ServerAdmin webmaster@localhost
        
        DocumentRoot /home/epiacenterde/v2/
        <Directory />
            Options FollowSymLinks
            AllowOverride None
        </Directory>
        <Directory /home/epiacenterde/v2/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
        </Directory>
    
        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
            AllowOverride None
            Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow,deny
            Allow from all
        </Directory>
    
        ErrorLog /var/log/apache2/error.log
    
        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn
    
        CustomLog /var/log/apache2/access.log combined
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    </VirtualHost>
     
  9. csiebert

    csiebert Member

    und nem auszug aus dem fehlerlog?
     
  10. zedriq

    zedriq New Member

    ist angehängt. ;)

    habe auf die schnelle die komplette genommen. obiger status quo betrifft aber nur die letzten beiden tage. ;)
     

    Anhänge:

  11. zedriq

    zedriq New Member

    hier jetzt mal der auszug der letzten 4 tage...
     

    Anhänge:

  12. zedriq

    zedriq New Member

    hat denn keiner ne idee?? :confused:
     
  13. zedriq

    zedriq New Member

    :( ...wir kommen hier einfach nicht weiter. PLZ, würde mich schon prostituieren, um an Hints oder Tipps zu kommen... :eek::(:eek:
     
  14. zedriq

    zedriq New Member

    Ein Kollege hat parallel mal ein frisches Nuke aufgesetzt und siehe da, es funktioniert...

    http://109.230.210.240/html/

    Noch nochmaligem Umkonfigurieren wird nun schonmal der Seitentitel und das Background angezeigt, aber dann bricht es wieder ab.

    http://109.230.210.240/v2/

    Momentan wissen wir wieder nicht, woran es liegen mag, aber ich habe das log von heute nochmal angehängt.

    Hier der Inhalt der Datei 000-default aus dem Ordner sites-enabled

    Code:
    <VirtualHost *:80>
        ServerAdmin webmaster@localhost
        
        DocumentRoot /var/www/
        <Directory />
            Options FollowSymLinks
            AllowOverride None
        </Directory>
        <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
        </Directory>
    
        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
            AllowOverride None
            Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow,deny
            Allow from all
        </Directory>
    
        ErrorLog /var/log/apache2/error.log
    
        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn
    
        CustomLog /var/log/apache2/access.log combined
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    </VirtualHost>
    
    EDIT:

    Habe irgendwie das Gefühl, dass es an dem tinyMCE liegt. Ggf. müsste der mal komplett auskommentiert werden, da der sowieso nicht mehr in Verwendung ist. :/ :?
    Kann mir einer sagen, in welcher Datei, der eingebaut wird? Hab mich gerade schon totgesucht... X(

    Muss ja iwo in der Head Anweisung sein, wenn man sich den Quelltext anschaut, den man jetzt schon ausgegeben bekommt. Nur wo genau?? :rolleyes:
     

    Anhänge:

    Zuletzt bearbeitet: 31. Okt. 2010

Diese Seite empfehlen