apache down nach ssl Erstellung in ISPConfig

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von isp, 27. Jan. 2012.

  1. isp

    isp New Member

    Hi,

    ich habe ISPConfig ganz neu installiert nach der Anleitung hier. Jetzt wollte ich für eine Webseite ein SSL Zertifikate über ISPConfig erstellen und dadurch ist der apache abgestürzt und lässt sich auch nicht mehr starten (ich weiß nicht mehr weiter).

    Hier ist das apache error log file:

    [Sun Jan 22 06:25:02 2012] [notice] Digest: generating secret for digest authentication ...
    [Sun Jan 22 06:25:02 2012] [notice] Digest: done
    [Sun Jan 22 06:25:02 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Sun Jan 22 06:25:02 2012] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze3 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o config$
    [Sun Jan 22 06:25:02 2012] [warn] long lost child came home! (pid 22857)
    [Mon Jan 23 02:09:52 2012] [error] [client ##.##.1.##] client denied by server configuration: /etc/apache2/htdocs
    [Mon Jan 23 02:09:53 2012] [error] [client ##.##.1.##] client denied by server configuration: /etc/apache2/htdocs
    [Mon Jan 23 02:09:54 2012] [error] [client ##.##.1.##] client denied by server configuration: /etc/apache2/htdocs
    [Mon Jan 23 02:09:55 2012] [error] [client ##.##.1.##] client denied by server configuration: /etc/apache2/htdocs
    [Mon Jan 23 02:09:56 2012] [error] [client ##.##.1.##] client denied by server configuration: /etc/apache2/htdocs
    [Mon Jan 23 02:09:57 2012] [error] [client ##.##.1.##] client denied by server configuration: /etc/apache2/htdocs
    [Mon Jan 23 09:18:26 2012] [error] [client ##.99.##.##] client denied by server configuration: /etc/apache2/htdocs
    [Mon Jan 23 09:20:02 2012] [notice] caught SIGTERM, shutting down
    [Mon Jan 23 09:20:02 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jan 23 09:20:02 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Jan 23 09:20:02 2012] [notice] Digest: generating secret for digest authentication ...
    [Mon Jan 23 09:20:02 2012] [notice] Digest: done
    [Mon Jan 23 09:20:03 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jan 23 09:20:03 2012] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze3 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o config$
    [Mon Jan 23 09:22:02 2012] [notice] caught SIGTERM, shutting down
    [Mon Jan 23 09:22:03 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jan 23 09:22:03 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Jan 23 09:22:03 2012] [notice] Digest: generating secret for digest authentication ...
    [Mon Jan 23 09:22:03 2012] [notice] Digest: done
    [Mon Jan 23 09:22:03 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jan 23 09:22:03 2012] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze3 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o config$
    [Mon Jan 23 09:25:59 2012] [error] [client ##.99.##.##] client denied by server configuration: /etc/apache2/htdocs
    [Mon Jan 23 09:26:01 2012] [notice] caught SIGTERM, shutting down
    [Mon Jan 23 09:26:02 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jan 23 09:26:02 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Jan 23 09:26:02 2012] [notice] Digest: generating secret for digest authentication ...
    [Mon Jan 23 09:26:02 2012] [notice] Digest: done
    [Mon Jan 23 09:26:02 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jan 23 09:26:02 2012] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze3 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o config$
    [Mon Jan 23 09:26:04 2012] [notice] caught SIGTERM, shutting down
    [Mon Jan 23 09:26:07 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jan 23 09:26:07 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Jan 23 09:26:07 2012] [notice] Digest: generating secret for digest authentication ...
    [Mon Jan 23 09:26:07 2012] [notice] Digest: done
    [Mon Jan 23 09:26:07 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jan 23 09:26:07 2012] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze3 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o config$
    [Mon Jan 23 09:26:08 2012] [error] [client ##.99.##.##] client denied by server configuration: /etc/apache2/htdocs
    [Mon Jan 23 09:26:12 2012] [error] [client ##.99.##.##] client denied by server configuration: /etc/apache2/htdocs
    [Mon Jan 23 09:31:01 2012] [notice] caught SIGTERM, shutting down
    [Mon Jan 23 09:31:02 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jan 23 09:31:02 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)

    Danke für eure Hilfe :(
     
  2. Till

    Till Administrator

    Wahrscheinlich ist das ssl Zertifikat das openssl erstellt hat nicht in Ordnung, das kann passieren wenn Du Umlaute oder ähnliches für das Zertifikat verwendest.

    Um Das Problem zu beheben üffnest Du die vhost Datei der Webseite für welche Du das SSL Zertifikat erstellt hast und kommentierst die SSL Zeilen die auf das Zertifikat und den Key verweisen aus. Dann Startest Du apache neu und erstellst in ISPConfig einneues SSL cert.
     
  3. isp

    isp New Member

    kurze Frage -> wo finde ich die vhost Datei(en)?

    Ich komme gerade nicht mehr auf den Pfad.
     
  4. Till

    Till Administrator

    /etc/apache2/sites-enabled/ bei Debian und Ubuntu, bei centos ist es /etc/httpd/.....
     
  5. isp

    isp New Member

    Ich habe das mal so in der Datei vom user auskommentiert und leider startet apache nicht neu. Habe ich etwas übersehen?

    #<IfModule mod_ssl.c>
    #SSLEngine on
    #SSLCertificateFile /var/www/clients/client1/web1/ssl/xxx.de.crt
    #SSLCertificateKeyFile /var/www/clients/client1/web1/ssl/xxx.de.key
    #</IfModule>
     
  6. Till

    Till Administrator

    Lösche mal die komplette vhost datei im sites-enabled Ordner, dann start apache, logge idhc in ispconfig ein und deaktivier ssl für diese webseite und klick auf speichern.
     
  7. isp

    isp New Member

    super .. jetzt geht es wieder - konnte apache wieder hochfahren .. jetzt kann ich allerdings nicht mehr die Webseiten aufrufen, weil denke ich mal die vhost fehlt ... wie kann ich die wieder erzeugen?

    also ispconfig kann ich schon aufrufen, nur die webseite des users geht nicht
     
    Zuletzt bearbeitet: 17. Apr. 2012
  8. Till

    Till Administrator

    Hab ich in meinem Post oben beschrieben: logge Dich in ispconfig ein, deaktivier ssl in der webseite und klicke aud´f speichern.
     
  9. isp

    isp New Member

    Danke für die Hilfe..habe ich ja gemacht... die Seiten kann ich trotzdem nicht aufrufen -> The requested URL /xxx was not found on this server.
     
  10. isp

    isp New Member

    Danke Till -> jetzt geht es
     

Diese Seite empfehlen