Apache Fehler 500 nach Upgrade auf Version: 2.2.35

#1
Hallo,

Gestern habe ich von ispconfig version 2.2.33 auf die 2.2.35 aktualisiert und seitdem gibt es Probleme mit dem Ausfuehren von PHP-Skripten. SuPHP wurde wie nach Anleitung installiert und funktionierte vorher auch wunderbar. Jetzt erhalte ich:

[Wed Mar 31 11:10:32 2010] [error] [client 209.85.238.215] SecurityException in Application.cpp:511: Unknown Interpreter: php
[Wed Mar 31 11:10:32 2010] [error] [client 209.85.238.215] Premature end of script headers: index.php

Woran kann das liegen? Die suphp.conf wurde auch nicht veraendert. Ich verweise weiterhin auf das Wrapper-Script von Ispconfig:

[handlers]
;Handler for php-scripts
x-httpd-php=php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper

Danke im Voraus!
 
#3
Die suphp.conf im Setup-Verzeichnis ist fehlerhaft. Es waere klasse, wenn wie in der naechsten ispconfig Version die Anfuehrungszeichen enthalten wuerde.

Danke.
 

Till

Administrator
#4
Fehlerhaft ist sie nicht unbedingt, sie ist nur nicht mit der von Dir verwendeten suphp Version kompatibel. Das suphp Projekt hat die Syntax Ihrer Config Dateien geändert, die Datei die ispconfig aktuell mitliefert ist kompatibel zu älteren suphp Versionen.
 
#5
Da aus Sicherheitsgruenden immer die aktuelle suPHP version installiert sein sollte, waere es fuer viele Anwender hilfreich, wenn das geaendert werden wuerde. Falls dies keine Option ist, dann sollte entweder ein Check durchgefuehrt werden, welche suPHP Version installiert ist und die richtige Konfigurationsdatei kopiert werden oder das automatische Kopieren garnicht nicht stattfinden. Der aktuelle Zustand verlangt von Jedem, der eine neuere Version einsetzt, sich zu merken, dass das Backup der Datei zurueckgespielt werden muss. Zugegeben ist dies keine elegante Variante.

Es waere klasse, wenn hier der optimale Weg fuer alle gefunden werden koennte.
 
#6
Dem kann ich mich nur anschliessen. Ich hab zwar inzwischen wieder auf die ältere version gewechselt.
In einem Test hab ich festgestellt, dass die alte Version auch mit den Anführungszeichen funktioniert, also stünde meiner Ansicht nach einer Änderung in der Config nichts im Weg...
 
#7
Till, waere eine Anpassung fuer die naechste Version moeglich? So wie es sich anhoert, sollten aeltere suPHP-Versionen auch wunderbar mit der neuen Version der Konfigurationsdatei zurechtkommen.

Danke.
 
#9
Wohl eine dumme Frage, aber wo finde ich den Bug-Tracker? Im Forum finde ich nichts ausser Feature-Requests und auf der Website steht auch nichts davon. Ein Link waere toll.
 
#11
Fuer die eine Fehlermeldung moechte ich jetzt nicht extra einen Account im Bugtracker anlegen. Till, koenntest du denn den Eintrag kurz vornehmen. Ich waere sehr dankbar!
 

Werbung

Top