Apache läuft nicht (mehr)

#1
Hi. Habe nach dem Der perfekte Server - Debian Etch (4.0) Tut alles gemacht, Apache lief bis Punkt 13 bis Listen 443 -> dan irgendwie nicht mehr, keine ahnung warum :( ispconfig ist (noch) nicht drauf. bekommen folgende fehlermeldung:
Code:
Debian-50-lenny-32-minimal:~# /etc/init.d/apache2 restart
Restarting web server: apache2apache2: Could not reliably determine the server's fully qualified domain name, using 29.382.38.123 for ServerName
apache2: Could not reliably determine the server's fully qualified domain name, using 29.382.38.123 for ServerName
(98)Address already in use: make_sock: could not bind to address [::]:443
.
Debian-50-lenny-32-mini
falls ich logs posten soll, bitte sagen welche genau.
os: debian lenny 32 bit

danke

PS: liegt mit sicherheit nicht an meinen ip adressen die ich zusätzlich kofig. habe, als apache lief waren die websites auf den ip*s nehmlich erreichbar -> it's works! kam^...
 
#4
ich poste einfach mal alles der datie /etc/apache2/sites-enabled/000-default:

Code:
<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    
    DocumentRoot /var/www/
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
in der /var/log/apache2/error.log steht:

Code:
[Sat Feb 21 21:57:47 2009] [notice] child pid 16314 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16315 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16316 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16317 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16318 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16319 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16320 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16321 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16322 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16323 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16324 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:47 2009] [notice] child pid 16325 exit signal Segmentation fault (11)
[Sat Feb 21 21:57:52 2009] [warn] child process 16376 still did not exit, sending a SIGTERM
[Sat Feb 21 21:57:54 2009] [warn] child process 16376 still did not exit, sending a SIGTERM
[Sat Feb 21 21:57:56 2009] [warn] child process 16376 still did not exit, sending a SIGTERM
[Sat Feb 21 21:57:58 2009] [error] child process 16376 still did not exit, sending a SIGKILL
[Sat Feb 21 21:57:59 2009] [notice] caught SIGTERM, shutting down
und in der /var/log/apache2/access.log das:

Code:
::1 - - [21/Feb/2009:21:48:04 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:48:04 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:48:04 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:48:04 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:48:04 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
193.138.231.255 - - [21/Feb/2009:21:48:25 +0100] "GET / HTTP/1.1" 200 56 "-" "Internet Explorer"
193.138.231.255 - - [21/Feb/2009:21:48:25 +0100] "GET /favicon.ico HTTP/1.1" 404 237 "-" "Internet Explorer"
193.138.231.255 - - [21/Feb/2009:21:49:42 +0100] "GET /favicon.ico HTTP/1.1" 404 237 "-" "Internet Explorer"
193.138.231.255 - - [21/Feb/2009:21:49:48 +0100] "GET /favicon.ico HTTP/1.1" 404 237 "-" "Internet Explorer"
193.138.231.255 - - [21/Feb/2009:21:50:07 +0100] "GET / HTTP/1.1" 200 56 "-" "Internet Explorer"
193.138.231.255 - - [21/Feb/2009:21:50:07 +0100] "GET /favicon.ico HTTP/1.1" 404 246 "-" "Internet Explorer"
193.138.231.255 - - [21/Feb/2009:21:50:07 +0100] "GET /favicon.ico HTTP/1.1" 404 246 "-" "Internet Explorer"
193.138.231.255 - - [21/Feb/2009:21:50:18 +0100] "GET / HTTP/1.1" 200 56 "-" "Internet Explorer"
193.138.231.255 - - [21/Feb/2009:21:50:19 +0100] "GET /favicon.ico HTTP/1.1" 404 239 "-" "Internet Explorer"
193.138.231.255 - - [21/Feb/2009:21:50:28 +0100] "GET /favicon.ico HTTP/1.1" 404 237 "-" "Internet Explorer"
::1 - - [21/Feb/2009:21:50:50 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:50:50 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:50:50 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:50:50 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:50:50 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:50:50 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:50:50 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:55:29 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:55:29 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:55:29 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:55:29 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:55:29 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:55:30 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) (internal dummy connection)"
::1 - - [21/Feb/2009:21:56:18 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny2 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g (internal dummy connection)"
::1 - - [21/Feb/2009:21:56:33 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny2 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g (internal dummy connection)"
::1 - - [21/Feb/2009:21:57:16 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny2 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g (internal dummy connection)"
 
#7
Code:
Debian-50-lenny-32-minimal:/# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:mysql                 *:*                     LISTEN      2289/mysqld
tcp        0      0 *:sunrpc                *:*                     LISTEN      1905/portmap
tcp        0      0 *:ftp                   *:*                     LISTEN      2629/proftpd: (acce
tcp        0      0 static.XXX.XXX.X:domain *:*                     LISTEN      2185/named
tcp        0      0 static.XXX.XXX.X:domain *:*                     LISTEN      2185/named
tcp        0      0 static.XXX.XXX.X:domain *:*                     LISTEN      2185/named
tcp        0      0 static.XXX.XXX.X:domain *:*                     LISTEN      2185/named
tcp        0      0 static.XXX.XXX.X:domain *:*                     LISTEN      2185/named
tcp        0      0 name.site.xx:domain *:*                         LISTEN      2185/named
tcp        0      0 Debian-50-lenny-:domain *:*                     LISTEN      2185/named
tcp        0      0 localhost:domain        *:*                     LISTEN      2185/named
tcp        0      0 *:smtp                  *:*                     LISTEN      2588/master
tcp        0      0 localhost:953           *:*                     LISTEN      2185/named
tcp        0      0 *:65181                 *:*                     LISTEN      2200/sshd
tcp        0      0 Debian-50-lenny-3:65181 ----------------- ESTABLISHED 2766/sshd: -@not
tcp        0    300 Debian-50-lenny-3:65181 ----------------- ESTABLISHED 2769/sshd: -
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      2504/couriertcpd
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      2522/couriertcpd
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      2510/couriertcpd
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      2492/couriertcpd
tcp6       0      0 [::]:domain             [::]:*                  LISTEN      2185/named
tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      2588/master
tcp6       0      0 ip6-localhost:953       [::]:*                  LISTEN      2185/named
tcp6       0      0 [::]:65181              [::]:*                  LISTEN      2200/sshd
Debian-50-lenny-32-minimal:/#
Bemerkung: habe es auch welchen gründen auch immer nicht geschafft beim tutorial folgende sachen zu installieren (liegt wahrscheinlich daran das bei lenny nicht in der sourlist ist oder warum auch immer...)

saslauthd
(falls ich weiteres festelle kommt hier hin)
 
#9
Kann es sein, das die suche von howtoforge.de und von howtoforge.com nicht syncronisiert wird?! Weil ich hab auf .de nach debian gesucht und dies nicht gefunden... aber es lief ja, einen kurzen schönen moment xD ich installiere es eben mal neu. thx.
 
#11
Es wäre aber gut (fuer solche personen wie mich) wenn ein hinweis angezeigt wird das man es auf .com versuchen soll. aber jetzt bin ich ja informiert.
 

Werbung

Top