Apache startet nach Versuch mit einem SSL Zertifikat

Dieses Thema im Forum "Server Administration" wurde erstellt von Falcon37, 14. Jan. 2010.

  1. Falcon37

    Falcon37 New Member

    Hi, habe mir gerade ein ungültiges SSL Zertifikat erstellt und es ins ISPConfig 3 Panel eingetragen. Nun startet Apache aber nicht mehr?!

    Code:
    Restarting web server: apache2[Thu Jan 14 21:54:24 2010] [warn] module evasive20_module is already loaded, skipping
    [Thu Jan 14 21:54:24 2010] [warn] NameVirtualHost 192.000.0002:443 has no VirtualHosts
    [Thu Jan 14 21:54:24 2010] [warn] NameVirtualHost 192.000.0003:80 has no VirtualHosts
    [Thu Jan 14 21:54:24 2010] [warn] NameVirtualHost 192.000.0004:443 has no VirtualHosts
    [Thu Jan 14 21:54:24 2010] [warn] NameVirtualHost 192.000.0005:443 has no VirtualHosts
    [Thu Jan 14 21:54:24 2010] [warn] module evasive20_module is already loaded, skipping
    [Thu Jan 14 21:54:24 2010] [warn] NameVirtualHost 192.000.0002:443 has no VirtualHosts
    [Thu Jan 14 21:54:24 2010] [warn] NameVirtualHost 192.000.0003:80 has no VirtualHosts
    [Thu Jan 14 21:54:24 2010] [warn] NameVirtualHost 192.000.0004:443 has no VirtualHosts
    [Thu Jan 14 21:54:24 2010] [warn] NameVirtualHost 192.000.0005:443 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:80
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
     failed!
    Jemand eine Idee was ich da falsch gemacht habe? Wollte eigentlich nur eine gesicherte Verbindung 4 free (für Testzwecke halt)... :(
     
  2. Till

    Till Administrator

    Ruf auf:

    killall apache2

    und starte apache dann neu.
     
  3. Falcon37

    Falcon37 New Member

    Nach der Eingabe kommt wieder die gleiche Fehlermeldung.
     
  4. Till

    Till Administrator

    Dann poste mal die Ausgabe von:

    netstat -tap
     
  5. Falcon37

    Falcon37 New Member

    netstat -tap Ausgabe:

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:1922                  *:*                     LISTEN      21063/sshd
    tcp        0      0 localhost.localdoma:839 *:*                     LISTEN      2783/famd
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      1879/amavisd (maste
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      2736/master
    tcp        0      0 *:mysql                 *:*                     LISTEN      1943/mysqld
    tcp        0      0 localhost.localdo:spamd *:*                     LISTEN      2010/spamd.pid
    tcp        0      0 *:sunrpc                *:*                     LISTEN      1634/portmap
    tcp        0      0 *:ftp                   *:*                     LISTEN      17818/pure-ftpd (SE
    tcp        0      0 domain1.xx:domain   *:*                     LISTEN      2668/mydns
    tcp        0      0 ip-XXX-XXX-XXX-X:domain *:*                     LISTEN      2668/mydns
    tcp        0      0 ip-XXX-XXX-XXX-X:domain *:*                     LISTEN      2668/mydns
    tcp        0      0 domain2.xx:domain *:*                     LISTEN      2668/mydns
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      2668/mydns
    tcp        0      0 *:smtp                  *:*                     LISTEN      2736/master
    tcp        0      0 localhost.localdo:49738 localhost.localdoma:ftp TIME_WAIT   -
    tcp        0      0 localhost.localdo:34949 localhost.locald:domain TIME_WAIT   -
    tcp        0      0 localhost.localdo:60661 localhost.localdo:mysql ESTABLISHED 13344/amavisd (ch16
    tcp        0    248 domain2.xx:3749   g2280802244.adsl.alicedsl.de:50741 ESTABLISHED 25883/sshd: burnbab
    tcp        0      0 localhost.localdo:mysql localhost.localdo:60661 ESTABLISHED 1943/mysqld
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      2646/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      2664/couriertcpd
    tcp6       0      0 [::]:1922               [::]:*                  LISTEN      21063/sshd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      2652/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      2634/couriertcpd
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      17818/pure-ftpd (SE
    tcp6       0      0 ip6-localhost:domain    [::]:*                  LISTEN      2668/mydns
     
  6. Till

    Till Administrator

    Nichts auf dem apache port zu sehen, komisch woher dann der Fehler kommt, dass er schon belegt ist... Nen kompletten reboot hast Du ja sicher auch schon versucht?
     
  7. Falcon37

    Falcon37 New Member

    Jop zweimal. :(
    Wo speichert ISPConfig 3 seine erstellen SSL Zertifikate ? Vielleicht wurden die nicht gelöscht...
    Sonst noch eine Idee woran es legen könnte?
     
    Zuletzt bearbeitet: 18. Jan. 2010
  8. Till

    Till Administrator

    Im ssl Verzeichnis des jeweiligen webs.
     
  9. Falcon37

    Falcon37 New Member

    Okay habe die mal auf die schnelle gelöscht, es war noch vorhanden. Jetzt bekomme ich diese Meldung bei Apache Neustart:

    Code:
    /etc/init.d/apache2 restart
    Restarting web server: apache2[Mon Jan 18 17:06:52 2010] [warn] module evasive20_module is already loaded, skipping
    Syntax error on line 95 of /etc/apache2/sites-enabled/doamin.com.vhost:
    SSLCertificateFile: file '/var/www/clients/client0/web3/ssl/domain.crt' does not exist or is empty
     failed!
    
    War vielleicht doch nicht die Idee, muss ich zugeben... :eek:
     
  10. Till

    Till Administrator

    Das mit dem löschen war keine gute Idee. Hast Du ein Backup davon? Ansonsten musst Du das ssl verzeichnis manuell neu erstellen, dann den symlink
    /etc/apache2/sites-enabled/doamin.com.vhost löschen, apache neu starten und in ispconfig das ssl cert neu erstellen. beache bitte dass du keine umlaute im ssl cert nimmst.
     
  11. Falcon37

    Falcon37 New Member

    1a danke sehr Apache geht wieder! :)
    Ich glaub das lag wirklich an den Umlauten...

    Wenn ich für diesen ganzen Support zahlen müsste, wäre ich jetzt arm, habe ja so viele Posts geschrieben :D

    Ich kauf mir demnächst mal wieder so ein 6 Monate Zugang, hoffentlich geht das Lastschriftverfahren jetzt mit Paypal...
     

Diese Seite empfehlen