Apache startet wg. Zertifikat nicht mehr?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von mcclane, 12. Nov. 2014.

  1. mcclane

    mcclane New Member

    Hallo,

    ich wollte vorhin eigentlich nur über ISPConfig 3 ein Zertifikat austauschen. Doch irgendwie hat sich dann der Apache verabschiedet. Diesen wollte ich dann wieder neustarten doch dies gelingt mir seitdem nicht mehr. Habe schon einiges ausprobiert, z. B. "ispconfig_update.sh" mit Neuerstellung der Zertifikate doch hat alles nicht genutzt.

    Im Moment erscheint folgendes nach Eingabe von "apache2ctl configtest"
    Die Datei '/usr/local/ispconfig/interface/ssl/ispserver.crt' existiert allerdings und ist auch nicht leer.

    Der angeblich fehlerhafte Inhalt aus der Datei /etc/apache2/sites-enabled/000-ispconfig.vhost sieht so aus:
    Jetzt weiß ich leider nicht mehr weiter... Wie bekomme ich den Apache wieder zum Laufen? Vielen Dank.
     
  2. F4RR3LL

    F4RR3LL Member

    Die Passage die du gepostet hast ist ok, was ist mir dem nicht existenten Docroot?
    Es würde Sinn machen den ganzen vhost zu posten. Denn diese abgehackte config sagt nix aus. Wenn in der Config vorher etwas fehlerhaft ist kann Line 58 ein logischer Fehler daraus sein.


    Gruß Sven

    Hier eine funktionierende vhost, meine is auf StartSSL angepasst, aber das betrifft nur die Certs, Rest is default.

    Code:
    ######################################################
    
    # This virtual host contains the configuration
    
    # for the ISPConfig controlpanel
    
    ######################################################
    
    
    
    Listen 8080
    
    NameVirtualHost *:8080
    
    
    
    <VirtualHost _default_:8080>
    
      ServerAdmin webmaster@localhost
    
    
      <FilesMatch "\.ph(p3?|tml)$">
    
        SetHandler None
    
      </FilesMatch>
    
    
      <IfModule mod_fcgid.c>
    
        DocumentRoot /var/www/ispconfig/
    
        SuexecUserGroup ispconfig ispconfig
    
        <Directory /var/www/ispconfig/>
    
          Options -Indexes +FollowSymLinks +MultiViews +ExecCGI
    
          AllowOverride AuthConfig Indexes Limit Options FileInfo
    
          <FilesMatch "\.php$">
    
              SetHandler fcgid-script
    
          </FilesMatch>
    
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    
                Order allow,deny
    
          Allow from all
    
              </Directory>
    
        IPCCommTimeout  7200
    
        MaxRequestLen 15728640
    
      </IfModule>
    
    
      <IfModule mpm_itk_module>
    
        DocumentRoot /usr/local/ispconfig/interface/web/
    
        AssignUserId ispconfig ispconfig
    
        AddType application/x-httpd-php .php
    
        <Directory /usr/local/ispconfig/interface/web>
    
          # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
    
          Options +FollowSymLinks
    
          AllowOverride None
    
                Order allow,deny
    
          Allow from all
    
                php_value magic_quotes_gpc        0
    
        </Directory>
    
      </IfModule>
    
    
      # ErrorLog /var/log/apache2/error.log
    
      # CustomLog /var/log/apache2/access.log combined
    
      ServerSignature Off
    
    
      <IfModule mod_security2.c>
    
        SecRuleEngine Off
    
      </IfModule>
    
    
    
      # SSL Configuration
    
      SSLEngine On
    
      SSLProtocol All -SSLv2 -SSLv3
    
      SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
    
      SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
    
      #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    
    ## must be re-added after an ISPConfig update!!!
    
      SSLCertificateChainFile /usr/local/ispconfig/interface/ssl/startssl.sub.class1.server.ca.crt
    
    
    
    </VirtualHost>
    
    
    
    <Directory /var/www/php-cgi-scripts>
    
        AllowOverride None
    
            Order Deny,Allow
    
        Deny from all
    
        </Directory>
    
    
    
    <Directory /var/www/php-fcgi-scripts>
    
        AllowOverride None
    
            Order Deny,Allow
    
        Deny from all
    
        </Directory>
    
     

Diese Seite empfehlen