Apache streikt...

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von pc_helferlein, 8. Aug. 2008.

  1. pc_helferlein

    pc_helferlein New Member

    Nach Installation von ISPConfig schien alles zu funktionieren, dann spielte ich in das web Verzeichnis PHP Daten ein. Prompt ging es los,
    der apache sendete die PHP Dateien als unbekannten dateityp als Download. Selbes Problem tritt auch bei meinen CGI's auf und ich weiß nicht wieso.Ich erhielt bei keiner installation eine fehlermeldung oder sonst etwas.

    Es kommt mir fast so vor als ob irgendwo ich was übersehen habe.
    Habe suse 10,3 mit ispconfig als Virtuelle maschine auf basis der Workstation 5 laufen damit die kompatibel mit ESX und VM Ware Server ist.

    Weiß zufällig jemand WO und in WELCHER config datei das addhandler oder sethandler für die cgi und php fehlen?

    MfG
     
  2. Till

    Till Administrator

    Schau mal in die Datei /home/admispconfig/ispconfig/lib/config.inc.php, da musst Du den Typ der PHP Einbindung für SuSE ändern, da SuSE da mal wieder alles anders macht als andere Linux Distributionen. Was Du machen musst, steht dort in den Kommentaren.

    Danach musst Du etwas in den Web-Einstellungen eines Webs ändern und auf speichern klicken, damit die Konfiguration neu geschrieben wird.

    Siehe auch:

    http://www.howtoforge.com/ispconfig-2.x-first-steps
     
  3. pc_helferlein

    pc_helferlein New Member

    Ups, hinter jeder Zeile ist ein schwarz hinterlegtes weisses accend Circonflex ^

    Das kenn ich nur von einem Problem her, falsche formatierung aber wieso tritt das da auf?
    Kannst du Till mal bei dir nachschauen ob im midnight commander dieses Zeichwen in der Config auch hinter jeder Zeile steht?
    *verwirrt bin*

    Wenn ja kein wunder das es streikt.
     
  4. Till

    Till Administrator

    Das ist ok und hat auch mit Deinem Problem nichts zu tun. In der 2.2.24er Version hat die Datei eine falsche Kodierung, da hat ebre keinerlei Auswirkunden auf die Funktion, da pHP mit Wundows und Linux Linebreaks gleicehrmaßen gut zurecht kommt.
     
  5. pc_helferlein

    pc_helferlein New Member

    Perfekt, die PHP Datein gehn jetzt, nur warum die vgi noch streiken weiß ich nicht :-S
    Entweder hat mich das rumarbeiten in der Materie Blind gemacht oder der Urlaub is überfällig :D

    Wie kommt es das er die CGI directives richtig setzt aber die dateien dennoch senden will?:(
     
  6. Till

    Till Administrator

    Hast Du die CGI auch ausführbar gemacht?
     
  7. pc_helferlein

    pc_helferlein New Member

    chmod 777 und user eben der User dem es gehört. Wobei die besitzrechte bei
    chmod 777 egal sind weil es ja so markiert ist das es jeder ausführen darf.

    Und anonsten steh ich grad auf dem schlauch.
    Das php hab ich durch editieren der php5.conf unter /etc/apache2/conf.d zum laufen bekommen. Hierfür musste ich nur das ## ISPCOFNIG INSTALL ## aus den Zeilen herausnehmen so das am ende als Zeile dann:
    AddHandler application/x... anstelle AddHandler ## ISPCOFNIG INSTALL ## application/x
    dastand.
     
  8. Till

    Till Administrator

    keine gute Idee, damit hast Du jetzt die ISPConfig Konfiguration deaktiviert. Wenn das die Lösung gewesen wäre, hätte ich Dir das geschrieben.
     
  9. pc_helferlein

    pc_helferlein New Member

    Ups holy moly. Das ist natürlich schlecht....
    Ich muss zugeben die komplexität dieses ISP Config Systems übersteigt eindeutig meine mir derzeit zur verfügung stehenden Freiräume. Ich kann nicht ein System verstehen wenn ich nebnher Arbeiten erledige.
    Ich mach die änderung mal flink rückgängig. Das CGI-Problem hat sich hierfür jetzt von allein in wohlgefallen aufgelöst, da hatte der Brwoser nen Schluckauf, nach ner neu installation wars weg. komischerweise.

    Wo sind die Handler der applications denn nun gesetzt? Ich würd da gern das Problem auch nochgelöst bekommen.

    MfG
     
  10. Till

    Till Administrator

    Hatte ich in Post #2 beschrieben.

    Also die Zeile für PHP so ändern, dass dort addhandler steht:

    $go_info["server"]["apache2_php"] = 'addhandler'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)
     
  11. pc_helferlein

    pc_helferlein New Member

    Danke, danke danke danke danke


    Ich hab mich entschlossen, ich geh in Urlaub das kann so nich weitergehen *lach*

    Man so langsam war ich noch nie im begreifen...
     

Diese Seite empfehlen