Apache und Pure-FTP

Dieses Thema im Forum "Server Administration" wurde erstellt von H3llGhost, 7. Okt. 2009.

  1. H3llGhost

    H3llGhost New Member

    Hallo Leute,

    ich habe SUSE 10.3 und habe mit dem Paketmanager Apache und den Pure-FTP installiert.
    Nun möchte ich mit Hilfe vom Pure-FTP auf den htdocs Ordner von Apache zugreifen.
    Deswegen habe ich ich als User die ID 30 (wwwrun) und als Gruppe die ID 8 (www) angegeben.

    Meine Config sieht wie folgt aus:

    Code:
    
    ChrootEveryone              yes
    
    TrustedGID                    49
    
    BrokenClientsCompatibility  no
    
    MaxClientsNumber            10
    
    Daemonize                   yes
    
    MaxClientsPerIP             3
    
    VerboseLog                  no
    
    AllowDotFiles               yes
    
    DisplayDotFiles             yes
    
    AnonymousOnly               no
    
    NoAnonymous                 yes
    
    SyslogFacility              ftp
    
    # FortunesFile              /usr/share/fortune/zippy
    
    DontResolve                 yes
    
    MaxIdleTime                 15
    
    # LDAPConfigFile                /etc/pure-ftpd/pureftpd-ldap.conf
    
    # MySQLConfigFile               /etc/pure-ftpd/pureftpd-mysql.conf
    
    # PGSQLConfigFile               /etc/pure-ftpd/pureftpd-pgsql.conf
    
    PureDB                        /etc/pure-ftpd/pureftpd.pdb
    
    # ExtAuth                       /var/run/ftpd.sock
    
    # PAMAuthentication             yes
    
    UnixAuthentication            yes
    
    LimitRecursion              2000 8
    
    AnonymousCanCreateDirs      no
    
    MaxLoad                     4
    
    # PassivePortRange          30000 50000
    
    # ForcePassiveIP                192.168.0.1
    
    # AnonymousRatio                1 10
    
    # UserRatio                 1 10
    
    AntiWarez                   yes
    
    # Bind                      127.0.0.1,21
    
    # AnonymousBandwidth            8
    
    # UserBandwidth             8
    
    Umask                       177:077
    
    MinUID                      40
    
    AllowUserFXP                no
    
    AllowAnonymousFXP           no
    
    ProhibitDotFilesWrite       no
    
    ProhibitDotFilesRead        no
    
    AutoRename                  no
    
    AnonymousCantUpload         yes
    
    #TrustedIP                  10.1.1.1
    
    #LogPID                     yes
    
    # AltLog                     clf:/var/log/pureftpd.log
    
    # AltLog                     stats:/var/log/pureftpd.log
    
    # AltLog                     w3c:/var/log/pureftpd.log
    
    NoChmod                     no
    
    KeepAllFiles                no
    
    CreateHomeDir               yes
    
    #Quota                       1000:10
    
    PIDFile                     /var/run/pure-ftpd.pid
    
    #CallUploadScript yes
    
    MaxDiskUsage               99
    
    NoRename                  no
    
    CustomerProof              yes
    
    # PerUserLimits            3:20
    
    # NoTruncate               yes
    
    # TLS                      1
    
    # IPV4Only                 yes
    
    # IPV6Only                 yes
    
    # FileSystemCharset    big5
    # ClientCharset        big5
    
    PassivePortRange    30000:30100
    
    Wenn ich mich einloggen will kommt folgender Fehler:
    Can't login as [mr-burns]: account disabled

    Die Userliste sieht wie folgt aus:
    mr-burns:$2a$07$2XkE.M6wzxKLvQ1nU00LkubUOUUFN.tGdjPdDNtRZgbTuEgX.7kBm:30:8::/srv/www/htdocs/./::::::::::::

    Das Verzeichnis mit /srv/www mit allen Unterverzeichnissen gehört wwwrun und www.
    Ich hoffe das ist richtig.

    Vielen Dank im Vorraus. :)


    EDIT:
    So nun funktioniert der Login.
    Ich habe auch die Verzeichnisse wieder dem Root gegeben.
    Mein Problem ist nun chmod funktioniert nicht als FTP-Benutzer.
    Warum nicht?
     
    Zuletzt bearbeitet: 7. Okt. 2009
  2. Till

    Till Administrator

    Versuch mal das hier einzufügen:

    NoChmod no
     
  3. H3llGhost

    H3llGhost New Member

    Das habe ich ja schon benutzt ... ;)
    Habe es nun so gemacht das ich ein chown auf alle Dateien gemacht habe.
    Ich denke das muss gemacht werden, da ich ja über die Konsole Dateien hinzugefügt habe.

    EDIT:
    problem ist nun ich kann Ordner erstellen aber nichts löschen.
    Weil chmod 0 ist.
    Sprich ich habe keine Rechte auf mein eigenen Ordner, woran kann das liegen?
     
    Zuletzt bearbeitet: 7. Okt. 2009
  4. Till

    Till Administrator

    Alle Ordner müssen dem Linux System user gehören, zu dem Dein pureftpd User gehört.
     

Diese Seite empfehlen