Apache2 failed! nach ispconfig Installation

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von telepathikus, 29. März 2009.

  1. telepathikus

    telepathikus New Member

    ISPConfig - www.meinedomaine.de:81 keine Verbidung

    Hallo zusammen!
    Ich habe auf eine frisches System die Installation von Ispconfig anhand "Der perfekte Server - Debian Etch (4.0)" konfiguriert.

    Nachdem ich ISPconfig installiert habe läuft Apache2 nicht mehr.

    Bei
    Code:
     [SIZE=2]force-load[/SIZE] 
    kommt die Fehlermeldung
    Code:
     [SIZE=2]httpd (no pid file) not running[/SIZE]  [COLOR=black]failed [/COLOR]
    Bei
    Code:
    start
    die Fehlermeldung
    Code:
    failed!
    Bei
    Code:
    stop 
    die Fehlermeldung
    Code:
     [SIZE=2]httpd (no pid file) not running[/SIZE] 
    Ich verzweifle so langsam... Finde einfach keine Lösung.


    Die Ispconfig-Installation ist bis zu
    Code:
    [B]Please enter a name for the ISPConfig database:[/B]                z.B. ispconfigdb
    gekommen und hat diese 3 letzten Schritte nicht mehr ausgeführt
    Code:
    [B]Please enter the IP address of the ISPConfig web:[/B]                z.B. 192.168.0.1
                  [B]Please enter the host name:[/B] z.B. www
                  [B]Please enter the domain:[/B] z.B. xyz.de
                  [B]Please select the protocol (http or https (SSL encryption)) to                use to access the ISPConfig system:[/B] 
    Ich bin für jeden Tip sehr dankbar.

    MfG,

    agnus

     
    Zuletzt bearbeitet: 30. März 2009
  2. telepathikus

    telepathikus New Member

    Nachtrag

    Nachtrag:

    Die Installation von IspConfig konnte nicht so wie in der der Anleitung gestartet werden.

    Weder die 3.0.1 noch die 2.2.30.

    In der Anleitung wird beschrieben
    Code:
    cd install_ispconfig 
    und dann
    Code:
     ./setup
    Ich konnte aber nur per Hand über Ispconfig3/install/install (oder so ähnlich) die install.php starten.

    Kann es daran liegen?
     
  3. Laubie

    Laubie Member

    öhm...
    du hast also debian 4 und hast nach Anleitung "Der perfekte Server" alles für dien Installation von ispC 2 vorbereitet.

    Welches IPSC haste denn dann installiert? 2 oder 3?

    Wenn mich bei der konfiguration von ispc3 grad nicht alles täuscht, braucht man dafür gaaaanz andere Komponenten, so dass nach dem "perfekten Server für debian 4" eine installation von ispc3 nicht möglich ist, oder irre ich mich da?

    Gruß
    Laubie
     
  4. telepathikus

    telepathikus New Member

    Hallo Laubie und vielen Dank für deine Antwort.

    Zuerst habe ich ispconfig 3 installiert.

    ####

    Danach auf den Server nen neuinstall gemacht und alle Schritte "Der perfekte Server" erneut ausgeführt und ispconfig2.


    Gruß,

    agnus
     
  5. planet_fox

    planet_fox Super-Moderator

    ähm was hast du nun installiert isp3 oder 2 das ist noch nicht so ersichtlich
     
  6. telepathikus

    telepathikus New Member

    Hallo!

    Wie gesagt, zuerst ispconfig 3 und dann wieder den Server komplett neu aufgespielt (neuinstall).

    Nach der Server-Neuinstallation ispconfig 2.
    ##############

    Hat sich erledigt! Gerade erneut Server neu aufgesetzt und ispconfig 2- hat sich installieren lassen.
    ###############

    Jetzt stehe ich vor einem neuen Problem.

    Die Installation Ispconfig 2 reibungslos funktioniert,
    konfiguriert wurde das frisch aufgespielte System (Debien 4 Etch) nach der Howtoforge.


    Problem: Die Login-Seite von ispconfig lässt sich nun nicht aufrufen.

    Woran könnte das liegen?
     
  7. Laubie

    Laubie Member

    sag uns doch mal, welcher fehler erscheint ;)

    ist unter der IP:81 versteckt, gell?

    funzt denn sonst alles? was kommt, wenn du nur die IP eingibst?

    Gruß Laubie
     
  8. telepathikus

    telepathikus New Member

    Hallo Laubie und vielen Dank für deine Antwort!


    Wenn ich http://www.meinedomain.de:81 aufrufe kommt:


    Verbindung fehlgeschlagen

    Firefox kann keine Verbindung zu dem Server unter www.meinedomaine.de:81 aufbauen.

    Obwohl die Website gültig erscheint, konnte keine Verbindung aufgebaut werden.

    * Könnte die Website temporär nicht verfügbar sein? Versuchen Sie es später nochmals.
    * Können Sie auch andere Websites nicht aufrufen? Überprüfen Sie die Netzwerk-Konfiguration des Computers.
    * Wird Ihr Computer oder Netzwerk durch eine Firewall oder einen Proxy geschützt? Falsche Einstellungen können den Web-Zugriff stören.
     
    Zuletzt bearbeitet: 30. März 2009
  9. Laubie

    Laubie Member

    probiers doch mal mit der ip deines Servers gefolgt von :81
     
  10. telepathikus

    telepathikus New Member

    Hallo Laubie!

    Nachtrag:
    Vorher habe ich einen Virtual Host angelegt, der sieht dann so aus:


    Code:
    <VirtualHost 84.200.211.158 >
    # Anmerkung: Default Domain muss vorhanden sein
    ServerAdmin EMAIL
    ServerName meinedomaine
    ServerAlias www.meinedomaine.de w.meinedomaine.de ww.meinedomaine.de
    # Anmerkung: Sicherstellung der Erreichbarkeit bei Schreibfehlern; *Domain .> Problem mit Subdomains
    DocumentRoot /var/www/telepathie
    # Pfad zu lokalen Verzeichnis unserer Debian Etch Webseite
    <Directory /var/www/telepathie>
    Order Deny,Allow
    Allow from all
    Options -Indexes
    # option = keine Auflistungvon Verzeichnissen im Browser
    </Directory>
    </VirtualHost>
    Es liegt aber nicht daran oder?
     
  11. telepathikus

    telepathikus New Member

    IP:81 geht auch nicht
     
  12. Laubie

    Laubie Member

    Doch daran lags ;)
    Dein VirtualHost schnappt sich alle IPs.
    Gib mal in der ersten Zeile

    <VirtualHost 84.200.211.158:80 >

    ein
     
  13. Laubie

    Laubie Member

    nebenbei: Warum lässt du die VHosts nicht durch ISPConfig erstellen??
    Die machen das nämlich richtig ;)
     
  14. telepathikus

    telepathikus New Member

    Hallo Laubie und vielen Dank!!

    Es klappt leider nicht

    Nicht mit <VirtualHost 84.200.211.158:80 >

    und

    auch nicht mit <VirtualHost * >

    Habe es aus verzweiflung auch mit <VirtualHost 84.200.211.158:81 > probiert und immer mit apache reload nach der Änderung...

    Die Seite ist leider immer noch nicht aufrufbar
     
  15. telepathikus

    telepathikus New Member

    Wusste ich nicht. Danke!

    Ich würde ja gerne mit ISPConfig erstellen lassen...
     
  16. Laubie

    Laubie Member

    kannst du die vhosts etc. nicht in den Ursprungszustand zurück versetzen?
     
  17. telepathikus

    telepathikus New Member

    Es gab gar keine Vhosts.

    Die musste ich erst eingeben bzw. einrichten allein schon wegen der ISPCconfig-Installation.

    Ich installieren ISPConfig mal neu und geben ihm anstatt der Adresse die IP. Mal sehen was dann passiert.


    Netten Gruß und vielen Dank,

    agnus
     
  18. telepathikus

    telepathikus New Member

    Fehler

    Bei der Neuinstallation kam am ganz zum Schluss ein Fehler:


    Code:
     ./setup2: line 1189: cd / root/install_ispconfig/compile_aps/../..: Datei oder Verzeichniss nich Vorhanden.

    Nach der "Howtoforce" habe das System für ISPCONFIG eingerichtet - samt allen Paketen.

    Ob noch etwas fehlt oder einfach nur der Download von IPSCONFIG nicht geklappt hat?

    Lade nochmal neu herunter und versuche es wieder
     
  19. telepathikus

    telepathikus New Member

    Habe ISPCONFIG neu heruntergeladen und installiert...

    Schon wieder der selbe Fehler am Ende
    Code:
    ./setup2: line 1189: cd / root/install_ispconfig/compile_aps/../..: Datei oder Verzeichniss nich Vorhanden.  
     
  20. telepathikus

    telepathikus New Member

Diese Seite empfehlen