apache2 mod_proxy_balancer

#1
Hallo zusammen!

Ich habe nach dem HowTo zum Thema "Apache: Erstellen eines Session-kompatiblen Loadbalancers unter Verwendung von mod_proxy_balancer (Debian Etch)" einen Loadbalancer erstellt!

Danach habe ich zum Testen Joomla 1.5 auf den Server kopiert!

Das Problem ist nun, dass ich, wenn ich das Admin-Interface verwende, mich immer wieder neu einloggen muss.
Wenn ich einen der beiden Server im Balancer Manager auf disabled setze funktioniert alles!

Gibt es zu diesem Problem eine Lösung???

Danke bereits im Vorraus!

Mfg Jakob
 
Zuletzt bearbeitet:
#3
Das liegt ja dann wohl am Sessionmanagement allgemein oder eben von Joomla.
Leider bin ich nicht fachkundig/tief genug im Thema, sonst würde ich gerne helfen.
Für weitere Bearbeitung wären z.B. die Configs ganz gut ...
mod_proxy_balancer habe ich persönlich auch schon getestet und es hat wunderbar funktioniert.
Du solltest mal Tante Gockel besuchen und sowas suchen wie sticky, session, mod_load_balancer um das Tutorial nochmal zu verifizieren.

Ich vermute einfach mal, dass dein Loadbalancer nicht richtig eingestellt ist auf Sessions, weil Sessions sind ja nicht nur bei Joomla wichtig.
Hast du es denn generell überhaupt getestet? Und gesehen auf welchem Server du landest?
Irgendwann hab ich das mal machen müssen und hab dafür auch ne Rewrite geschrieben (Hast du dich dabei an die Rewrite aus dem Tutorial gehalten?) ... hoffe ich konnte ein ganz kleines bisschen weiterhelfen :)
 
Zuletzt bearbeitet:

Werbung

Top