Apache2 startet nach Update nicht

#1
Nach einem automatischen Update vom Apache, lässt sich dieser nicht mehr starten.

"update to apache2 from 2.2.9-10+lenny8 to 2.2.9-10+lenny9"

Es erscheint die folgende Fehlermeldung:
"Konnte Apache nicht starten :
Starting web server: apache2Syntax error on line 37 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
failed!
"

Grundsystem ist Debian 5 mit Ispconfig 2.2.37
 

Till

Administrator
#2
Bei Dir scheint mod_php nicht installiert zu sein oder aber es ist nicht aktiviert. Versuch mal:

a2enmod php5
/etc/init.d/apache2 restart
 
#3
Hallo Till,

danke für die Antwort. Leider war dies nicht von Erfolg gekrönt.
Die "libphp5.so" fehlt tatsächlich im System.

Warum das nun so ist weiss ich noch nicht, da das System bereits seit 2 Jahren läuft. Eventuell, wird beim Update die Datei gelöscht?

Ich baue mir erstmal den Server in VMware nach und schaue mir den Apachen dort an.

www:~# a2enmod php5
Enabling module php5.
Run '/etc/init.d/apache2 restart' to activate new configuration!
www:~# /etc/init.d/apache2 restart
Restarting web server: apache2apache2: Syntax error on line 185 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory
failed!
 
#4
Problem gelöst

Nach der Anleitung

http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig2-p5

den zweiten Abschnitt der Apache-Installation neu ausgeführt:

apt-get install libapache2-mod-php5 libapache2-mod-ruby libapache2-mod-python php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-pspell php5-recode php5-snmp php5-sqlite php5-suhosin php5-tidy php5-xcache php5-xmlrpc php5-xsl


Dabei wurden libapache2-mod-php5 und php5 neu installiert.

Das System läuft nun wieder.
 

Werbung

Top