APS - installierte Pakete - Fehler

Dieses Thema im Forum "Allgemein" wurde erstellt von miglosch, 7. März 2013.

  1. miglosch

    miglosch New Member

    unter dem Punkt installierte Pakete erhalte ich statt einer Liste folgende Ausgabe:
    Code:
    DB::query(SELECT aps_instances.id AS id, aps_instances.package_id AS package_id, aps_instances.customer_id AS customer_id, sys_group.name AS customer_name, aps_instances.instance_status AS instance_status, aps_packages.name AS package_name, aps_packages.version AS package_version, aps_packages.release AS package_release, aps_packages.package_status AS package_status, CONCAT ((SELECT value FROM aps_instances_settings WHERE name='main_domain' AND instance_id = aps_instances.id), '/', (SELECT value FROM aps_instances_settings WHERE name='main_location' AND instance_id = aps_instances.id)) AS install_location FROM aps_instances, aps_packages, sys_group WHERE sys_group.client_id = aps_instances.customer_id AND aps_instances.package_id = aps_packages.id ORDER BY package_name LIMIT 0, 15) -> mysqli_query FUNCTION dbispconfig.CONCAT does not exist#0 db->query(SELECT aps_instances.id AS id, aps_instances.package_id AS package_id, aps_instances.customer_id AS customer_id, sys_group.name AS customer_name, aps_instances.instance_status AS instance_status, aps_packages.name AS package_name, aps_packages.version AS package_version, aps_packages.release AS package_release, aps_packages.package_status AS package_status, CONCAT ((SELECT value FROM aps_instances_settings WHERE name='main_domain' AND instance_id = aps_instances.id), '/', (SELECT value FROM aps_instances_settings WHERE name='main_location' AND instance_id = aps_instances.id)) AS install_location FROM aps_instances, aps_packages, sys_group WHERE sys_group.client_id = aps_instances.customer_id AND aps_instances.package_id = aps_packages.id ORDER BY package_name LIMIT 0, 15) called at [/usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php:157] #1 db->queryAllRecords(SELECT aps_instances.id AS id, aps_instances.package_id AS package_id, aps_instances.customer_id AS customer_id, sys_group.name AS customer_name, aps_instances.instance_status AS instance_status, aps_packages.name AS package_name, aps_packages.version AS package_version, aps_packages.release AS package_release, aps_packages.package_status AS package_status, CONCAT ((SELECT value FROM aps_instances_settings WHERE name='main_domain' AND instance_id = aps_instances.id), '/', (SELECT value FROM aps_instances_settings WHERE name='main_location' AND instance_id = aps_instances.id)) AS install_location FROM aps_instances, aps_packages, sys_group WHERE sys_group.client_id = aps_instances.customer_id AND aps_instances.package_id = aps_packages.id ORDER BY package_name LIMIT 0, 15) called at [/usr/local/ispconfig/interface/web/sites/aps_installedpackages_list.php:112]
    :eek:

    ISPConfig Version 3.0.5.1

    Könnte das ein Bug sein?
     
  2. Till

    Till Administrator

    Das ist ein Bug in der von Dir verwendeten mysql Version welche keine Leerzeichen zwischen concat un "(" unterstützt, aktuelle mysql Versionen haben das Problem nicht mehr. Wir haben aber auch in ispconfig einen workaround dafür bereits im svn stable eingebaut dass es mit diesen mysql Versionen wieder funktioniert.
     
  3. miglosch

    miglosch New Member

    Okay...
    Wie funktioniert das mit dem workaround?
    Kann ich ./ispconfig_update erneut ausführen?

    Leider bekomme ich auf meinem alten Lenny keine Updates mehr... :(
    Ich weiß, ein Upgrade wäre wohl das Sinnigste, aber irgendwie habe ich davor etwas Bammel...
     

Diese Seite empfehlen