ASP mit Debian und Apache

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von xwsnet, 1. Okt. 2008.

  1. xwsnet

    xwsnet New Member

    Hallo,
    seit einiger Zeit versuche ich eine ASP Seite auf meinem Server zum laufen zu bringen. Das klappt aber nicht so, wie ich mir das vorstelle...

    Kennt jemand ein gutes Howto, wie man das am besten macht.? Ich habe das unter anderem mit ModMono versucht...
     
  2. Till

    Till Administrator

    Möchtest Du ASP oder ASP.NET zum laufen bringen. Das sind 2 unterschiedliche Sachen und je nachdem benötigst Du andere Erweiterungen für den apache.
     
  3. xwsnet

    xwsnet New Member

    Sorry, da habe ich mich nicht ganz klar ausgedrückt.
    Ich möchte asp.net zum laufen bringen.

    Wäre echt klasse, wenn du (oder jemand anderes) mir dabei helfen kann...

    Noch als ergänzung. Die Seiten sind mit VB geschrieben. Schön wäre es, wenn das gehen würde. Und wenn das auch noch möglich ist, das auch Seiten mit C# gehen, bin ich total happy... :)
     
    Zuletzt bearbeitet: 2. Okt. 2008
  4. Till

    Till Administrator

  5. xwsnet

    xwsnet New Member

    Guten morgen...

    Ich habe jetzt einmal die Anleitung von der Ubuntu-Seite versucht, und leider hat es nicht geklappt.

    Wenn ich die entsprechende Default.aspx Datei aufrufen möchte läd er mir die nur runter. Angezeigt wird jedoch nichts...

    Hast du noch einen Tipp für mich???
     
  6. Till

    Till Administrator

    Poste mal die exakte Konfiguration des vhosts des apache.
     
  7. xwsnet

    xwsnet New Member

    Das ist die entsprechende Passage aus der Datei. Da ich ISPControl verwende ist das natürlich etwas anders, als bei ISPCP... Aber das ist ja kein Problem...
     
  8. Till

    Till Administrator

    Vermutlich haut Dir da die ISPCP Konfiguration irgendwo dazwischen. Am besten fragst Du mal deren Entwickler, wie man Mono für ISPCP einrichtet.
     
  9. xwsnet

    xwsnet New Member

    Jo, schade... Dann werd ich das dort noch einmal versuchen :)
    Aber eigentlich dürfte das doch relativ egal sein, mit welcher Verwaltungsoberfläche man das macht...
     
  10. Till

    Till Administrator

    Nicht unbedingt. Jede Verwaltungsoberfläche bringt bestimte Voreinstellungen etc. mit und es gibt viele Arten einen Apache zu konfigurieren. Es ist also gut möglich, dass man für Dieses Controlpanel etwas anderes beachten muss als z.B. für ISPConfig.
     
  11. xwsnet

    xwsnet New Member

    Ok, ich habe es jetzt einmal mit ISPConfig versucht. Damit müsste das dann ja gehen...

    Ich habe das jetzt genauso gemacht, wie das in dem Link in deiner ersten Antwort war.

    Dazu habe ich folgendes in die apache Direktiven geschrieben.
    (natürlich mit geänderten Pfaden...)

    Wenn ich dann die Datei aufrufe erhalte ich einen Error 500 und das hier steht im Error.log.

    Leider weiß ich net genau, was dieser Fehler sagt und was ich damit machen muss...
     
  12. Till

    Till Administrator

    Ok, das sieht doch schonmal recht gut aus, da mono richtig aufgerufen wird. Die Fehlermeldung besagtm dass Du in der Datei:

    /var/www/web1620/web/web.config

    and Zeile 14 etwas stehen hast, dass er nicht kennt.
     
  13. xwsnet

    xwsnet New Member

    Hallo,
    ich hab die datei mal als txt gespeichert. Denn ich hab das inzwischen auch schon gemerkt.
    http://sommer.xwsnet.de/webconfig.txt

    Leider weiß ich net, was das Problem ist...
     
  14. Till

    Till Administrator

    Ich bin kein .net Programmierer, daher bin ich da auch etwas überfragt. Möglicherweise ist das ein Bestandteil von .NET, der in mono so noch nicht implementiert ist. Ich würde da einfach mal in einem mono Forum oder auf einer Mailingliste nachfragen.
     
  15. xwsnet

    xwsnet New Member

    Joa, ich bevorzuge auch eher php :)
    Aber was tut man net alles für seine freunde und kunden...

    Dann werd ich das mal versuchen oder den jenigen an einen .net hoster verweisen
     

Diese Seite empfehlen