Auffälligkeiten nach Update von 3.0.3 auf 3.0.4.1

NWO

New Member
#1
Update klappte wie immer ohne Probleme, danke für die neue Version! Allerdings hatte/habe ich 1-2 Auffälligkeiten:

1. Ich hab ein Fetchmail-Konto, Abruf per IMAP von einem ISPConfig 2 Server. Direkt nach dem Update habe ich alle Mails ein 2. und 3. mal bekommen, erst als ich das Konto deaktivierte und danach wieder aktivierte war alles i.O. und es wurden nur noch neue Mails übernommen

2. Meine Mailwarteschlange läuft voll, allerdings kommt das nur von einem Konto. Dieses Konto hat keine Mailbox sondern nur eine bzw. zwei Weiterleitungen:
Die Mail ging an reedlav@domain.tld, dieser Benutzer ist nicht vorhanden, genauso wie auch bei allen anderen Mails in der Warteschlange. Somit existiert natürlich auch kein Ordner /var/vmail/domain.tld/reedlav/

Code:
F2FE24A5C18C 1880 Sun Nov 27 10:21:27 yiamkqktvfeq@allnationscrc.org
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied sh: /var/vmail/domain.tld/reedlav/ispconfig_mailsize: No such file or directory /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/domain.tld/reedlav/24791.0.server1.example.com.)
@Till: Wir hatten ja schon mal ein ähnliches Problem, dass User automatisch erstellt wurden wenn es sie nicht gab. Genau diesen Bug habt ihr glaube ich mit dieser Version bzw. mit der 3.0.4 behoben oder? Vielleicht geht das ja in die Richtung.
Mit deinem Code von damals lief es ja ohne Probleme:
/var/vmail/.mailfilter

Code:
#
# Autocreate maildir, if not existant
#

#`test -e /var/vmail/$HOST`
#if ( $RETURNCODE != 0 )
#{
# `mkdir /var/vmail/$HOST`
#}

#`test -e /var/vmail/$HOST/$USER`
#if ( $RETURNCODE != 0 )
#{
# `maildirmake /var/vmail/$HOST/$USER`
# `chmod -R 0700 /var/vmail/$HOST`
#}

`test -e /var/vmail/$HOST/$USER`
if ( $RETURNCODE != 0 )
{
EXITCODE = 67
exit
}
3. Unterschiedliches Backend: Ich hatte letzte Woche auf einem anderen Server 3.0.4 frisch installiert und dann ein Update auf 3.0.4.1 gemacht. Dort gibt es jetzt bei den Listen jetzt diese nette "Live-Serach" in den Dropdowns, auf dem anderen Server habe ich immer noch normale Dropdowns. Browsercache usw. hab ich gelöscht, auch in unterschiedlichen Browsern getestet. Siehe anghänge Screenshots
 

Anhänge

Till

Administrator
#2
zu 1) Schaue ich mir mal an und versuche es zu reproduzieren. Das update ändert keine bestehenden fetchmail jobs, daher kann ich mir nicht ganz erklären wie das kommen kann.

Zu 2) Ok, hat vermutlich mit der Erfassung der Emailstatistik zu tun. Ändere mal bitte die Zeile:

Code:
`echo $SIZE >> /var/vmail/$HOST/$USER/ispconfig_mailsize`
in:

Code:
`test -e /var/vmail/$HOST/$USER`
if ( $RETURNCODE == 0 )
{
`echo $SIZE >> /var/vmail/$HOST/$USER/ispconfig_mailsize`
}
Zu 3) Das sind unterschiedliche Themes. Schau mal unter System > CP Users welches Theme Du ausgewählt hast.
 

NWO

New Member
#3
Hey Till, danke für die schnelle Antwort!

zu 2) Hat leider keine Änderung gebracht. Muss ich noch irgendwas anderes als Postfix nach der Änderung neu starten?
Hab aber noch was (wichtiges?) vergessen, die Mail-Domain hat ein Alias und genau dieser Alias verursacht das Problem, d.h. Mails an gibt-es-nicht@domain.tld werden korrekt abgewiesen, bei Mails an gibt-es-nicht@alias-domain.tld gibt es die Fehlermeldung
Code:
Nov 27 12:09:43 server1 postfix/smtpd[17576]: 6186C4A5C1CA: client=localhost[127.0.0.1]
Nov 27 12:09:43 server1 postfix/cleanup[17566]: 6186C4A5C1CA: message-id=<Rg88kbVO7GeCM7SPN2Mt8YP86Gt0F@yrxkeatjscaes>
Nov 27 12:09:43 server1 postfix/qmgr[13646]: 6186C4A5C1CA: from=<gwmrjlkshesbu@achoice.org>, size=1889, nrcpt=1 (queue active)
Nov 27 12:09:43 server1 amavis[16215]: (16215-13-4) Passed CLEAN, [92.80.156.252] [92.80.156.252] <gwmrjlkshesbu@achoice.org> -> <reedlav@alias-domain.tld>, Message-ID: <Rg88kbVO7GeCM7SPN2Mt8YP86Gt0F@yrxkeatjscaes>, mail_id: u3uFsfTX0D7a, Hits: 22.51, size: 1411, queued_as: 6186C4A5C1CA, 522 ms
Nov 27 12:09:43 server1 postfix/smtp[17569]: 374074A5C0C7: to=<reedlav@alias-domain.tld>, relay=127.0.0.1[127.0.0.1]:10024, conn_use=4, delay=2.3, delays=0.33/1.4/0/0.53, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=16215-13-4, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 6186C4A5C1CA)
Nov 27 12:09:43 server1 postfix/pipe[17435]: 6186C4A5C1CA: to=<reedlav@domain.tld>, orig_to=<reedlav@alias-domain.tld>, relay=maildrop, delay=0.05, delays=0.02/0/0/0.02, dsn=4.3.0, status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/domain.tld/reedlav/17784.0.server1.example.com.  )
zu 3) Grrr, da hätte ich auch selber drauf kommen können, danke das war es
 
Zuletzt bearbeitet:

Till

Administrator
#4
Das ist jetzt aber ein anderer Fehler. Denn es bezieht sich auf domain.tld und nicht auf die Aliasdomains, siehe Pfad in Fehlermeldung: /var/vmail/domain.tld/reedlav/

Poste mal die Ausgabe von:

ls -la /var/vmail/domain.tld/reedlav/
 

NWO

New Member
#5
Weder /var/vmail/domain.tld/ noch /var/vmail/alias-domain.tld/ gibt es, sind ja nur Weiterleitungen
ls: cannot access /var/vmail/domain.tld/reedlav/: No such file or directory

Es gibt 3 Domains für diesen Kunden, 2 davon sind ein Alias für die Hauptdomain. Es gibt keine Mailboxen, nur 2 Weiterleitungen
mail1@hauptdomain.tld --> externe T-Online Adresse und
mail2@hauptdomain.tld --> externe T-Online Adresse
 

Werbung