Autoresponder funktioniert nicht ISPConfig V. 3.0.2.1

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von tulip, 18. Mai 2010.

  1. tulip

    tulip New Member

    Hallo zusammen,

    habe mir so ziemlich alle Beiträge zum Thema Autresponder durchgelesen, aber komme nicht weiter.

    1:
    Der Autorespondertext taucht nach der Aktivierung in der SQL-Datenbank auf (habe ich mit phpmyadmin überprüft)

    2: In "/var/vmail/mailfilters" wird nichts angelegt bzw. das Verzeichnis ist leer.

    Muss ich da noch Dateien oder Verzeichnisse von Hand anlegen die danach geändert und genutzt werden?

    Gruß
    Tulip
     
    Zuletzt bearbeitet: 18. Mai 2010
  2. Till

    Till Administrator

    Nein.

    Schalte mal das verbose logging Unter system > server ein, schalte den Autoresponder aus und wieder ein, warte ein bis zwei Minuten und dann schau mal, was im ispconfig.log steht.
     
  3. tulip

    tulip New Member

    Hallo,

    da kommt eigentlich nur:
    Code:
    18.05.2010-18:51 - DEBUG - There is already an instance of server.php running. Exiting.
    18.05.2010-18:51 - DEBUG - There is already a lockfile set. Waiting another 10 seconds...
    18.05.2010-18:51 - DEBUG - There is already a lockfile set. Waiting another 10 seconds...
    18.05.2010-18:51 - DEBUG - There is already a lockfile set. Waiting another 10 seconds...
    18.05.2010-18:51 - DEBUG - There is already a lockfile set. Waiting another 10 seconds...
    18.05.2010-18:51 - DEBUG - There is already a lockfile set. Waiting another 10 seconds... 
    
    Gruß
    Tulip
     
  4. Till

    Till Administrator

    Dann scheint da ein prozess zu hängen oder ist abgestürzt. Lösche mal das Logfile mit:

    rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock

    und schu dann nach ein paar Minuten nochmal ins Log.
     
  5. tulip

    tulip New Member

    Hi,

    habe ich schon gemacht (gerade eben).

    Dananch kommt kurz:

    Code:
    18.05.2010-19:02 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    18.05.2010-19:02 - DEBUG - Found 479 changes, starting update process.
    18.05.2010-19:02 - DEBUG - Call function 'soa_delete' in plugin 'bind_plugin' raised by event 'dns_soa_delete'.
    18.05.2010-19:03 - DEBUG - There is already a lockfile set. Waiting another 10 seconds...
    18.05.2010-19:03 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    18.05.2010-19:03 - DEBUG - Found 479 changes, starting update process.
    18.05.2010-19:03 - DEBUG - Call function 'soa_delete' in plugin 'bind_plugin' raised by event 'dns_soa_delete'. 
    
    Nach der letzten Call function.... passiert wieder das Gleiche wie schon vorher:

    Code:
    DEBUG - There is already a lockfile set. Waiting another 10 seconds...
    
    Wo werden denn die anstehenden Änderungen bzw. die Queue gespeichert?

    Gruß
    Tulip
     
  6. Till

    Till Administrator

    Dein Problem ist ein Bug im DNS Modul. Editier bitte mal die Datei:

    /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php

    und ändere die Zeile (um Zeilen nr. 132):

    $app->uses("getconf");

    zu:

    $app->uses("getconf,tpl");

    und lösche die lock Datei nochmal.
     
  7. tulip

    tulip New Member

    Super,

    dein Änderungsvorschlag hat es gebracht. Jetzt sind erst mal >400 Änderungen gelaufen. Der Autoresponder funktioniert jetzt.
    Vielen Dank nochmal.

    Gruß
    Tulip
     
  8. xabbu

    xabbu Member

    Datei wird nicht angelegt

    Hallo,

    ich habe ein ähnliches Problem.
    In der SQL sind alle Einträge vorhanden, doch leider funktioniert der Autoresponder nicht.
    ISPConfig 3.0.2.1

    Hier mal das Log:

    Code:
    21.05.2010-21:29 - DEBUG - Call function 'update' in plugin 'network_settings_plugin' raised by event 'server_update'.
    21.05.2010-21:29 - DEBUG - Network configuration not available for this linux distribution.
    21.05.2010-21:29 - DEBUG - Call function 'update' in plugin 'postfix_server_plugin' raised by event 'server_update'.
    21.05.2010-21:29 - DEBUG - Processed datalog_id 198
    21.05.2010-21:29 - DEBUG - Call function 'restartHttpd' in module 'web_module'.
    21.05.2010-21:29 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    21.05.2010-21:30 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    21.05.2010-21:30 - DEBUG - Found 1 changes, starting update process.
    21.05.2010-21:30 - DEBUG - Call function 'user_update' in plugin 'mail_plugin' raised by event 'mail_user_update'.
    21.05.2010-21:30 - DEBUG - Updated Maildir quota: su -c 'maildirmake -q 1048576000S /var/vmail/mindorf-netz.de/soeren' vmail
    21.05.2010-21:30 - DEBUG - Processed datalog_id 199
    21.05.2010-21:30 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    21.05.2010-21:31 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    21.05.2010-21:31 - DEBUG - Found 1 changes, starting update process.
    21.05.2010-21:31 - DEBUG - Call function 'user_update' in plugin 'mail_plugin' raised by event 'mail_user_update'.
    21.05.2010-21:31 - DEBUG - Updated Maildir quota: su -c 'maildirmake -q 1048576000S /var/vmail/mindorf-netz.de/soeren' vmail
    21.05.2010-21:31 - DEBUG - Processed datalog_id 200
    21.05.2010-21:31 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    21.05.2010-21:32 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    21.05.2010-21:32 - DEBUG - No Updated records found, starting only the core.
    21.05.2010-21:32 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    21.05.2010-21:33 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    
    
    Habt Ihr eine Idee?

    Danke und Gruß
    Sören
     
  9. Till

    Till Administrator

    1) setzt Du couroer oder dovecot ein.
    2) Werden die Autoresponder Dateien in den Verzeichnissen undet /var/vmail/mailfilters angelegt?
     
  10. xabbu

    xabbu Member

    Hallo Till,

    ich setzte Courier ein.
    Nein, es werden keine Dateien in /var/vmail/mailfilters angezeigt.

    Gruß
    Sören
     
  11. Till

    Till Administrator

    Schau mal in die ispconfig DB mit phpmyadmin und dort in die Tabelle server, da gibt es einen Datensatz für den Server und darin ein Feld "updated". Der Wert im Updated Feld darf nicht größer sein als der größte Wert der der datalog_id in der Tabelle sys_datalog.
    Ändere den Wert des updated Feld ggf. dann deaktiviere und aktiviere dann den Autoresponder nochmal.
     
  12. xabbu

    xabbu Member

    Hallo Till,

    also:

    updated hat den Wert 200
    und die größte datalog_id ist die 200

    Gruß
    Sören
     
  13. Till

    Till Administrator

    Und Du hast im Auoresponder auch wirklich die Aktivierungscheckbox angehakt und nicht nur das datum eingetragen? Datum alleine reicht nicht.

    Andere Änderungen werden aber im Server geschrieben?
     
  14. xabbu

    xabbu Member

    Hi,

    eine Aktivierungsbox habe ich nicht.
    Ich habe den Text eingetragen und den haken UND bei Autoresponder gesetzt. Auch habe ich eine Start und Stopzeit eingetragen.
    In der Übersicht steht auch autoresponder "y".

    Ja, bis jetzt werden alle anderen Einstellungen geschrieben.

    Kann es sein, das das maildrop Plugin nicht aufgerufen wird?
    Ich sehe es im Debug gar nicht.

    Gruß
    Sören
     
    Zuletzt bearbeitet: 22. Mai 2010
  15. xabbu

    xabbu Member

    heavy debugging

    Hallo Till,

    so, ich habe mal versucht, zu debuggen, warum der Autoresponder nicht funktioniert.
    Dabei habe ich festgestellt, das das maildrop_plugin nicht aktiviert war.
    Warum auch immer....

    Ich habe dann das Plugin aktiviert und siehe da, es funktioniert teilweise. Nach dem Anlegen eines Autorsponders und anschl. deaktivieren, läßt sich der Autoresponder nicht wieder aktivieren.
    Fehlermeldung im log: WARNING - Unable to delete file:
    Wenn ich das Verzeichnis in /var/vmail/mailfilters/EmailDomain lösche, klappt es wieder, bis zur Deaktivierung.
    Hast Du eine Idee warum?

    Außerdem habe ich in Postfix einen Header_check aktiviert:

    Code:
    /^From: <>/
      REJECT You need to specify a return address, otherwise we will not accept your email.
    
    Dadurch wird der Autoresponder auch nicht funktionieren, da leider kein "From" mitgegeben wird.
    Kann man das irgendwo konfigurieren?

    Danke und Gruß
    xabbu
     
  16. Till

    Till Administrator

    Das Plugin wird nur dann deaktiviert, wenn ein Dovecot Binary auf Deinem System festgestellt wurde. Schau mal in den ISPConfig Server settings nach, ob da corier als mta und maildrop als lda ausgewählt ist.


    Der Autoresponder soll ja kein From haben. Das wird so gemacht damit Du keine Mail Loops bekommst. Stell Dir mal Vor wenn Du ein From setzen würdest und der gegenüber hat auch einen Autoresponder, der ein From setzt. Dann hast Du einen netten Mail loop, der Deine und den gegenüberliegenden Mailserver lahmlegen kann. deshalb setzt man bei Autorespondern kein From.
     
  17. xabbu

    xabbu Member

    Hallo Till,

    Danke für die Antworten.
    Mein System steht auf Courier und Maildrop. Aber das Plugin war trotzdem nicht aktiviert.

    zum Form: eigentlich sollte im Header die Information, das es eine Autoantwort ist, mitgegeben werden, so würde dann auch kein Loop mehr entstehen.

    Warum wurde die .autoresponder- Datei nach deaktivieren vom Autoresponder nicht gelöscht? Leider steht nichts aussagekräftiges im log.
    (WARNING - Unable to delete file:) mehr steht da nicht.

    Danke und Gruß
    xabbu
     

Diese Seite empfehlen