AWStats openSUSE 11.4

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von ufreier, 5. Sep. 2011.

  1. ufreier

    ufreier New Member

    Hi,

    gibt es da etwas besonderes zu beachten? Nach Anleitung doch eigentlich nur AWStats installieren. Die 4 Pfade in Serverkonfiguration -> Web sind an SUSE angepasst, es passiert aber ... gar nichts, also auch keine Fehlermeldungen in Logdateien. Die /etc/awstats/awstats.$domain.conf-Dateien werden jede Nacht um 00:30 neu geschrieben und beinhalten alle einen Include auf eine /etc/awstats/awstats.conf, die es nicht gibt. Es gibt dort nur awstats.smtp.conf, awstats.vsftp.conf und awstats.web.conf. Liegt es daran?

    Gruß, Uwe
     
  2. Till

    Till Administrator

    Das kann sein. Kopier mal die awstats.web.conf nach awstats.conf
     
  3. ufreier

    ufreier New Member

    Danke, das war's. Und in der /etc/sysconfig/apache2 noch AWSTATS in die APACHE_SERVER_FLAGS aufnehmen damit die IfDefines aus der /etc/apache2/conf.d/awstats.conf ziehen und der AWStats seine bunten Bildchen und Styles findet.

    Gruß, Uwe
     
  4. ufreier

    ufreier New Member

    awstats auf deutsch

    jetzt bin ich am gleichen Punkt wie der Thread http://www.howtoforge.de/forum/installation-und-konfiguration-12/awstats-deutsch-3674/, awstats bleibt trotz 'Lang=de' (und der Korrektur des fehlenden " bei DirLang=/usr/share/awstats/lang" in openSUSE 11.4) sowie der Neugenerierung der Stats auf englisch. Hat da eigentlich inzwischen jemand eine Lösung? Ich generiere auf einem anderen Server von mir auch mit awstats, dort übergebe ich aber "-lang=de' explizit dem awstats_buildstaticpages.pl - geht hier ja schlecht.

    Gruß, Uwe
     
  5. Till

    Till Administrator

    Das ist im SVN geändert worden und wird mit ISPConfig 3.0.4. veröffentlicht.
     

Diese Seite empfehlen