Beim setzen des Autoreply werden Aliase gelöscht

Dieses Thema im Forum "Allgemein" wurde erstellt von vistree, 19. März 2010.

  1. vistree

    vistree Member

    Hallo,
    ich habe gerade etwas sehr bedenkliches festgestellt:
    Wenn ich bei einem Benutzer als Admin oder als Kunde den Autoreply einschalte / manipuliere, dann werden für die Mailbox sämtliche Aliase gelöscht. ISPconfig zeigt zwar noch die Alias-Adressen an, es wird aber diie Ziel-Email-Adresse gelöscht.

    Ist das nur bei mir so, oder ergeht das sonst noch jemandem so? Gibt es hier einen Bugfix???

    Verhalten tritt auf nach dem Update auf 3.0.2 (auf Debian Lenny nach Howto eingerichtet)
     
  2. Germanius

    Germanius New Member

  3. Till

    Till Administrator

    Ist bereits im SVN gefixt.
     
  4. vistree

    vistree Member

    Hallo ihr beiden,
    danke für die Bestätigung und den Hinweis auf den Fix.
    Dazu habe ich jetzt eine Frage: ich habe bisher ganz rückständig nur über die offiziellen Pakete mit den Installern gearbeitet. Kann ich hier nun gefahrlos die SVN-Version drüberbügeln?? Gibt es da irgendwo Tipps, wie man das am besten anstellt?
    Für mich wäre z.B. wichtig, dass die Postfix-Einstellungen erhalten bleiben ....

    Für das konkrete Problem: sind hier mehrere Dateien betroffen, oder könnte man z.B. einzelne Dateien aus dem SVN laden und ins System einspielen?

    Grüße und ein schönes Wochenende
     
  5. Till

    Till Administrator

    Nein. das sollte man auf Produktivsystemen nie machen.

    Es ist nur eine Datei betroffen. Du kannst Dir für jeden Bugfix direkt im SVN ansehen, welche Dateien betroffen sind und sogar auch welche Zeilen dafür geändert wurden.

    In diesem Fall ist es die Datei /usr/local/ispconfig/interface/web/mail/mail_user_edit.php
     
  6. vistree

    vistree Member

    Super - Danke!
     
  7. vistree

    vistree Member

    Sorry, jetzt muss ich doch noch mal rückfragen:
    @Till: Ich habe jetzt mal im Bugtracker geschaut - da gibt es keinen Verweis auf die betroffenen Dateien.
    Das bedeutet, ich muss das direkt im SVN ablesen können? Kann man das Online einsehen (und auch die Dateien Online erreichen)? Oder muss ich das auf jeden Fall über ein SVN-Tool auf meinem Server machen. Sorry für die merkwürdigen Fragen, aber SVN habe ich bisher noch nie benutzt.
     
  8. vistree

    vistree Member

    Hmm, leider geht das immer noch nicht.
    Also, ich habe mir über checkout das svn-trunk-Archiv auf meinen Server geladen. Dann habe ich über cp -f die Datei mail_user_edit.php auf meinem Server ersetzt.
    Apache neu geladen - Leider werden Aliase und Weiterleitung jetzt aber immer noch gelöscht. Mache ich da irgendwas falsch? Wird die problematische Datei irgendwo noch von ispconfig gecached??

    edit: vergesst es: war zu doof zum Kopieren ;-( Habe die Datei eine Ebene zu hoch eingefügt. Funktioniert nun prima!!!
     
    Zuletzt bearbeitet: 20. März 2010
  9. Till

    Till Administrator

    Die Liste der von einem Fix betroffenen Dateien kannst Du im SVN Log (welches mit jedem gängigen SVN Client einsehbar ist) sehen.
     

Diese Seite empfehlen