Berechtigungsprobleme gesamte Serverebene

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von iceget, 2. Feb. 2010.

  1. iceget

    iceget Member

    Hallo Liebe Community,

    und zwar habe ich ein riesen Problem:

    ich verwende die aktuellste ISP Config 2 Version,
    und ein Kollege von mir hat unbeabsichtigt ein Backup direkt auf die ROOT entpackt.

    Nun startet der die halben Dienste nicht mehr, da er einfach "keine Berechtigung" schreibt.

    Nun hab ich mir gedacht wenn ich ein chmod -R 777 /* mache, sollte das Problem behoben sein, ...

    jetzt fährt der Server nicht mehr hoch..

    Was kann ich noch tun? Per Konsole komm ich aber noch rauf auf den Server nur nicht mehr per SSH. Gibt's da eine Möglichkeit das ich die ganzen rechte wieder auf die Defaultrechte zurücksetzten kann (für die gesamten Systemdienste usw)..

    Ich hoffe ihr könnt mir helfen! Bin am verzweifeln!

    VIELEN DANK!
     
  2. Till

    Till Administrator

    Von so einem Tool hab ich bis jetzt noch nichts gehört. Hast Du mal bei google gesucht? Welche Linux distribution verwendest Du?

    Ansonsten solltest Du nebenbei schonmal versuchen alle wichtigen dateien zu sichern, um not falls die websites und amil accounts auf einem neu aufgesetzten System wieder herzustellen.

    Der Thread hier enthält eine Menge infos dazu:

    http://www.howtoforge.com/forums/showthread.php?t=2717
     
  3. iceget

    iceget Member

    Hallo Till,

    ich verwendet Debian 4.0... [etch]

    Gibts da wirklich keine andere Möglichkeit :(

    Ich habe nun Zugriff auf die Konsole, direkt am Server...

    Vielen Dank!

    PS wenn ich das System neu aufsetzten müsste, kann ich nach der anleitung gehen die Du mir geschickt hast?

    Vielen Dank!
     
  4. Till

    Till Administrator

  5. iceget

    iceget Member

    Re

    Hallo Till,

    vielen dank für deine antwort!

    Habe gestern das System neu aufgesetzt!

    Leider konnte ich die MySQL Datenbank nicht korrekt exportieren.

    Ich habe 1:1 den selben MySQL Dienst installiert, und die Datenbank dateien mit den der frischen Installation ersetzt!

    Funktioniert eigentlich wunderbar, nur habe ich nun das Problem das die gesamten Umlaute zwar in der Datenbank richtig dargestellt werden, nur jedoch mit z.B. Typo3 wird ein umlaut als viereck dargestellt.

    Wo kann ich dies ändern, das auch die Umlaute wieder korrekt angezeigt werden? Wie gesagt, habe 1:1 die selbe Installation durchgeführt wie schon damals, und nur die Datenbankdateien (auch ISPConfig) ersetzt, und es funktioniert eigentlich wieder alles!

    Nur das Problem mit der Datenbankabfrage, wieso nun statt den umlauten ein viereck oder Fragezeichen dargestellt wird, obwohl aber in der Datenbank alle Umlaute vorhanden sind!

    Hoffe Du kannst mir helfen!

    Vielen dank für die Anleitung, ohne diese würde der Server heute noch immer stehen!

    Eine zweite Frage hätte ich da noch:
    ich habe bis jetzt (leider) alle meine Backups mit tar xfvz BACKUP.tar.gz /pfad1 /pfad2 /pfad3, ... erstellt.

    Ist dies nicht korrekt?

    Oder sollte ich das so sichern wie es Falco beschrieben hat (mit dem P vorne).

    Vielen recht herzlichen dank!

    MfG
    --
    Markus
     
  6. Till

    Till Administrator

    Das mity typo3 muss nicht unbedingt an der datenbank liegen. Schau mal nach, was in der apache Konfigurationsdatei als default charset drin steht. Je nachdem was drin steht, kannst Du mal versuchen auf utf8 bzw. latin1 umzuschalten und apache dann neu starten.

    Also der Befehl ist zum entpcken (x = extract), zum Packen verwendet man:

    tar pcfz dateien.tar.gz /pfad/zu/dateien/

    Das p ist wichtig, es steht für preserver und sorgt dafür, dass bei der Sicherung auch alle Dateirechte und Eigentümer mitgesichert werden. Wenn Du es ohne "p" machst, dann gehören nach dem Entpacken alle Dateien dem root User, mit "p" gehören sie den "original" usern.
     
  7. Laubie

    Laubie Member

    Das ist ein typisches Zeichensatzproblem.
    Hatte ich auch schon mal, als ich von einem win-server mit dem din-iso-irgendwas zeichensatz auf nen debian mit UTF-8 umgestiegen bin.

    Da kannste dir nen Wolf nach googlen, so viele Hilfe tutorials gibts da ;)
    Ich hab damals in die Datenbank-öffne-Datei folgenden Text eingefügt:
    Code:
     
    mysql_query("SET NAMES 'utf8'"); 
    mysql_query("SET CHARACTER SET 'utf8'");
    
    dann die ganze Seiten auf utf8 eingestellt und fertig :)

    Grüße
    Laubie
     
  8. iceget

    iceget Member

    Re

    Hallo, und Vielen Dank für die super Antworten!

    Habe das Problem nun gelöst (vielen dank Till), ich habe meine alte apache2.conf mit der neuen verglichen und bemerkt das folgendes auskommentiert war:
    #AddDefaultCharset ISO-8859-1

    nachdem ich das auf

    AddDefaultCharset ISO-8859-1

    geändert hatte, funktionierte es nach einem Force-Reload des Apache2's sofort!

    Vielen Dank!

    Okay also werde ich meine Backupscripts anpassen!

    Eine kleinigkeit habe ich trotzdem noch:
    Wenn ich die MySQL Datenbank starte, mekert er:
    ns1:/etc/apache2# /etc/init.d/mysql restart
    Stopping MySQL database server: mysqld failed!
    Starting MySQL database server: mysqld already running.
    /usr/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user
    'debian-sys-maint'@'localhost' (using password: YES)'

    Das kam erst nachdem ich die Dateien vom alten Server mit den Dateien auf dem neuen ersetzt habe. Kann ich das irgendwie "beheben"?

    Per PHPMyAdmin und root komme ich ohne Probleme auf die MySQL Datenbanken drauf, ...

    Noch eine kleinigkeit: ich sichere die Datenbanken zur Zeit nur mittels tar Befehl (tar cfvz MySQL.tar.gz /var/lib/mysql). Leider musste ich feststellen das wenn die DB gerade schreibt, dann diese Tables verloren sind...

    Wie kann ich das besser sichern?

    Und meine allerletzte Frage:
    Wieso Funktioniert trotz des 1:1 imports das Roundcube Webmail nicht mehr? Es kommt einfach eine weisse Website, ... hat bestimmt auch was mit der Sicherung von der MySQL Datenbank zu tun, oder...?

    Vielen recht herzlichen dank für eure hilfe!

    glg Markus
     

Diese Seite empfehlen