Big problem @ amavisd

Dieses Thema im Forum "Allgemein" wurde erstellt von sence123, 14. Okt. 2009.

  1. sence123

    sence123 New Member

    Hey,

    bei mir landen ca 30-40 % der Sauberen Emails im Virus folder, sogar wenn ich eine Antwort von diesem Forum bekomme -.-

    Wie kann ich das einstellen, dass die Mails auf jedenfall ausgeliefert werden mit dem ***spam***

    das ist gerade sehr tödlich :/

    --------------------
    dann wollte ich die releasen mit amavisd-realease name
    und bekomme den Fehler
    amavisd-release badh-4QQ4piZAaanN
    450 4.5.0 Failure: File /var/lib/amavis/virusmails/badh-4QQ4piZAaanN does not exist at (eval 94) line 374, <GEN68> line 5.


    ------------------------
    wie kann ich alle auf einmal wieder frei geben ? :////

    dankeeeeeeee
     
  2. sence123

    sence123 New Member

    zusatz

    /etc/amavis/conf.d/25-amavis_helpers
    1. $unix_socketname = "/var/run/amavis/amavisd.sock";
    2. $interface_policy{’SOCK’} = ‘AM.PDP-SOCK’;
    3. $policy_bank{’AM.PDP-SOCK’} = {
    4. protocol => ‘AM.PDP’,
    5. auth_required_release => 0,
    6. };
    -------------
    root@ha-mailone:/var/lib/amavis/virusmails/W# amavisd-release spam-WNfWSwGAPAaj
    450 4.5.0 Failure: File /var/lib/amavis/virusmails/spam-WNfWSwGAPAaj does not exist at (eval 94) line 374, <GEN26> line 5.
    root@ha-mailone:/var/lib/amavis/virusmails/W# amavisd-release spam-WNfWSwGAPAaj.gz
    450 4.5.0 Failure: File /var/lib/amavis/virusmails/spam-WNfWSwGAPAaj.gz does not exist at (eval 94) line 374, <GEN26> line 5.



    -----
    root@ha-mailone:/var/lib/amavis/virusmails/4# amavisd-release /var/lib/amavis/virusmails/4/spam-40ic0joLAp7o.gz
    Invalid quarantine ID: /var/lib/amavis/virusmails/4/spam-40ic0joLAp7o.gz
    amavisd-release version 1.5
    Usage: $ amavisd-release mail_file [secret_id [alt_recip1 alt_recip2 ...]]
    or to read request lines from stdin: $ amavisd-release -


    -----------------------------------------------

    und die Mails von Freenet und web, werden als Spam behandelt :/
    hier mal ein Auszug aus dem Log:

    -Spam-Flag: YES
    X-Spam-Score: 9.64
    X-Spam-Level: *********
    X-Spam-Status: Yes, score=9.64 tagged_above=3 required=6.9 tests=[AWL=-1.348,
    HTML_IMAGE_ONLY_08=2.432, HTML_MESSAGE=0.001,
    HTML_SHORT_LINK_IMG_1=1.078, MPART_ALT_DIFF_COUNT=1.882,
    TRACKER_ID=2.696, TVD_SPACE_RATIO=2.899]
    Received: from ([127.0.0.1])
    by localhost () (amavisd-new, port 10024)
    with ESMTP id 3XA1uRQJqU+b for <myaddress@my.de>;
    Wed, 14 Oct 2009 13:17:56 +0200 (CEST)
    Received: from mout7.freenet.de (mout7.freenet.de [195.4.92.97])
    by (Postfix) with ESMTPS id 573FC10DC0E3
    for <myaddress@my.de>; Wed, 14 Oct 2009 13:17:56 +0200 (CEST)
    Received: from [195.4.92.15] (helo=5.mx.freenet.de)
    by mout7.freenet.de with esmtpa (ID user@freenet.de) (port 25) (Exim 4.69 #92)
    id 1My1qY-0001tj-Nt
    for myaddress@my.de; Wed, 14 Oct 2009 13:16:46 +0200
    Received: from web12.emo.freenet-rz.de ([194.97.107.134]:53605)
    by 5.mx.freenet.de with esmtpa (ID user@freenet.de (port 25) (Exim 4.69 #94)
    id 1My1qY-0001gd-Ky
    for myaddress@my.de; Wed, 14 Oct 2009 13:16:46 +0200
    Received: from localhost ([127.0.0.1] helo=emo.freenet.de)
    by web12.emo.freenet-rz.de with esmtpa (Exim 4.69 1 (Panther_1))
    id 1My1qM-0007MP-UR
    for <myaddress@my.de>; Wed, 14 Oct 2009 13:16:35 +0200
    Date: Wed, 14 Oct 2009 13:16:34 +0200
    From: user@freenet.de
    Subject: ***SPAM*** hallo
    To: myaddress@my.de
    MIME-Version: 1.0
    X-Abuse: 505133407 / 81.210.145.57
    Message-Id: <anyid@email.freenet.de>
    User-Agent: freenetMail
    Content-Type: multipart/alternative; boundary="emo_01_eanyid"


    Vielen Dank
     
    Zuletzt bearbeitet: 4. Aug. 2010
  3. Till

    Till Administrator

    Du musst ja irgendwas an den Standardeinstellunegn von aispconfig geändert haben. Stell mal bitte bei den Policies wieder das ein, was ursprünglich drin stand und dann check mal die amavisd-conf, was Du als final_spam_destiny drin stehen hast, die muss auf pass stehen und wird so von ispconfig ausgeliefert.
     
  4. sence123

    sence123 New Member

    guten morgen Till

    Leider hatte ich zum Anfang hin nichts verstellt gehabt,
    hatte den Server installiert gehabt und dann ab ins RZ :/

    da ich sonst keine Probleme damit hatte, und das nun das erste mal passiert ist.

    von der Grundeinstellung stand er nicht auf D_PASS
    das hab ich nun schon geändert gehabt, nachdem ich nach langem suchen endlich mal nen halbwegs gutes howto fand ,)

    was wird standartmäßig benutzt für Spam, amavis oder spamassasin ?
    und meine letzte Frage, wie kann ich auf einmal alle emails freigeben mit amavis

    vielen dankkkkk
     
  5. Till

    Till Administrator

    Beides. amavisd ist nämlich eine Applikation zur Einbindung und Nutzung der spamassassin Libraries zum filtern von Spam in einem postfix setup.
     
  6. sence123

    sence123 New Member

    re

    ah ok danke,

    aber eine Lösung um alle Freizugeben emails über amavis-realease freizugeben gibt es anscheinend nicht :/

    najut danke aber schonmal
     
  7. Phenomenon

    Phenomenon New Member

    Hi,

    ich habe Heute auf die Version 3.0.1.6 aktualisiert. Egal, ob ich vom STABLE oder SVN aktualisiert habe, jedesmal wurde meine amavisd Konfiguration so geändert, das $final_spam_destiny auf G_DISCARD gestellt wurde. In der Datei amavisd_user_config.master (ispconfig3_install/install/tpl) steht $final_spam_destiny auch auf G_DISCARD. Wenn ISPConfig G_PASS als Standard ausliefert, sollte dies nicht dann auch in dieser Datei so stehen?

    Ich weiss auch, das ich das nach einem Update manuell ändern kann, aber sollte dies nicht schon automatisch mit dem Update so eingespielt werden, sodass wir das nicht ständig ändern müssen? Zudem wäre eine Einstellung diesbezüglich im Webinterface wünschenswert.

    Ansonsten kann ich nur ein echt großes Lob für euer Projekt aussprechen. Macht weiter so!
     
  8. Till

    Till Administrator

    Sorry, hatte mich oben verschrieben. Es muss natürlich auf $_Discard stehen, so wie es ispconfig ausliefert. Alles weitere stellst Du ja in den policys von ispconfig ein und dort wird nichts durch updates überschrieben.
     
  9. sence123

    sence123 New Member

    fehler in der Std einstellung ?

    Hey,

    jap war bei mir auch von Grund auf, hatte neu installiert gehabt und dann das update gemacht, also irgendwo dort muss nen fehler im Installer sein.

    Till schaust du dir das mal bitte an, ob dort irgendwo nen Fehler ist, oder ein fehlerhaftes Script vorliegt

    danke ,)
     
  10. Till

    Till Administrator

    Hab ich bereits beantwortet. Der Installer ist korrekt, ich hatte mich bei der Aussage oben im Thread geirrt. Es muss $_Discard heißen.
     

Diese Seite empfehlen