[Cent OS 5.5] - Apache Server plötzlich nicht mehr erreichbar?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von WolfCG, 21. Mai 2010.

  1. WolfCG

    WolfCG New Member

    Hallo Zusammen...

    Sorry dass ich mich schon wieder melde aber ich beginne durchzudrehen.? *g*
    Erst läuft alle ganz gut, danach plötzlich nicht mehr. Mein Server ist unter http://scvserv.homedns.org erreichbar. Ich habe auch die Domain www.scvschweiz.ch registriert und eine weiterleitung auf scvserv.homedns.org gemacht. Damit alls funktioniert hab ich einen DNS Dienst erhalten, bei dem ich bis zu 100 DNS Zonen selbst verwalten kann.

    Habe ein CNAME, ein SOA Record gemacht etc, hatte funktioniert und ich konnte auch über www.scvschweiz.ch auf den Server zugreifen. Jetzt plötzlich geht nichts mehr !! www.scvschweiz.ch klappt nur noch wenn ich das lokal auf dem Server selbst eingebe. Auswärts kommt immer die Meldung dass die Antwort zu lange dauern würde.

    Wo liegt der hAse begraben?? In einer ConfigDatei?? Wenn ja in welcher und muss dort www.scvschweiz.ch oder nur scvschweiz.ch (ohne www)) stehen? Oder liegts doch am Zonendienst??

    Hier die ZOnenEinstellungen:

    Danke für die Hilfe / Hinweise.

    Gruss
    Wolf
     
  2. Till

    Till Administrator

    Dann ist ja schon mal klar, dass es mit Deinem Server nichts zu tun hat. Wenn es lokal geht aber nicht extern, dann liegt es entweder an Deinem Router bzw. Firewall oder aber am Dyndns Eintrag,
     
  3. WolfCG

    WolfCG New Member

    Hi Till

    Also folgendes: Habe mir nun Debian 5 Lenny installiert und alles gemäss HowTo eingerichtet. Ich habe für das Internet lediglich ein normales "Kabelmodem" (das Ineternt läuft über das TV Kabel). Auf das Modem Zugreifen kann ich, aber nichts einstellen, Sprich es hängt kein Router dran.

    Von www.wieistmeineip.de weiss ich, dass meine feste IP 91.190.28.145 ist. In den Netzwerkeinstellungen (etc/network/interfaces) habe ich folgendes drin:

    Ich habe gemäss HowTo bei dhcp dann static hingeschrieben, allerdings kommt dann beim Restart des Netzwekres folgende Fehlermeldung:

    Also liess ich es bei dhcp. Nun gut, weiter im Text:
    Der Server ist von aussen NUR über die DynDNS Adresse http://scvserv.homedns.org erreichbar, auch ISPConfig usw funktionieren darüber von Aussen sehr gut.

    Aber über www.scvschweiz.ch geht leider nichts, obwohl ich bei der DNS Zonenverwaltung (ein Extra Angebot von meinem Domainanbieter Novatrend.ch, wo ich die Domain registriert habe) ein CNAME hinzugefügt und alles eingestellt habe. Vielleicht ist dort etwas falsch?? ich weis es nicht.

    Hier noch die /etc/hosts-Datei:

    Wo liegt hier der Fehler'? Meinersichts sollte alles funktionieren, tut es auch, nur nicht unter der Domain www.scvschweiz.ch von aussen. DIe Adresse bei DEBIAN (also auf dem Server) im Browser eingegeben funktioniert, aber Aussenzugriff geht nur über scvserv.homedns.org !

    Warum??

    Gruss
    Wolf
     
  4. F4RR3LL

    F4RR3LL Member

    laut dig zeigen scvschweiz.ch. und www.scvschweiz.ch. auf die IP 194.150.248.10.
    Stells richtig ein und es wird gehen.
     
  5. WolfCG

    WolfCG New Member

    Was ist denn dig?

    Und wieso kommt der auf die IP Adresse?? Ich hab in der Netzwerk-Config diese IP Adresse 194.150.248.10 nirgends stehen!!

    Kann das wohl daran liegen dass scvschweiz noch in einem anderem Hosting aktiv ist ?? Zb. Bei netland.ch??


    Gruss
    Wolf
     
  6. Till

    Till Administrator

    Dig ist ein programm zum Abfragen von DNS Servern, es macht also das gleiche was Dein Browser im Hintergrund vor dem Abruf der Webseite macht.

    Das kann sein. Du musst in dem DNS Server des Providers, bei dem die Domain liegt einen SNS A-Record auf die externe IP Deines Servers einrichten. Oder zumindest einen CName Record auf eine Domain, die auf Deinen Server verweist. Irgendwelche sonstigen Formen der Weiterleitung, die der Provider vielleicht anbietet, werden nicht funktionieren.
     
  7. WolfCG

    WolfCG New Member

    Hi Till

    Also von all dem wo Du gesagt hast habe ich ja alles gemacht. Die Domain scvserv.homedns.org ist eine Dynamische Domain, welche lediglich immer auf die automatische und aktuelle IP meines Servers zeigt. die IP Meines Server bleibt aber immer die gleiche, da Fix!

    Ich hab folgende Zonen eingerichtet (siehe Bild):
    [​IMG][​IMG]

    Vielleicht ist doch irgendwo dort etwas falsch??
    Vom ehemaligen Hoster sind alle Daten schon seit 2 Tagen weg.

    Gruss
    Wolf
     
    Zuletzt bearbeitet: 25. Mai 2010
  8. Till

    Till Administrator

    Die Domain zeigt immer noch auf die falsche IP. Da das ein problem mit dem DNS System dieses Anbieters oder aber dem Domain Registrar ist, würde ich Dir raten dass Du Dich mal an deren Support wendest.
     

Diese Seite empfehlen