[CentOS 5.5] - SquirrelMail macht Probleme..

#1
Hallo Zusammen

Ich habe meinen eigenen Server wie auf http://www.howtoforge.com/perfect-server-centos-5.2-ispconfig-3-p3 beschrieben eingerichtet und installiert. Alles klappte wunderbar.

Jetzt ist die Webseite http://scvserv.homedns.org wunderbar erreichbar. Auch das ISPConfig 3 ist verfügbar und funktioniert sowie auch phpmyAdmin klappt wie gewünscht,.

Jedoch habe ich ein problem mit dem Webmail. nach der Installation von Squirrelmail konnte ich einmal unter http://scvserv.homedns.org/webmail dieses E-Mail Programm im Browser aufrufen. Jetzt gehts plötzlich nicht mehr. Anstatt eine Loginseite kommt einfach der gesamte Code der index.php Datei!! Nichts geschieht. Auch die direkte Eingabe des SRC/Configtest oder login.php etc bleibt erfolglos.

Habe alles neu installiert, ich kriege es nicht mehr hin und ich weis nicht wo hier der Hase begraben liegt?? http://scvserv.homedns.org/webmail sollte Squirrelmail starten. Anstatt irgendetwas steht der komplette PHP Source

1. Was soll das und wie kommt es dazu?
2. Wie kann ich den Fehler beheben und wo?

bin 3. noch nicht ganz vertraut mit Linux.

Grüsse aus der Schweiz
Wolf
 
#3
Hm.. ja da hast Du Recht!! mist!! hatte ich doch installiert gehabt? naja dann mache ich es nochmal... ev klappts dann..

thx.. warum dann aber PHPINFO dennoch funktioniert hat bis vor wenige sekunden weiss ich aber auch nicht.
Edit:pHP war / ist installiert. Das System sagt mir nämlich:

Setting up Install Process
Package php-5.1.6-27.el5.i386 already installed and latest version
Hab jetzt mal ein reinstall gemacht und den httpd Dienst neu gestartet.. Aber funktioniert weiterhin nicht mehr. An was das wohl liegt??
 
Zuletzt bearbeitet:
#5
Fehler gefunden!

Hat sich inziwschen erledigt. AHbe den Fehler gefunden.

Bei einer Einstellung von ISPConfig3 war es irgendwie möglich, dass man für jede einzelne Webseite bestimmen kann ob PHP benutzt werden darf oder nicht und fals dies der Fall ist sollte man etwas ausklammern.

Das, wo ich in der phpd.conf ausgeklammert hab, hab ich nun wieder eingebunden also so:

# Cause the PHP interpreter to handle files with a .php extension.
#
AddHandler php5-script .php
AddType text/html .php
Die beiden AddHandler und AddType waren ausgeklammert. Jetzt ohne Ausklammerung klappts..

Gruss
Wolf
 

Werbung