cgi-bin leitet an falsche Stelle

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Martur, 7. Mai 2013.

  1. Martur

    Martur New Member

    Großes Chaos, nachdem ich meinen Server versehentlich von Debian 5 nach 7 geupdatet habe. Inzwischen ist fast alles wieder im Lot, ausser dass alle domain.xyz/cgi-bin/script.cgi Aufrufe, die auf /var/www/domain.xyz/cgi-bin/script.cgi verweisen sollten nach usr/lib/cgi-bin/script.cgi geleited werden.
    Ich nehme an, dass das mit der /etc/apache2/sites-enabled/000-default zu tun hat, denn dort sind für's CGI-bin genau diese Einstellungen drin. Ich habe aber keine Ahnung warum das so verquer verarbeitet wird.



    Hier mal meine Einstellungen:
    default.conf

    Code:
    <VirtualHost *:80>
            ServerAdmin webmaster@localhost
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
            [B]ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/[/B]
            [I]<Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>[/I]
            ErrorLog ${APACHE_LOG_DIR}/error.log
            LogLevel warn
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>
    
    domain.xyz.conf

    Code:
    <Directory /var/www/domain.xyz>
                    AllowOverride None
                    Order Deny,Allow
                    Deny from all
    </Directory>
    <VirtualHost *:80>
                                            DocumentRoot /var/www/domain.xyz/web
    
                    ServerName domain.xyz
                    ServerAlias fotos.domain.xyz
                    ServerAdmin webmaster@domain.xyz
                    ErrorLog /var/log/ispconfig/httpd/domain.xyz/error.log
                    Alias /error/ "/var/www/domain.xyz/web/error/"
                    ErrorDocument 400 /error/400.html
                    ErrorDocument 401 /error/401.html
                    ErrorDocument 403 /error/403.html
                    ErrorDocument 404 /error/404.html
                    ErrorDocument 405 /error/405.html
                    ErrorDocument 500 /error/500.html
                    ErrorDocument 502 /error/502.html
                    ErrorDocument 503 /error/503.html
                    <IfModule mod_ssl.c>
                    </IfModule>
                    <Directory /var/www/domain.xyz/web>
                                    Options FollowSymLinks
                                    AllowOverride All
                                    Order allow,deny
                                    Allow from all
                                    AddType text/html .shtml
                                    AddOutputFilter INCLUDES .shtml
                                    Options +Includes
                    </Directory>
                    <Directory /var/www/clients/client1/web2/web>
                                    Options FollowSymLinks
                                    AllowOverride All
                                    Order allow,deny
                                    Allow from all
                                    AddType text/html .shtml
                                    AddOutputFilter INCLUDES .shtml
                                    Options +Includes
                    </Directory>
                    <IfModule mod_perl.c>
                            PerlModule ModPerl::Registry
                            PerlModule Apache2::Reload
                            <Directory /var/www/domain.xyz/web>
                                    PerlResponseHandler ModPerl::Registry
                                    PerlOptions +ParseHeaders
                                    Options +ExecCGI
                            </Directory>
                <Files *.pl>
                                    SetHandler perl-script
                </Files>
                    </IfModule>
            [I]<Directory /var/www/clients/client1/web2/cgi-bin>
                            Order allow,deny
                            Allow from all
                    </Directory>[/I]
                    [B]ScriptAlias  /cgi-bin/ /var/www/clients/client1/web2/cgi-bin/[/B]
                    AddHandler cgi-script .cgi
                    AddHandler cgi-script .pl
                    <IfModule mod_suexec.c>
                            SuexecUserGroup web2 client1
                    </IfModule>
                    <FilesMatch "\.ph(p3?|tml)$">
                                    SetHandler None
                    </FilesMatch>
                    <IfModule mod_fcgid.c>
                                    IdleTimeout 300
                                    ProcessLifeTime 3600
                                    DefaultMinClassProcessCount 0
                                    DefaultMaxClassProcessCount 100
                                    IPCConnectTimeout 3
                                    IPCCommTimeout 360
                                    BusyTimeout 300
                    </IfModule>
                    <Directory /var/www/domain.xyz/web>
                                    AddHandler fcgid-script .php .php3 .php4 .php5
                                    FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
                                    Options +ExecCGI
                                    AllowOverride All
                                    Order allow,deny
                                    Allow from all
                    </Directory>
                    <Directory /var/www/clients/client1/web2/web>
                                    AddHandler fcgid-script .php .php3 .php4 .php5
                                    FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
                                    Options +ExecCGI
                                    AllowOverride All
                                    Order allow,deny
                                    Allow from all
                    </Directory>
                    RewriteEngine on
                    RewriteCond %{HTTP_HOST}   ^fotos\.domain\.xyz$ [NC]
                    RewriteCond %{REQUEST_URI} !^/webdav/
                    RewriteCond %{REQUEST_URI} !^/fotos/
                    RewriteRule   ^/(.*)$ /fotos/$1
                    <IfModule mpm_itk_module>
                            AssignUserId web2 client1
                    </IfModule>
                    <IfModule mod_dav_fs.c>
                            <Directory /var/www/clients/client1/web2/webdav>
                                    <ifModule mod_security2.c>
                                            SecRuleRemoveById 960015
                                            SecRuleRemoveById 960032
                                    </ifModule>
                                    <FilesMatch "\.ph(p3?|tml)$">
                                            SetHandler None
                                    </FilesMatch>
                            </Directory>
                            DavLockDB /var/www/clients/client1/web2/tmp/DavLock
                    </IfModule>
    </VirtualHost>
    
    Ich kann in der Konfiguration leider keinen Fehler finden und hoffe, dass mir hier geholfen wird.
    P.S.: Ich hab die neueste Version von ISPconfig drauf. (und auch von allen anderen das neueste stable)

    Nachtrag:
    Ich habe jetzt default deaktiviert und im log festgestellt, dass der Aufruf fehlgeleitet wird. Anstatt nach /var/www/domain.xyz/cgi-bin wird nach /var/www/domain.xyz/web/cgi-bin geleitet. Deshalb wahrscheinlich auch der Weg über die default.conf.
     
    Zuletzt bearbeitet: 7. Mai 2013
  2. Martur

    Martur New Member

    Erledigt

    Die Lösung des Problems war, dass die Aliase nicht richtig eingerichtet waren. Allen, die sich die Mühe gemacht haben hier mal reinzuschauen ein Dankeschön.
     

Diese Seite empfehlen