CGI Frage

#1
Hallo Leute,

ich verwende die aktuelle ISPConfig 3 Version und habe in einem vhost mailgraph am laufen.

Ereichbar unter: Förderdiagnostik, Förderdiagnose

Nun ist dies jetzt für alle Welt einsehbar. Meine Idee war die das ich ein normales Unterverzeinis aufmache, mit htaccess schütze und dieses Unterverzeichnis für CGI freigebe.

Folgendes habe ich in die Apache Direktive eingetragen:

Code:
<Directory /var/www/xyz/web/mailgraph/>
Options +ExecCGI
</Directory>
<Directory /var/www/clients/client0/web5/web/mailgraph/>
Options +ExecCGI
</Directory>
Funktioniert aber nicht. Fehler 403. Im error.log steht "Options ExecCGI is off for this directory"

Habt ihr eine Idee?

Danke und lg
redi78
 

Till

Administrator
#2
Sieht auf den erste Blick ok aus, hast es ja auch für beide möglichen Pfade gesetzt. hast Du mal nachgesehen ob es korrekt in die vhost config geschrieben wurde?
 
#3
mhhh anscheinend nicht. irgendetwas funktioniert da scheinbar nicht.

Code:
<Directory /var/www/xyz.at>
        AllowOverride None
        Order Deny,Allow
        Deny from all
</Directory>

<VirtualHost 192.168.1.10:80>
                    DocumentRoot /var/www/xyz.at/web
            
        ServerName xyz.at
        ServerAlias www.xyz.at
        ServerAdmin webmaster@xyz.at

        ErrorLog /var/log/ispconfig/httpd/xyz.at/error.log

        Alias /error/ "/var/www/xyz.at/web/error/"
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 502 /error/502.html
        ErrorDocument 503 /error/503.html

        <IfModule mod_ssl.c>
        </IfModule>

        <Directory /var/www/xyz.at/web>
                Options FollowSymLinks
                AllowOverride All
                Order allow,deny
                Allow from all
        </Directory>
        <Directory /var/www/clients/client0/web5/web>
                Options FollowSymLinks
                AllowOverride All
                Order allow,deny
                Allow from all
        </Directory>




        # cgi enabled
    <Directory /var/www/clients/client0/web5/cgi-bin>
            Order allow,deny
            Allow from all
        </Directory>
        ScriptAlias  /cgi-bin/ /var/www/clients/client0/web5/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # Clear PHP settings of this website
        <FilesMatch "\.ph(p3?|tml)$">
                SetHandler None
        </FilesMatch>
        # mod_php enabled
        AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@xyz.at"
        php_admin_value upload_tmp_dir /var/www/clients/client0/web5/tmp
        php_admin_value session.save_path /var/www/clients/client0/web5/tmp
    # PHPIniDir /var/www/conf/web5
        php_admin_value open_basedir /var/www/clients/client0/web5/web:/var/www/clients/client0/web5/tmp:/var/www/xyz.at/web:/srv/www/xyz.at/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/tine20:/var/lib/tine20:/tmp:/usr/share/php:/etc/tine20:/var/log/tine20


        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
            AssignUserId web5 client0
        </IfModule>

        <IfModule mod_dav_fs.c>
        # Do not execute PHP files in webdav directory
            <Directory /var/www/clients/client0/web5/webdav>
                <ifModule mod_security2.c>
                    SecRuleRemoveById 960015
                    SecRuleRemoveById 960032
                </ifModule>
                <FilesMatch "\.ph(p3?|tml)$">
                    SetHandler None
                </FilesMatch>
            </Directory>
            DavLockDB /var/www/clients/client0/web5/tmp/DavLock
            # DO NOT REMOVE THE COMMENTS!
            # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
      # WEBDAV BEGIN
            # WEBDAV END
        </IfModule>


</VirtualHost>
 

Till

Administrator
#4
Gibt es eine .err Version in sites-available? Wenn ja. benenne die aktuelle .vhost datei in .bak um, dann die .err in .vhost und dann starte apache neu, er wird wahrscheinlich nicht starten und etwas im error.log bemängeön, was in dem vhost nicht geht.
 
#5
Hi,

im Log des vhosts finde ich nun folgende Fehlermeldung:

Code:
[Wed Nov 20 14:23:57 2013] [error] Unable to configure RSA server private key
[Wed Nov 20 14:23:57 2013] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
 
#6
und das hier:

Code:
[Wed Nov 20 14:22:00 2013] [notice] mod_fcgid: process /var/www/ispconfig/keepalive.php(11349) exit(shutting down), get stop signal 9
 

Till

Administrator
#9
schalte erstmal ssl in den web settings aus (ssl checkbox). Dann müsste die cgi Änderungen im web eingetragen werden. aktuell kan ssl auch nicht funktionieren in der seite.

wenn Du ssl aktivieren willst, dann brauchst Du entweder den passenden key zum aktuellen cert, oder du musst ein neues ssl key / cert paar in ISPconfig erstellen.
 
#11
Hallo Till,

hat soweit alles funktioniert. Nur jetzt kann ich im Web root keine Files mehr aufrufen:

Code:
[error] [client xx.xx.xxx.xx] Directory index forbidden by Options directive: /var/www/xyz.at/web/
Da scheint etwas mit den Direktiven nicht zu stimmt. Wie kann ich das korrigieren. Allow Override steht auf "All"
 
#13
Hi Till,

aktueller Inhalter in Apache Direktiven:

Code:
<Directory /var/www/rds360.at/web/mailgraph/>
Options +ExecCGI
</Directory>
<Directory /var/www/clients/client0/web5/web/mailgraph/>
Options +ExecCGI
</Directory>
lg redi78
 

Till

Administrator
#14
Wenn Du Datilisten angezeigt bekpmmen möchtest im apache Webserver, dann musst Du "Options +Indexes" für das entsprechende Verzeichnis setzen.
 

Werbung

Top