Client denied by server configuration

#1
Guten Tag,

ich habe massive Probleme mit meiner Server Konfiguration, es handelt sich dabei um ein Aktuelles Debian Wheezy mit ISPConfig, fast CGI, Apache und Fast CGI.

Ich habe gestern versucht eine Seite Umzuziehen.
Dafür habe ich 2 Sub Domänen angelegt

1. media.gnitter.de
2. api.gnitter.de

Nun sollten diese Ordner Öffentlich sichtbar sein, dies habe ich gemacht mit einer .htaccess bei der Index aktiviert ist.

Kommen wir zu dem Problem.

In beiden Subdomänen habe ich die rechte für garnichts, sowie ich versuche auf eine Datei zuzugreifen erhalte ich im web die Meldung

You don't have permission to access /banner/apps/gildennachrichten-roelanda-de.png on this server
Wenn ich in den Server Log schaue so erhalte ich bei diesen Ordnern die Meldung
[Wed Sep 18 20:41:59 2013] [error] [client 87.168.248.60] client denied by server configuration: /media/
Ich kann es mir einfach nicht erklären warum.

Meine Apache httpdconf ist

im confd Ordner

<IfModule mod_dir.c>

#DirectoryIndex index.html index.cgi index.pl index.php index.xhtml index.htm
DirectoryIndex index.html index.htm index.shtml index.cgi index.php index.php3 index.pl index.xhtml

</IfModule>
<Directory /var/www/gnitter.de>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /var/www/gnitter.de/web

ServerName gnitter.de
ServerAlias www.gnitter.de
ServerAlias api.gnitter.de
ServerAlias media.gnitter.de
ServerAdmin webmaster@gnitter.de

ErrorLog /var/log/ispconfig/httpd/gnitter.de/error.log


<IfModule mod_ssl.c>
</IfModule>

<Directory /var/www/gnitter.de/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web7/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>




# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
# php as fast-cgi enabled
# For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
<IfModule mod_fcgid.c>
FcgidIdleTimeout 300
FcgidProcessLifeTime 3600
# FcgidMaxProcesses 1000
FcgidMaxRequestsPerProcess 5000
FcgidMinProcessesPerClass 0
FcgidMaxProcessesPerClass 100
FcgidConnectTimeout 3
FcgidIOTimeout 360
FcgidBusyTimeout 300
FcgidMaxRequestLen 1073741824
</IfModule>
<Directory /var/www/gnitter.de/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web7/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web7/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web7/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>

RewriteEngine on
RewriteCond %{HTTP_HOST} ^api\.gnitter\.de$ [NC]
RewriteCond %{REQUEST_URI} !^/webdav/
RewriteCond %{REQUEST_URI} !^/api/
RewriteRule ^/(.*)$ /api/$1
RewriteCond %{HTTP_HOST} ^media\.gnitter\.de$ [NC]
RewriteCond %{REQUEST_URI} !^/webdav/
RewriteCond %{REQUEST_URI} !^/media/
RewriteRule ^/(.*)$ /media/$1

# add support for apache mpm_itk
<IfModule mpm_itk_module>
AssignUserId web7 client1
</IfModule>

<IfModule mod_dav_fs.c>
# Do not execute PHP files in webdav directory
<Directory /var/www/clients/client1/web7/webdav>
<ifModule mod_security2.c>
SecRuleRemoveById 960015
SecRuleRemoveById 960032
</ifModule>
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
</Directory>
DavLockDB /var/www/clients/client1/web7/tmp/DavLock
# DO NOT REMOVE THE COMMENTS!
# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
# WEBDAV BEGIN
# WEBDAV END
</IfModule>


</VirtualHost>

Liebe Grüße,

Deex
 
Zuletzt bearbeitet:

Till

Administrator
#2
Liegt denn im Ordner /media/ eine index Datei? Wenn nicht, dann müsstest Du wahrscheinlich direcory indexes aktivieren wenn Du eine Dateiliste sehen möchtest. Außerdem kann essein dass Du irgendwo einen Alias für /media/ in Deriner apache config hast?
 
#3
Hi Till,

ich habe dort eine index datei, egal was ich mache es ist mir nicht erlaubt auf eine Subdomain mit namen Media zuzugreifen.

Ich durchsuche schon alle apache configurationen ich selbst habe nie sowas angelegt. Ich hoffe das ich irgendwas finde was es verweigert. Ich habe keine Chance den ordner zu verwenden.
 

Till

Administrator
#4
Das Problem kann auch auftreten wenn /media ein Linux System Ordner ist und apache daher versucht /media auf dem Server zu nehmen anstatt /media in der Webseite. Ggf. kannst Du media.deinedomain.de als vhostsubdomain anlegen und nicht als rewrite.
 
#5
Du hast Recht Till, es gibt natürlich bei mir das media verzeichnis des Servers.

Okay wie änder ich denn das? Muss ich dafür dann extra einen Vhost anlegen oder geht es auch über andere wege?
 

Till

Administrator
#6
HTML:
Du hast Recht Till, es gibt natürlich bei mir das media verzeichnis des Servers.

Okay wie änder ich denn das? Muss ich dafür dann extra einen Vhost anlegen oder geht es auch über andere wege?
Du legst über ispconfig eine vhostsubdomain an. die Funktion heißt so und ist im ispconfig webseiten Modul verfügbar wenn Du sie unter system > interface config aktiviert hast.
 

Werbung