connect to spamd on 127.0.0.1 failed, retrying

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Lonesome Walker, 7. Okt. 2008.

  1. Lonesome Walker

    Lonesome Walker New Member

    Hallo,

    nachdem ich die Nase gestrichen voll von der neuen Spam-Welle hatte, war ich so frei, die local.cf von Spammassassin anzupassen.

    Als ich dann die anderen .pre's durchgeguckt habe, habe ich noch folgende Module auskommentiert, damit sie aktiv geschaltet sind:

    in der v310.pre:
    ----------
    loadplugin Mail::SpamAssassin::plugin::DCC
    loadplugin Mail::SpamAssassin::plugin::TextCat

    Sooo, da die beiden Module aber nicht vorrätig waren (ich habe extra geguckt...), war ich so frei, und habe per cpan die Dingers kurzerhand selbst heruntergeladen.
    Naja, kompiliert war das ganze ja schnell, in das entsprechende /usr/share/perl-Verzeichnis im ispconfig-Ordner war es auch schnell kopiert, aber iwie ist da was schief gelaufen, denn seit dem Zeitpunkt habe ich folgende Einträge im mail.err:

    Lustig ist:
    die neuen Module funktionieren hervorragend, der SPAM aus Rußland wird mittlerweile weggeputzt (da ich selbst einen russischen Server betreibe, war das sehr schnell zu testen...), und man kann auch in den Email-Headern sehen, daß die Scores ordnungsgemäß eingetragen werden.

    Also, was muß ich tun, damit der eklige spamc (also nicht der spamd, sondern der Client) aufhört, ins Error-Log zu schreiben?
    Ich meine, ich ruf' den ja nirgends explizit auf.

    Durch die cpan-Kompilation/-Installation der Module hat sich zwangsweise der spamd auch neu mitkompiliert, aber der startet ja nirgends.

    Weiß wer Rat?

    Ebenfalls würde es mich interessieren, warum DCC nicht per Default als aktives Modul geführt wird (wegen der nicht freien Sourcen???)?


    Danke
     
  2. Till

    Till Administrator

    Welchen spamc rufts Du denn genau auf?
     
  3. Lonesome Walker

    Lonesome Walker New Member

    :( das würde mich ja auch interessieren, dann könnte ich es nämlich fixen...

    Wie schon gesagt, meine Vorgehensweise war, die Module in den Configs auskommentiert, festgestellt die fehlen, CPAN aufgerufen, mit "install Modulname" die Dinger nachinstalliert, kopiert, fettich.
    Festgestellt, daß sich nicht nur das Modul mit runtergeladen und kompiliert hat, sondern auch der Mail::SpamAssassin.

    Ja, und wo vorher unter /etc/mail/spamassassin nichts war, habe ich jetzt leider ein Verzeichnis mit Inhalt :rolleyes:


    Grrr, ich hasse CPAN/Perl :D
     
  4. Till

    Till Administrator

    Na du hast es doch selbst in die procmail scripte eingebaut da ispconfig spamc garnicht verwendet, Du musst also den Pfad zum spamc wissen.
     
  5. Lonesome Walker

    Lonesome Walker New Member

    Das ist ja das lustige:

    ebend nicht.

    Durch die Verwendung von CPAN hats da bissel viel vermurkst.
    Nachdem ich mit CPANPLUS das Zeug jetzt wieder alles rausgekratzt habe, ist auch (vorerst...?) Ruhe im Error-Log eingekehrt.

    Ich würde mich hüten, die sorgsam von ISPConfig gepflegten Sachen anzufassen :D
     

Diese Seite empfehlen