Cronjob killt den Apache

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von besterwosgibt, 3. Juli 2015.

  1. besterwosgibt

    besterwosgibt New Member

    Hi Leute,
    ich habe heute das Upgrade von 3.0.5.4p6 auf 3.0.5.4p8 wie üblich in meinem Multiserver-Setup durchgeführt.
    Alle Maschinen laufen sauber weiter, bis auf die mit den wichtigsten Webseiten. Der Apache wird vom ISPConfig-Cron neugestartet und kommt daraufhin nicht mehr zurück. Im Log steht hierzu folgendes (Loglevel Debug):
    Code:
    [Fri Jul 03 19:36:03 2015] [info] mod_fcgid: process /var/www/php-fcgi-scripts/web548/.php-fcgi-starter(8150) exit(shutting down), terminated by calling exit(), return code: 0
    [Fri Jul 03 19:36:03 2015] [info] mod_fcgid: Process manager 8077 stopped
    [Fri Jul 03 19:36:04 2015] [info] Init: Seeding PRNG with 656 bytes of entropy
    [Fri Jul 03 19:36:04 2015] [info] Init: Generating temporary RSA private keys (512/1024 bits)
    [Fri Jul 03 19:36:04 2015] [info] Init: Generating temporary DH parameters (512/1024 bits)
    [Fri Jul 03 19:36:04 2015] [info] Init: Generating temporary EC parameters (256 bits)
    [Fri Jul 03 19:36:04 2015] [info] Init: Initializing (virtual) servers for SSL
    [Fri Jul 03 19:36:04 2015] [info] mod_ssl/2.2.22 compiled against Server: Apache/2.2.22, Library: OpenSSL/1.0.1e
    [Fri Jul 03 19:36:04 2015] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Jul 03 19:36:04 2015] [notice] FastCGI: process manager initialized (pid 10640)
    [Fri Jul 03 19:36:04 2015] [info] mod_fcgid: Process manager 10642 started
    [Fri Jul 03 19:36:05 2015] [info] Init: Seeding PRNG with 656 bytes of entropy
    [Fri Jul 03 19:36:05 2015] [info] Init: Generating temporary RSA private keys (512/1024 bits)
    [Fri Jul 03 19:36:05 2015] [info] Init: Generating temporary DH parameters (512/1024 bits)
    [Fri Jul 03 19:36:05 2015] [info] Init: Generating temporary EC parameters (256 bits)
    [Fri Jul 03 19:36:05 2015] [debug] ssl_scache_shmcb.c(253): shmcb_init allocated 512000 bytes of shared memory
    [Fri Jul 03 19:36:05 2015] [debug] ssl_scache_shmcb.c(272): for 511920 bytes (512000 including header), recommending 32 subcaches, 133 indexes each
    [Fri Jul 03 19:36:05 2015] [debug] ssl_scache_shmcb.c(306): shmcb_init_memory choices follow
    [Fri Jul 03 19:36:05 2015] [debug] ssl_scache_shmcb.c(308): subcache_num = 32
    [Fri Jul 03 19:36:05 2015] [debug] ssl_scache_shmcb.c(310): subcache_size = 15992
    [Fri Jul 03 19:36:05 2015] [debug] ssl_scache_shmcb.c(312): subcache_data_offset = 3208
    [Fri Jul 03 19:36:05 2015] [debug] ssl_scache_shmcb.c(314): subcache_data_size = 12784
    [Fri Jul 03 19:36:05 2015] [debug] ssl_scache_shmcb.c(316): index_num = 133
    [Fri Jul 03 19:36:05 2015] [info] Shared memory session cache initialised
    [Fri Jul 03 19:36:05 2015] [info] Init: Initializing (virtual) servers for SSL
    [Fri Jul 03 19:36:05 2015] [info] mod_ssl/2.2.22 compiled against Server: Apache/2.2.22, Library: OpenSSL/1.0.1e
    [Fri Jul 03 19:36:05 2015] [notice] Apache/2.2.22 (Debian) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.4.42-1~dotdeb+7.4 mod_ssl/2.2.22 OpenSSL/1.0.1e configured -- resuming normal operations
    [Fri Jul 03 19:36:05 2015] [info] Server built: Dec 23 2014 22:48:29
    [Fri Jul 03 19:36:05 2015] [debug] prefork.c(1023): AcceptMutex: sysvsem (default: sysvsem)
    [Fri Jul 03 19:36:05 2015] [info] mod_fcgid: server v2.xxx.de:/var/www/php-fcgi-scripts/web548/.php-fcgi-starter(10648) started
    PHP Warning:  Module 'imagick' already loaded in Unknown on line 0
    [Fri Jul 03 19:36:06 2015] [info] mod_fcgid: server v2.xxx.de:/var/www/php-fcgi-scripts/web548/.php-fcgi-starter(10650) started
    PHP Warning:  Module 'imagick' already loaded in Unknown on line 0
    [Fri Jul 03 19:36:07 2015] [info] removed PID file /var/run/apache2.pid (pid=10637)
    [Fri Jul 03 19:36:07 2015] [notice] caught SIGTERM, shutting down
    [Fri Jul 03 19:36:07 2015] [info] mod_fcgid: process /var/www/php-fcgi-scripts/web548/.php-fcgi-starter(10648) exit(shutting down), terminated by calling exit(), return code: 0
    [Fri Jul 03 19:36:07 2015] [info] mod_fcgid: process /var/www/php-fcgi-scripts/web548/.php-fcgi-starter(10650) exit(shutting down), terminated by calling exit(), return code: 0
    [Fri Jul 03 19:36:07 2015] [info] mod_fcgid: Process manager 10642 stopped
    [Fri Jul 03 19:36:08 2015] [info] Init: Seeding PRNG with 656 bytes of entropy
    [Fri Jul 03 19:36:08 2015] [info] Init: Generating temporary RSA private keys (512/1024 bits)
    [Fri Jul 03 19:36:08 2015] [info] Init: Generating temporary DH parameters (512/1024 bits)
    [Fri Jul 03 19:36:08 2015] [info] Init: Generating temporary EC parameters (256 bits)
    [Fri Jul 03 19:36:08 2015] [info] Init: Initializing (virtual) servers for SSL
    [Fri Jul 03 19:36:08 2015] [info] mod_ssl/2.2.22 compiled against Server: Apache/2.2.22, Library: OpenSSL/1.0.1e
    [Fri Jul 03 19:36:08 2015] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Jul 03 19:36:08 2015] [notice] FastCGI: process manager initialized (pid 10743)
    [Fri Jul 03 19:36:08 2015] [info] mod_fcgid: Process manager 10745 started
    [Fri Jul 03 19:36:08 2015] [info] Init: Seeding PRNG with 656 bytes of entropy
    [Fri Jul 03 19:36:08 2015] [info] Init: Generating temporary RSA private keys (512/1024 bits)
    [Fri Jul 03 19:36:08 2015] [info] Init: Generating temporary DH parameters (512/1024 bits)
    [Fri Jul 03 19:36:08 2015] [info] Init: Generating temporary EC parameters (256 bits)
    [Fri Jul 03 19:36:08 2015] [debug] ssl_scache_shmcb.c(253): shmcb_init allocated 512000 bytes of shared memory
    [Fri Jul 03 19:36:08 2015] [debug] ssl_scache_shmcb.c(272): for 511920 bytes (512000 including header), recommending 32 subcaches, 133 indexes each
    [Fri Jul 03 19:36:08 2015] [debug] ssl_scache_shmcb.c(306): shmcb_init_memory choices follow
    [Fri Jul 03 19:36:08 2015] [debug] ssl_scache_shmcb.c(308): subcache_num = 32
    [Fri Jul 03 19:36:08 2015] [debug] ssl_scache_shmcb.c(310): subcache_size = 15992
    [Fri Jul 03 19:36:08 2015] [debug] ssl_scache_shmcb.c(312): subcache_data_offset = 3208
    [Fri Jul 03 19:36:08 2015] [debug] ssl_scache_shmcb.c(314): subcache_data_size = 12784
    [Fri Jul 03 19:36:08 2015] [debug] ssl_scache_shmcb.c(316): index_num = 133
    [Fri Jul 03 19:36:08 2015] [info] Shared memory session cache initialised
    [Fri Jul 03 19:36:08 2015] [info] Init: Initializing (virtual) servers for SSL
    [Fri Jul 03 19:36:08 2015] [info] mod_ssl/2.2.22 compiled against Server: Apache/2.2.22, Library: OpenSSL/1.0.1e
    [Fri Jul 03 19:36:08 2015] [notice] Apache/2.2.22 (Debian) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.4.42-1~dotdeb+7.4 mod_ssl/2.2.22 OpenSSL/1.0.1e configured -- resuming normal operations
    [Fri Jul 03 19:36:08 2015] [info] Server built: Dec 23 2014 22:48:29
    [Fri Jul 03 19:36:08 2015] [debug] prefork.c(1023): AcceptMutex: sysvsem (default: sysvsem)
    [Fri Jul 03 19:36:09 2015] [info] mod_fcgid: server v2.xxx.de:/var/www/php-fcgi-scripts/web548/.php-fcgi-starter(10751) started
    PHP Warning:  Module 'imagick' already loaded in Unknown on line 0
    [Fri Jul 03 19:36:10 2015] [info] mod_fcgid: server v2.xxx.de:/var/www/php-fcgi-scripts/web548/.php-fcgi-starter(10753) started
    PHP Warning:  Module 'imagick' already loaded in Unknown on line 0
    [Fri Jul 03 19:36:14 2015] [info] mod_fcgid: process /var/www/php-fcgi-scripts/web548/.php-fcgi-starter(10751) exit(shutting down), terminated by calling exit(), return code: 0
    [Fri Jul 03 19:36:14 2015] [info] mod_fcgid: process /var/www/php-fcgi-scripts/web548/.php-fcgi-starter(10753) exit(shutting down), terminated by calling exit(), return code: 0
    [Fri Jul 03 19:36:14 2015] [info] mod_fcgid: Process manager 10745 stopped
    [Fri Jul 03 19:36:14 2015] [warn] child process 10831 still did not exit, sending a SIGTERM
    [Fri Jul 03 19:36:16 2015] [warn] child process 10831 still did not exit, sending a SIGTERM
    [Fri Jul 03 19:36:18 2015] [warn] child process 10831 still did not exit, sending a SIGTERM
    [Fri Jul 03 19:36:20 2015] [error] child process 10831 still did not exit, sending a SIGKILL
    [Fri Jul 03 19:36:21 2015] [info] removed PID file /var/run/apache2.pid (pid=10740)
    [Fri Jul 03 19:36:21 2015] [notice] caught SIGTERM, shutting down
    [Fri Jul 03 19:36:22 2015] [info] Init: Seeding PRNG with 656 bytes of entropy
    [Fri Jul 03 19:36:22 2015] [info] Init: Generating temporary RSA private keys (512/1024 bits)
    [Fri Jul 03 19:36:22 2015] [info] Init: Generating temporary DH parameters (512/1024 bits)
    [Fri Jul 03 19:36:22 2015] [info] Init: Generating temporary EC parameters (256 bits)
    [Fri Jul 03 19:36:22 2015] [info] Init: Initializing (virtual) servers for SSL
    [Fri Jul 03 19:36:22 2015] [info] mod_ssl/2.2.22 compiled against Server: Apache/2.2.22, Library: OpenSSL/1.0.1e
    [Fri Jul 03 19:36:22 2015] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Jul 03 19:36:22 2015] [notice] FastCGI: process manager initialized (pid 10856)
    [Fri Jul 03 19:36:22 2015] [info] mod_fcgid: Process manager 10858 started
    [Fri Jul 03 19:36:22 2015] [info] Init: Seeding PRNG with 656 bytes of entropy
    [Fri Jul 03 19:36:22 2015] [info] Init: Generating temporary RSA private keys (512/1024 bits)
    Daraufhin lässt sich der Apache nicht mehr manuell neustarten, weil der Prozess, der vom Cronjob gestartet wird, Port 80 blockt. Führe ich /etc/init.d/apache start, restart oder reload per Hand aus (mit auskommentierten Cronjob) funktioniert der Apache problemlos - bis ich den Cronjob wieder einkommentiere.
    Im cron.log findet sich nur folgender Eintrag:
    Code:
    init.inc not found
    Fr 3. Jul 19:44:28 CEST 2015 setquota: Setze Inodegnadenfrist auf /dev/simfs nicht, denn das weiche Limit ist nicht überschritten.
    Fr 3. Jul 19:44:40 CEST 2015 setquota: Setze Blockgnadenfrist auf /dev/simfs nicht, denn das weiche Limit ist nicht überschritten.
    Fr 3. Jul 19:44:40 CEST 2015 setquota: Setze Inodegnadenfrist auf /dev/simfs nicht, denn das weiche Limit ist nicht überschritten.
    Ideen? Die Configs habe ich sicherheitshalber schon mal resynced und auch das upgrade.php-Script nochmal ausgeführt... per Hand startet der Apache ja aber problemlos.
    Danke!
     
    Zuletzt bearbeitet: 6. Juli 2015
  2. smith64fx

    smith64fx New Member

    Das gleiche Problem habe ich auch, allerdigs mit PHP5-FPM
     

Diese Seite empfehlen