Custom php.ini settings fehlerhaft?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von freemind, 8. Nov. 2012.

  1. freemind

    freemind New Member

    Hallo Leute!

    habe ein frisches ISPConfig 3.0.4.6 auf Debian Squeeze installiert, mit nginx und php-fpm(nach der howtoforge Anleitung) - läuft soweit auch Spitze! :)

    Die "Custom php.ini settings" werden leider ignoriert, ich finde auf der Festplatte mit find/locate keine php.ini die erzeugt wurde, auch phpinfo() zeigt bei den web-usern keine custom-ini die geparsed wird.

    Ich denke da fehlt nur eine Kleinigkeit, da sonst alles läuft - bin für jeden Hinweis dankbar! :)

    MfG
    Freemind :)
     
  2. falko

    falko Administrator

    Es wird keine eigene php.ini generiert, stattdessen stehen die Settings in der FPM-Pool-Datei mit drin (unter /etc/php5/fpm/pool, z.B. web1.conf).
     
  3. freemind

    freemind New Member

    danke für den hinweis! :) in der datei wurde auch nichts eingetragen, habe jedoch herausfinden können warum:

    ich hatte bei "custom php.ini settings" eingetragen:

    display_errors on

    - daraufhin hat ispconfig keinen fehler gebracht, jedoch auch nichts eingetragen.

    wenn man:

    display_errors = on

    benutzt, dann klappt alles! er braucht offenbar zwingend das "=".

    Danke für den Denkanstoß und einen schönen Abend :)
    Freemind
     

Diese Seite empfehlen