D.P.S.-Debian Squeeze mit BIND, Dovecot & Nginx [ISPConfig 3] -> "insserv: warnings"

#1
ich teste gerade dieses Tutorial:
HowtoForge Linux Tutorials » Der Perfekte Server - Debian Squeeze (Debian 6.0) mit BIND, Dovecot & Nginx [ISPConfig 3]
auf einem KVM-Server.

wenn man insserv Aktionen macht
(z.B. auf Seite 7: "insserv -r apache2")
dann kommen so komische Warnungen mit denen ich nicht so recht etwas anfangen kann:
Code:
insserv: warning: script 'K01jailkit' missing LSB tags and overrides
insserv: warning: script 'jailkit' missing LSB tags and overrides
Was hat es damit auf sich ?
 

Till

Administrator
#2
Das bedeutet dass die init scripte des Programms Jailkit keine LSB Tags haben.LSB Tags beschreiben die Reihenfolge in denen init scripte ausgeführt werden.

Das ist kein Problem da es nicht zu Fehlern auf dem Server führt.
 
#3
vielen Dank.
das Tutorial ist toll -> es läuft alles (und es läuft schnell) ...
(muss echt überlegen, ob ich überhaupt noch apache irgendwo einsetzen werde)

gestern hat ISPConfig3 angezeigt,
dass ein ngingx-update vorhanden sei (1.2.7)
das einspielen über apt-get update / apt-get upgrade hat auch geklappt
allerdings bekam ich ngingx danach nicht wieder zum laufen :(
musste das alte Backup mit 1.2.6 wieder zurückspielen ...
 

Till

Administrator
#4
Möglicherweise hat das Update irgendeine Konfigurationsdate überschrieben. In vielen fällen hilft es ispconfig nochmal runter zu laden, entpacken und dann das update.php script im install Verzeichnis auszuführen. Während des Updates wählst Du aus dass die Diense rekonfiguriert werden sollen.
 
#9
noch mal etwas zu dem nginx update:
nach dem update auf 1.2.7 stoppe ich den nginx dienst
und starte ihn dann wieder,
dann erscheint:
Code:
# /etc/init.d/nginx start
Starting nginx: nginxnginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] still could not bind()
sagt Euch das etwas ?

der Tipp:
...In vielen fällen hilft es ispconfig nochmal runter zu laden, entpacken und dann das update.php script im install Verzeichnis auszuführen. Während des Updates wählst Du aus dass die Diense rekonfiguriert werden sollen.
hilft leider auch nichts :-/


[edit1] kann es sein, dass nginx sich ein neues /etc/nginx/sites-available/default angelegt hat ?
[edit2] das ist tatsächlich der Fall !
einfach die Kommentarzeichen wieder rein machen vor den beiden "listen" zeilen und alles ist wieder gut:
Code:
[...]
server {
    #listen 80;
    #listen [::]:80 default_server;
[...]
das war einfach.
 
Zuletzt bearbeitet:
#11
da das ja ggf. beim nächsten nginx update wieder passieren wird,
und man ja eigentlich den "default" gar nicht verwendet,
kann man auch einfach die entsprechende Verknüpfung löschen mit:
"rm /etc/nginx/sites-enabled/default"
 

Werbung

Top