Debian 4.0 ISPConfig 2.2.35 -> 2.2.36 Upgrade Fehler

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von iceget, 5. Aug. 2010.

  1. iceget

    iceget Member

    Hallo Liebe Community,

    ich habe folgendes Problem:
    bis jetzt habe ich immer ein erfolgreiches Update von ISP Config durchführen können.

    Dieses mal ging das leider schief, ...!

    Ich wurde am Anfang vom Update hingewiesen das ich gewisse Libs benötige, die ich dann mittels apt-get install (wie im Setup File beschrieben) Upgedatet habe.
    Anschließend habe ich wieder versucht das Update zu starten.
    Verlief eigentlich bis auf den Schluss gut.

    Am schluss kamen dann folgende Meldungen:
    cp -f clamassassin /home/admispconfig/ispconfig/tools/clamav/bin
    chmod 555 /home/admispconfig/ispconfig/tools/clamav/bin/clamassassin
    What email address or URL should be used in the suspected-spam report
    text for users who want more information on your filter installation?
    (In particular, ISPs should change this to a local Postmaster contact)
    default text: [the administrator of that system]

    NOTE: settings for "make test" are now controlled using "t/config.dist".
    See that file if you wish to customise what tests are run, and how.

    checking module dependencies and their versions...
    ***************************************************************************
    ERROR: the required NetAddr::IP module is installed (3.14),
    but is below the minimum required version 4.000,
    some functionality will not be available.

    Used in determining which DNS tests are to be done for each of
    the header's received fields, and used by AWL plugin for extracting network
    address from an IPv6 addresses (and from IPv4 address on nondefault mask).


    ***************************************************************************
    NOTE: the optional Digest::SHA module is not installed.

    The Digest::SHA module is required by the DKIM plugin.

    ***************************************************************************
    NOTE: the optional Mail::SPF module is not installed.

    Used to check DNS Sender Policy Framework (SPF) records to fight email
    address forgery and make it easier to identify spams.


    ***************************************************************************
    NOTE: the optional IP::Country module is not installed.

    Used by the RelayCountry plugin (not enabled by default) to determine
    the domain country codes of each relay in the path of an email.


    ***************************************************************************
    NOTE: the optional Razor2 module is not installed,
    minimum required version is 2.61.

    Used to check message signatures against Vipul's Razor collaborative
    filtering network. Razor has a large number of dependencies on CPAN
    modules. Feel free to skip installing it, if this makes you nervous;
    SpamAssassin will still work well without it.

    More info on installing and using Razor can be found
    at
    http://wiki.apache.org/spamassassin/InstallingRazor .

    ***************************************************************************
    NOTE: the optional Net::Ident module is not installed.

    If you plan to use the --auth-ident option to spamd, you will need
    to install this module.


    ***************************************************************************
    NOTE: the optional IO::Socket::INET6 module is not installed.

    This is required if the first nameserver listed in your IP
    configuration or /etc/resolv.conf file is available only via an
    IPv6 address. Also used by a DCC plugin to access dccifd over network.


    ***************************************************************************
    NOTE: the optional IO::Socket::SSL module is not installed.

    If you wish to use SSL encryption to communicate between spamc and
    spamd (the --ssl option to spamd), you need to install this
    module. (You will need the OpenSSL libraries and use the
    ENABLE_SSL="yes" argument to Makefile.PL to build and run an SSL
    compatibile spamc.)


    ***************************************************************************
    NOTE: the optional Mail::DKIM module is not installed,
    minimum required version is 0.31, recommended version is 0.37 or higher.

    If this module is installed and the DKIM plugin is enabled,
    SpamAssassin will perform DKIM signature verification when DKIM-Signature
    header fields are present in the message headers, and check ADSP rules
    (e.g. anti-phishing) when a mail message does not contain a valid author
    domain signature. Version 0.37 or later is needed to fully support ADSP.


    ***************************************************************************
    NOTE: the optional Encode::Detect module is not installed.

    If you plan to use the normalize_charset config setting to detect
    charsets and convert them into Unicode, you will need to install
    this module.

    REQUIRED module out of date: NetAddr::IP
    optional module missing: Digest::SHA
    optional module missing: Mail::SPF
    optional module missing: IP::Country
    optional module missing: Razor2
    optional module missing: Net::Ident
    optional module missing: IO::Socket::INET6
    optional module missing: IO::Socket::SSL
    optional module missing: Mail::DKIM
    optional module missing: Encode::Detect

    warning: some functionality may not be available,
    please read the above report before continuing!

    make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden. Schluss.
    ERROR: Could not make SpamAssassin



    Könnt ihr mir helfen?

    Vielen Dank!

    Mfg
    --
    Markus
     
  2. Till

    Till Administrator

    Das Problem ist das einige perl Pakete in Debian 4 zu alt für den aktuellen spamassassin sind. Für die Lösung schau bitte mal hier in #4:

    http://www.howtoforge.com/forums/showthread.php?t=46184

    Ich würde Dir raten auch mal auf Debian 5 upzudaten. Für die 4er gibt es ja keine Sicherheitsupdates mehr.
     
  3. iceget

    iceget Member

    Re

    Hallo!

    Danke für die Antwort!

    1)
    Ich habe vor der Installation diesen Befehl ausgeführt:
    apt-get install libnetaddr-ip-perl libarchive-tar-perl

    Hat aber dann wie beschrieben mitten in der Installation abgebrochen.

    Der Server (81er Port für ISPConfig) stand komplett. Nach einem reboot war keine einzige Website mehr erreichbar.

    Also workaround habe ich wieder die 35er Version installiert wo ich einige Einrichtungseinstellungen durchführen musste (SSL Name, Country, ) sowie wie heißt der MySQL Server usw.

    Zum Glück hatte ich damals eine 100%ige Videodokumentation, sonst wäre mir die Wiederherstellung des alten Systems nicht gelungen.

    Was kann ich nun noch tun?


    2)
    kann ich irgendwie von ISPConfig 2.x auf 3.x upgraden?

    3)
    kann ich irgendwie mein komplettes System in eine VMware umwandeln?

    Vielen Dank!

    MfG
    --
    Markus König
     
  4. Till

    Till Administrator

    genau. Den Grund dafür habe ich ja oben bereits beschrieben und die Lösung steht im Thread den ich verlinkt habe in post #4.

    2) Nein.
    3) Müsste möglich sein. Schau mal in der vmware knowledgebase.
     
  5. iceget

    iceget Member

    Re

    Vielen Dank für Deine Hilfe!

    Hat nun funktioniert!

    Vielen lieben dank!

    MfG
    --
    Markus
     

Diese Seite empfehlen