Debian 8 Jessie / Isp-Config3 - Quota gibt Fehler beim Start

#1
Guten Morgen,
ich habe gemäß dem Tutorial The Perfect Server - Debian 8 Jessie (Apache2, BIND, Dovecot, ISPConfig 3)
einen Server aufgesetzt. Vorab: Vielen Dank für das tolle Tutorial.

Nun bemerke ich nach dem 2. Neustart des Servers, dass Quota nicht laufen möchte.
Während des Bootens erscheint eine Fehlermeldung:

Failed to start Check And Enable File System Quotas.
See 'systemctl Status quota.service' for Details


Folgendes habe ich bereits unternommen:
Quotas abschalten: quotaoff -avug
Quotas prüfen: quotacheck -avugm
Quotas anschalten: quotaon -avug

Das prüfen und anschalten der Quotas verläuft erfolgreich, dennoch tritt die Fehlermeldung beim nächsten Neustart wieder auf.
Hat jemand eventuell den gleichen Fehler und weiß hier eine Lösung?

Anbei ein Bild des Fehlers:

quota-fail.JPG

VG Rouven
 
#5
Hallo Florian,
das ist das Problem in diesem Falle. Ich habe quotaon ja bereits getestet und es läuft so durch. Quota ist im Nachgang also aktuell auch aktiv, lediglich beim Systemstart zickt er rum.
Ich habe eben nochmal quotaoff und danach wieder quotaon durchlaufen lassen. Er kommt dann kurt mit checking..... und dann ist er fertig ohne Fehlermeldung.

Kannst Du Dir da einen reim drauf machen?

Einzig vor 2 Tagen habe ich nach der Installation mysql Client und Server neu per apt-get installieren müssen. Da kann es aber nicht mit zusammenhängen, wie ich meine.

LG Rouven
 

Till

Administrator
#6
Bei Debian 8 werden die Dienste ja mittels systemd gestartet und systemd startet dienste gleichzeitig um das Booten zu beschleunigen. Wahrscheinlich ermittelt systemd die Abhängigkeiten im Fall des quota service falsch und starte ihn daher zu früh. Wenn Quota trotzdem funktioniert dann würde ich die Boot meldung einfach ignorieren.
 

Werbung