Debian mit ISPConfig 3 unter falschem Hostnamen

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Weitdenker, 8. Dez. 2009.

  1. Weitdenker

    Weitdenker New Member

    Hallo,

    ich habe meinen Server nach den HowTo "The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3]" aufgesetzt. Der Server läuft unter dem Hostnamen "meinedomain.de"
    Es läuft auch alles prima. Leider habe nun das Problem, dass ich für meinedomain.de keine E-Mail-Adresse festlegen kann zumindest läuft diese dann nicht. Ich habe
    für "meinedomain.de" einen virtual host angelegt.

    Alle anderen E-Mail-Adressen unter anderen Domains lauft jedoch einwandfrei. Ich denke dies kommt daher, dass ich als Hostnamen "meinedomain.de" gewählt habe und nicht
    eine Subdomain wie "server.meinedomain.de".

    Ich habe schon versucht den Hostnamen über etc/hosts zu ändern, leider ohne Erfolg. Im Webmin z.B. sehe ich, dass meine Änderung nicht übernommen worden ist oder
    nicht komplett war. Was muss ich alles tun um meinen Server einen neuen Hostnamen zu vergeben ohne mir jetzt alle Konfigurationen und Installationen zu zerschießen?
    Oder liege ich ganz falsch mit meiner Vermutung?

    Würde mich über eure Mithilfe freuen.
     
  2. Till

    Till Administrator

    Der Server hostname darf niemals identisch mit einer email bzw. web domain sein, damit kommen weder postfix noch apache klar. Sowas wie server.deinedomain.de ist aber ok.

    Du musst den Hostnamen ändern in /etc/hosts, /etc/mailname, /etc/hostname und auch in der main.cf, falls er da irgendwo drin steht. Dann rufst Du auf:

    /etc/init.d/hostname.sh

    and dann musst Du noch apache und postfix neu starten.
     
  3. Weitdenker

    Weitdenker New Member

    Dachte ich es mir doch ;-) Vielen Dank für die schnelle Antwort!
     

Diese Seite empfehlen