Debian Squeeze: Installer hat /etc/init.d/ispconfig_server nicht installiert

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Deex, 1. März 2013.

  1. Deex

    Deex Member

    Debian Squeeze: Could not Bind on Adress / Kein Zugriff mehr möglich

    Hi, ich habe jetzt ein kleines Problem,
    nachdem ich den Server Neugestartet habe startet ISPconfig auch nicht mehr
    nach einer Prüfung habe ich festgestellt das es garnicht Automatisch gestartet wird und ich es nicht einmal manuell Starten kann da die Startscripte scheinbar fehlen.

    Laut Beschreibung müsste ich bei Debian folgendes finden
    /etc/init.d/ispconfig_server
    Dieses ist jedoch nicht vorhanden, bei der Installation gab es auch keine fehler

    Nachtrag 1:

    Okay scheinbar war das wohl aus der alten version, ich denke mein Problem ist das der Apache nicht mehr starten kann
    er erzeugt folgende Fehlermeldung:

    Und da läuft wer mag es Glauben:
    Apache
    Jetzt weiß ich auch nicht mehr weiter, fakt ist lediglich ich komme nicht mehr auf ISPconfig und wenn ich das ISPConfig Setup starte sagt er das der Port belegt ist, wenn ich Apache Manuell Starte sagt er auch das er ihn nicht Starten kann.

    Freude.

    Ich kann derzeit nur sagen das zwischen dem Totalen Ausfall von ISPconfig 3 und funktion ich lediglich folgendes getan habe
    1. eAccelerator Installiert
    2. MysQL import erledigte
    3. PHPMyadmin Aktualisierte

    Nachtrag 2.
    Ich habe jetzt das komplette System neu Installiert, ebenso ISPConfig, derzeit läuft alles normal.
    Ich habe die vermutung das die Installation des Paketes php5-dev nachdem ISPconfig Installiert wurde schwerwiegende Fehler erzeugt, und daher
    diesmal die reihenfolge verändert,- sprich zuerst php5-dev danach ISPconfig.

    So ganz viel Sicherheit gibt mir das nun nicht da ich mich derzeit nicht traue eAccelerator erneut mit ISPConfig zu Installieren und wieder alles verbuggt.
     
    Zuletzt bearbeitet: 1. März 2013
  2. Till

    Till Administrator

    Ich glaube Du bringst hier so einiges durcheinander, ein script /etc/init.d/ispconfig_server gibt es garnicht bei ispconfig 3. Solch ein script gab es mal bei ispconfig 2, das ist aber auch ein anderes controlpanel. Du sprichts aber von einem Update dass Du installiert hast, bei ispconfig 2 gab es aber seit Jahren kein Update mehr da die Software eingestellt wurde, ich vermute also mal Du redest von ISPConfig 3 und dort ist ein script /etc/init.d/ispconfig_server nicht vorhanden.

    Zu Deinem ursprünglichen Problem. wahrscheinlich ist apache hängen geblieben so dass er nicht mehr neu gestarte werden konnt und auch keine neue Config mehr geladen hat. Das ist selten, kommt aber manchmal vor. Meistens hilft dann ein server reboot.

    Wenn Du einen php cache installieten möchtest dann würde ich Dir zu xCache raten, läuft auf meinen Servern stabiler als eAccelerator un APC.
     
  3. Deex

    Deex Member

    Hallo (mal wieder ;) )
    Till,

    Ja es ist ISPconfig 3, ich habe es auch nach einigen Neustarts nicht wieder hinbekommen und musste das komplette System neu Installieren.

    Der Xcache hat der eine Administrationsoberfläche auf PHP ? Und wie sieht es mit der Leistung aus? Warst du zufriedener als mit eAccelerator?
     

Diese Seite empfehlen