Debian-Update von 5 auf 7

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von hahni, 12. Juni 2013.

  1. hahni

    hahni Active Member

    Hallo zusammen,

    ich wollte gerade eben von Debian 5 auf 7 updaten. Vielleicht hätte ich die 6er nicht auslassen sollen. Doch nun kann ich das leider nicht rückgängig machen, weil schon Pakete installiert wurden, die von der 7er-Version sind.

    Fakt ist, dass ich mit folgendem Fehler konfrontiert bin:
    --
    h1795796:/# apt-get upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Lese Status-Informationen ein... Fertig
    Probieren Sie »apt-get -f install«, um dies zu korrigieren.
    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    libc-bin: Stört: libc6 (< 2.10) aber 2.7-18lenny7 ist installiert
    libc-dev-bin: Hängt ab: libc6 (> 2.13) aber 2.7-18lenny7 ist installiert
    Empfiehlt: manpages-dev ist aber nicht installiert
    libc6-i686: Hängt ab (vorher): libc6 (= 2.13-38) aber 2.7-18lenny7 ist installiert
    locales: Hängt ab: glibc-2.13-1
    nscd: Hängt ab: libc6 (> 2.13) aber 2.7-18lenny7 ist installiert
    E: Nicht erfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
    --

    Was tun, um das Problem zu beheben?

    Viele Grüße

    Hahni
     
  2. Till

    Till Administrator

    Ein upgrade aud eine neue Major Version macht man per dist-upgrade und nicht upgrade. Schau Dir am Besten mal die Debian Update Tutorials auf howtoforge.com an.
     
  3. hahni

    hahni Active Member

    Ich weiß. Das ist auch bei Ubuntu so. Doch das ändert nichts am aufgetretenen Fehler:

    --
    h1795796:/# apt-get dist-upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Lese Status-Informationen ein... Fertig
    Probieren Sie »apt-get -f install«, um dies zu korrigieren.
    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    libc-bin: Stört: libc6 (< 2.10) aber 2.7-18lenny7 ist installiert
    libc-dev-bin: Hängt ab: libc6 (> 2.13) aber 2.7-18lenny7 ist installiert
    Empfiehlt: manpages-dev ist aber nicht installiert
    libc6-i686: Hängt ab (vorher): libc6 (= 2.13-38) aber 2.7-18lenny7 ist installiert
    locales: Hängt ab: glibc-2.13-1
    nscd: Hängt ab: libc6 (> 2.13) aber 2.7-18lenny7 ist installiert
    E: Nicht erfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
    --
     
  4. Till

    Till Administrator

    Und was passiert wenn Du wie vorgeschlagen:

    apt-get -f install

    ausführst?
     
  5. hahni

    hahni Active Member

    Hatte ich auch schon probiert und da wird auch die libc6 vermisst :(

    --
    h1795796:/# apt-get -f install
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Lese Status-Informationen ein... Fertig
    Abhängigkeiten werden korrigiert... Fertig
    Die folgenden Pakete wurden automatisch installiert und werden nicht länger benötigt:
    php-fpdf egroupware-mydms
    Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
    Die folgenden zusätzlichen Pakete werden installiert:
    binutils cpp cpp-4.7 g++ g++-4.7 gcc gcc-4.7 libc6 libc6-dev libgcc1 libgmp10 libgomp1 libitm1 libmpc2 libmpfr4 libquadmath0 libstdc++6 libstdc++6-4.7-dev make multiarch-support
    Vorgeschlagene Pakete:
    binutils-doc cpp-doc gcc-4.7-locales g++-multilib g++-4.7-multilib gcc-4.7-doc libstdc++6-4.7-dbg gcc-multilib manpages-dev autoconf automake1.9 libtool flex bison gdb gcc-doc gcc-4.7-multilib libmudflap0-4.7-dev libgcc1-dbg
    libgomp1-dbg libitm1-dbg libquadmath0-dbg libmudflap0-dbg libcloog-ppl0 libppl-c2 libppl7 binutils-gold glibc-doc libstdc++6-4.7-doc make-doc
    Die folgenden Pakete werden ENTFERNT:
    g++-4.3 gcc-4.3 libstdc++6-4.3-dev
    Die folgenden NEUEN Pakete werden installiert:
    cpp-4.7 g++-4.7 gcc-4.7 libgmp10 libitm1 libmpc2 libmpfr4 libquadmath0 libstdc++6-4.7-dev multiarch-support
    Die folgenden Pakete werden aktualisiert:
    binutils cpp g++ gcc libc6 libc6-dev libgcc1 libgomp1 libstdc++6 make
    10 aktualisiert, 10 neu installiert, 3 zu entfernen und 329 nicht aktualisiert.
    11 nicht vollständig installiert oder entfernt.
    Es müssen noch 0B von 38,5MB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 44,6MB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren [J/n]? J
    Vorkonfiguration der Pakete ...
    (Lese Datenbank ... 57170 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereiten zum Ersetzen von libc6 2.7-18lenny7 (durch .../libc6_2.13-38_i386.deb) ...
    Checking for services that may need to be restarted...
    Checking init scripts...
    WARNING: this version of the GNU libc requires kernel version
    2.6.26 or later. Please upgrade your kernel before installing
    glibc.

    The installation of a 2.6 kernel _could_ ask you to install a new libc
    first, this is NOT a bug, and should *NOT* be reported. In that case,
    please add lenny sources to your /etc/apt/sources.list and run:
    apt-get install -t lenny linux-image-2.6
    Then reboot into this new kernel, and proceed with your upgrade
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libc6_2.13-38_i386.deb (--unpack):
    Unterprozess pre-installation script gab den Fehlerwert 1 zurück
    Fehler traten auf beim Bearbeiten von:
    /var/cache/apt/archives/libc6_2.13-38_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    --
     
  6. hahni

    hahni Active Member

    Mit dem Befehl "aptapt-get build-dep -s libc6-dev" erscheint in der Fehlerausgabe unter anderem folgendes:

    --
    Paketlisten werden gelesen...
    Abhängigkeitsbaum wird aufgebaut...
    Lese Status-Informationen ein...
    Die folgenden Pakete werden ENTFERNT:
    defoma dnsutils g++-4.3 gcc-4.3 klogd libbind9-50 libc-client2007b
    libdigest-sha1-perl libdns58 libgs8 libisccfg50 libkrb53 libperl5.10
    libstdc++6-4.3-dev lzma openssh-client openssh-server psfontmgr sasl2-bin
    smbfs squid ssh sysklogd
    Die folgenden NEUEN Pakete werden installiert:
    autoconf automake autopoint autotools-dev build-essential cpp-4.4 cpp-4.7
    debhelper diffstat dpkg-dev fakeroot fdupes g++-4.4 g++-4.4-multilib g++-4.7
    gcc-4.4 gcc-4.4-base gcc-4.4-multilib gcc-4.7 gcc-4.7-multilib gcc-multilib
    gettext git git-man html2text intltool-debian krb5-locales lib64gcc1
    lib64gomp1 lib64itm1 lib64quadmath0 lib64stdc++6 libalgorithm-diff-perl
    libalgorithm-diff-xs-perl libalgorithm-merge-perl libapt-inst1.5
    libapt-pkg4.12 libasprintf0c2 libavahi-client3 libavahi-common-data
    libavahi-common3 libbind9-80 libc-client2007e libc6-amd64 libc6-dev-amd64
    libclass-isa-perl libcroco3 libcurl3-gnutls libdb5.1 libdbus-1-3 libdns88
    libdpkg-perl liberror-perl libfile-copy-recursive-perl
    libfile-fcntllock-perl libgeoip1 libgettextpo0 libgmp10 libgs9 libgs9-common
    libgssapi-krb5-2 libijs-0.35 libisc84 libisccc80 libisccfg82 libitm1
    libjasper1 libjbig0 libjbig2dec0 libjpeg8 libk5crypto3 libkrb5-3
    libkrb5support0 liblcms2-2 libltdl7 liblwres80 liblzma5
    libmail-sendmail-perl libmpc2 libmpfr4 libmysqlclient18 libonig2 libp11-kit0
    libpam-modules-bin libperl5.14 libqdbm14 libquadmath0 libreadline6 librtmp0
    libsensors4 libssl1.0.0 libstdc++6-4.4-dev libstdc++6-4.7-dev libswitch-perl
    libsys-hostname-long-perl libtalloc2 libtdb1 libtinfo5 libunistring0
    multiarch-support patch po-debconf poppler-data quilt squid-langpack squid3
    squid3-common xz-utils
    Die folgenden Pakete werden aktualisiert:
    apt apt-utils base-files binutils cpp dpkg fetchmail fontconfig-config g++
    gcc gettext-base ghostscript gsfonts ifupdown initscripts ldap-utils libacl1
    libapache2-mod-php5 libapt-pkg-perl libattr1 libauthen-pam-perl libbind-dev
    libblkid1 libc6 libc6-dev libcups2 libcupsimage2 libcurl3 libdbd-mysql-perl
    libdbi-perl libdigest-md4-perl libfontconfig1 libgcc1 libgcrypt11
    libgnutls26 libgomp1 libgpg-error0 libhtml-parser-perl libidn11
    libio-pty-perl libldap-2.4-2 liblocale-gettext-perl libneon27
    libneon27-gnutls libnet-libidn-perl libnet-ssleay-perl libnss-ldap
    libpam-krb5 libpam-modules libpam-runtime libpam0g libpcre3 libpq5
    libsasl2-2 libsasl2-modules libselinux1 libslang2 libsnmp-base libsnmp15
    libsqlite3-0 libssh2-1 libstdc++6 libtasn1-3 libterm-readkey-perl
    libtext-charwidth-perl libtext-iconv-perl libtiff4 libunicode-map-perl
    libunicode-map8-perl libunicode-string-perl libuuid1 libwbclient0 libxml2
    linux-libc-dev lprng m4 make mysql-common netbase perl perl-base
    perl-modules php-apc php5-cli php5-common php5-curl php5-gd php5-imap
    php5-ldap php5-mcrypt php5-mysql php5-pgsql php5-sqlite postfix psmisc samba
    samba-common slapd smbclient smbldap-tools squidguard sysvinit-utils tar
    ttf-dejavu-core ttf-dejavu-extra update-inetd util-linux
    WARNUNG: Die folgenden essentiellen Pakete werden entfernt.
    Dies sollte NICHT geschehen, außer Sie wissen genau, was Sie tun!
    lzma (wegen dpkg)
    107 aktualisiert, 108 neu installiert, 23 zu entfernen und 225 nicht aktualisiert.
    --

    Die Installation wird wegen lzma in jedem Fall schief gehen, oder?
     
  7. hahni

    hahni Active Member

    Scheint weitestgehen zu laufen. Allerdings hält sich noch immer ein Fehler hartnäckig:

    --
    h1795796:/# apt-get upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Statusinformationen werden eingelesen... Fertig
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    1 nicht vollständig installiert oder entfernt.
    Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren [J/n]? j
    slapd (2.4.23-7.3) wird eingerichtet ...
    Backing up /etc/ldap/slapd.conf in /var/backups/slapd-2.4.11-1+lenny2... done.
    Moving old database directories to /var/backups:
    Loading from /var/backups/slapd-2.4.11-1+lenny2:
    - directory dc=villa-editha,dc=de... failed.

    Loading the database from the LDIF dump failed with the following
    error while running slapadd:
    /var/backups/slapd-2.4.11-1+lenny2/dc=villa-editha,dc=de.ldif: No such file or directory
    dpkg: Fehler beim Bearbeiten von slapd (--configure):
    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
    configured to not write apport reports
    Fehler traten auf beim Bearbeiten von:
    slapd
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    --
     

Diese Seite empfehlen