Debian Wheezy Proxmox und KVM

#1
Hi Leute

Leider verzweifel ich gerade an Proxmox. Bis jetzt hab ich bei Proxmox rein die OpenVz Container verwendet die kein Problem dargestellt haben.
Jetzt versuche ich gerade mit einem Hetzner Server und einem /28 Subnet KVM zu erstellen.
Nur egal was ich mache ich bekomme keine Netzwerkverbindung.
Hab mich brav an das Wiki bei Hetzner gehalten und trotzdem keine Verbindung. Kann mir vielleicht jemand die interface Datei an meine Konfiguration anpassen?


lg Abigail
 
#2
wie schaut deine Interface im Host denn derzeit aus, wie schaut deine Interface in der VM aus. Wie schaut deine sysctl.conf im Host aus?
Irgendwelche iptables Rules? Welche Art von Routing? Bridged? Falls ja, ist die Virtuelle MAC zu der IP der VM bei Hetzner im Robot passend?

Gruß Sven
 
#3
Entschuldigung war gestern etwas übermüdet. Zwei Minuten nachdem ich diesen Beitrag geschrieben habe war ich schon im Land der Träume. ;-)

HOST Interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 148.251.187.12
broadcast 148.251.187.63
netmask 255.255.255.192
pointopoint 148.251.187.1 *verändert*
gateway 148.251.187.1
# default route to access subnet
up route add -net 148.251.187.0 netmask 255.255.255.192 gw 148.251.187.1 eth0

iface eth0 inet6 static
address 2a01:4f8:211:896::2
netmask 64
gateway fe80::1

*verändert*
auto vmbr1
iface vmbr1 inet static
address 136.243.248.33
netmask 255.255.255.240
bridge_ports none
bridge_stp off
bridge_fd 0



HOST sysctl.conf
net.ipv4.conf.all.rp_filter=1
net.ipv4.icmp_echo_ignore_broadcasts=1
net.ipv4.conf.default.forwarding=1
net.ipv4.conf.default.proxy_arp = 0
net.ipv4.ip_forward=1
kernel.sysrq = 1
net.ipv4.conf.default.send_redirects = 1
net.ipv4.conf.all.send_redirects = 0
net.ipv4.conf.eth0.proxy_arp=1
net.ipv6.conf.all.forwarding=1
net.ipv4.conf.all.accept_redirects = 0
net.ipv6.conf.all.accept_redirects = 0


GAST Interface
auto eth0
iface eth0 inet static
address 136.243.248.33
netmask 255.255.255.240
gateway 136.243.248.33


Keine IP Tables
Routing KVM/Routed nach diesem wiki
http://wiki.hetzner.de/index.php/Proxmox_VE#Netzwerkkonfiguration_Hostsystem_KVM.2FRouted
 
#4
Bevor ich es vergesse.
Ich kann vom Host den Gast pingen.
Vom Gast nach außen oder zum Host geht gar nix.
Und versuch ich per ssh von mir zum Gast zu kommen komm ich nur zum Host.
 
Zuletzt bearbeitet:
#6
Ups übersehen.
Schon geändert trotzdem kann vm nicht nach extern pingen.
vmbr1 ip 136.243.248.32
gast 136.243.248.33

wenn ich von host auf gast pinge kommt nur die ip von vmbr1 komme aber nicht auf das eigentliche gastsystem und umgekehrt komme ich ins nirvana
 

Werbung

Top