default host Einstellungen

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von katasun, 5. Aug. 2013.

  1. katasun

    katasun Member

    Guten Tag, bei der Konfiguration von ISPConfig habe ich eine Frage, wie ich am besten vorgehe. Es geht um die Einstellungen der default hosts.

    Mein Problem, für den Standarddomain Namen meines Servers lege ich einen Vhost mit ISPConfig an und erstelle dann dort die Inhalte der Webseite.

    Dieser Vhost wird auf in der Apache-Konfiguration aufgeführt. Beim Aufrufen meiner Server Domain wird aber der default vhost Eintrag benutzt, für den Port 80 und 443.

    Der Apache nimmt also immer den default Eintrag und nicht den vhost Eintrag.

    Beispiel:

    root@xxxxxxx:/etc/apache2# apache2ctl -S

    [Mon Aug 05 06:49:34 2013] [warn] NameVirtualHost *:80 has no VirtualHosts

    VirtualHost configuration:
    wildcard NameVirtualHosts and _default_ servers:

    _default_:8081 xxxxx.de (/etc/apache2/sites-enabled/000-apps.vhost:10)

    *:50443 is a NameVirtualHost
    default server xxxxx.de (/etc/apache2/sites-enabled/000-ispconfig.vhost:18)
    port 50443 namevhost xxxxx.de (/etc/apache2/sites-enabled/000-ispconfig.vhost:18)

    *:443 is a NameVirtualHost
    default server sub.xxxxx.biz (/etc/apache2/sites-enabled/100-sub.xxxxx.biz.vhost:76)
    port 443 namevhost sub.xxxxx.biz (/etc/apache2/sites-enabled/100-sub.xxxxx.biz.vhost:76)


    *:80 is a NameVirtualHost
    default server xxxxx.de (/etc/apache2/sites-enabled/000-default:1)
    port 80 namevhost xxxxx.de (/etc/apache2/sites-enabled/000-default:1)
    port 80 namevhost xxxxx.de (/etc/apache2/sites-enabled/100-xxxxx.de.vhost:7)

    Syntax OK

    Das Thema wird an verschiedenen Stellen diskutiert, mit verschiedenen Lösungsvorschlägen.

    Den Aufruf der Vhosts habe ich jetzt auf die IP geändert, das Problem bleibt aber bestehen.

    Meine Frage, wie gehe ich am besten vor um das Problem zu lösen.

    Ich wollte die Inhalte des ISP-Config in die Standard Vhost Einträge kopieren, dann würde ja alles laufen. Vielleicht gibt es aber bessere Lösungen. Danke.

    Katasun
     
  2. Till

    Till Administrator

    Das Problem ensteht wen:

    a) IP Adressen undWildcard (*) basierte hosts auf dem server gemischt werden.
    b) Wenn die Domain des vhosts nicht stimmt (Tippfehler)

    Das ist natürlich nicht nötig und macht auch nicht viel Sinn.
     
  3. katasun

    katasun Member

    Danke dafür, ich habe alle Vhost überprüft, inklusive den Datenbankeinträgen von ISPConfig, alles läuft über IP. Ich habe auch den Vhost gelöscht und neu angelegt, aber geändert hat sich nichts.

    In den Einstellungen in /etc/apache2/sites_available/

    zeigt der Eintrag xxx.xy immer auf den default.host Eintrag. xxx.xy habe ich auch als Servername benutzt, kann es etwas damit zu tun haben?

    Also default.host wird immer vorrangig zum vhost behandelt.

    Katasun
     
  4. Till

    Till Administrator

    Der Servername sollte eine subdomain sein die nicht für vhosts verwendet wird, da apache diese vorranging auf /var/www umleitet.
     
  5. katasun

    katasun Member

Diese Seite empfehlen