Default vhost greift nicht bei nicht angelegten Domains

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von wemaflo, 5. Jan. 2014.

  1. wemaflo

    wemaflo New Member

    Guten Abend,

    ich habe ein seltsames Problem, welches mir erst neulich auffiel (ich weiß nicht, ob es einen Zusammenhang mit dem getätigten Upgrade auf Debian 7 zu tun hat): Rufe ich eine IP des Servers auf, wird wie gewünscht die default Seite angezeigt.
    Rufe ich nun eine Domain auf, die in ISPConfig nicht angelegt ist und die keinen vhost hat (in diesem Fall den fqdn und Hostname des Servers), wird die erste Kundenseite angezeigt.

    Laut Struktur in sites-enabled dürfte das gar nicht funktionieren, es existiert der default host mit Wildcard, sowie von ISPConfig angelegt für jede eingetragene IP ein weiterer default-host, diese sind in sites-enabled durch vorangestellte Nullen im Alphabet höher als die Kunden-Vhosts (diese heißen ja 100-name.vhost).

    Woran kann das liegen? Mich wundert ja, dass bei Aufruf der IPs alles klappt, bei nicht vorhandenen Domains macht er aber diesen Fehler.

    Vielen Dank schon mal!
     
  2. nowayback

    nowayback Well-Known Member

    scheindomain aaa.aa anlegen :)
     
  3. wemaflo

    wemaflo New Member

    Danke für deine Antwort, aber das ist es ja eben nicht. 000-default kommt vor 100-dxxx.vhost. Mit aaa.aaa bleibt es der gleiche Fehler.
     
  4. nowayback

    nowayback Well-Known Member

    haste es ausprobiert? sollte nämlich nicht so sein
     
  5. wemaflo

    wemaflo New Member

    Klar hab ich :) Deshalb schrieb ich ja, dass der Fehler gleich bleibt.
     
  6. nowayback

    nowayback Well-Known Member

    Und cache gelöscht haste auch?
     
  7. wemaflo

    wemaflo New Member

    Auch das :)
    Ich bin nun aber etwas weiter, anscheinend tritt dieses Phänomen nur auf, wenn man den Hostname des Servers im Browser aufruft. Ich habe gerade mal nen A-Record auf den Server für ne andere Subdomain angelegt, siehe da, Standard-Page.
     
  8. Till

    Till Administrator

    Der hostname des servers hat im apache ine besondere bedeutung und zeigt immer auf das globale docroot /var/www wenn du den server hostnamen umleiten willst dann füge eine .htaccess mit rewrite im docroot ein.
     
  9. wemaflo

    wemaflo New Member

    Hallo Till!

    Das will ich ja eben nicht. Der Hostname soll ganz normal auf /var/www/ weisen, das ist auch documentroot im default vhost. Tatsächlich bekomme ich aber beim Aufruf des Hostnames die erste Kundenseite angezeigt, nicht /var/www/.

    Die default- und ispconfig-vhosts sind in sites-enabled alle mit 000- nach vorne gestellt, die Kundenseiten fangen bei 100- an, wieso der Apache statt 000-default 100-dxxx.vhost ausgibt, und das nur, wenn der hostname aufgerufen wird, weiß ich nicht.

    Eigentlich sind die vhosts alle "naturbelassen", wie ISPConfig sie erstellt.
     
  10. Till

    Till Administrator

    Nutzt Du denn * oder eine IP in Deinen Webseiten? In apache hat eine IP immer Priorität über * bzw. _default_. Wenn Du also IP's in den webseiten nutzt und trotzdem einen default vhost für domains welche auf die selbe IP verweisen haben möchtest, dann musst Du einen vhost mit 000- prefix anlegen bei dem die IP und nicht * oder _default_ im vhost pattern verwendet wird. denn ansonsten würde apache den ersten vhost bei dem die IP verwendet wird gegenüber dem default vhost bevorzugen, unabhängig vom domainnamen.
     
  11. wemaflo

    wemaflo New Member

    Ich habe zwar im default-vhost eine Wildcard (bzw. _default_) und nutze für die Seiten fest zugewiesene IPs, allerdings hat ISPConfig ja beim Anlegen der IPs auch zusätzliche default-vhosts mit der jeweiligen IP angelegt, auch diese sind mit 000-default55 oder 000-default71 usw. in sites-enabled verlinkt.

    Nur noch mal zur Verdeutlichung: Rufe ich eine IP des Servers oder irgendeine Domain auf, die auf den Server zeigt, funktioniert alles und ich bekomme die default Seite gezeigt.
    Lediglich beim Aufruf des Hostname tritt dieser Fehler auf.
     
  12. Till

    Till Administrator

    ISPConfig legt keine default vhosts an, wenn Du solche Dateien hast, dann musst Du sie selbst angelegt haben.
     

Diese Seite empfehlen