Die Webseite kann nicht angezeigt werden

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Andre, 22. Apr. 2008.

  1. Andre

    Andre New Member

    Hallo

    ich habe das neue 2.2.23 auf Debian4.0 Etch installiert und bekomme immer die fehlermeldung
    Code:
    Die Webseite kann nicht angezeigt werden
    auch wenn ich die IP.IP.IP.IP:81 nehme, habe dies schon 10mal neu installiert alles ohne erfolg, der router neu gestartet.
    Ich hatte vorher 2.2.21 und da musste ich manchmal auch schon zwei mal installieren bis er sich pingen liess.

    Gibt es die möglichkeit irgend ein hand eintrag zu machen damit es funktioniert!
    Vhosts_ispconfig.conf ist leer!

    Router ,Ports, IP's alles korrekt
     
  2. Till

    Till Administrator

    Erstmal vorweg, die Datei Vhosts_ispconfig.conf hat nichts mit dem Webserver auf port 81 zu tun. ISPConfig verwendet 2 verschiedene Webserver, einen auf port 80 und einen auf port 81. Das beide nicht gehen ist äußerst unwahrscheinlich, da muss etwas generelles an Deinem Setup nicht stimmen. Neu Installieren von ISPConfig bringt da übrigens nicht, da das nicht Dein Setup korrigieren kann.

    1) Hattest Du irgendwelche Fehlermeldungen während der Installation?

    2) Hast Du Dich bei der Unstallation exakt an den Perfect Server Guide für Debian Etch gehalten?

    3) Poste mal die Audgabe von:

    netstat -tap
     
  3. Andre

    Andre New Member

    Hallo Till

    1) Keine Fehlermeldung während der Installation, ausser bei "dpkg-reconfigure postfix" ist mir aufgefallen dass Other destinations to accept mail for? (blank for none) <-- server1.example.com, localhost.example.com, localhost.localdomain, localhost
    es so geschrieben wird: server1.example.com, localhost.example.com, , localhost aber das ist postfix.
    2) habe alles so gemacht
    3) netstat -tap
    Code:
    Aktive Internetverbindungen (Server und stehende Verbindungen)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN     12341/mysqld
    tcp        0      0 *:sunrpc                *:*                     LISTEN     1907/portmap
    tcp        0      0 *:81                    *:*                     LISTEN     23380/ispconfig_htt
    tcp        0      0 *:auth                  *:*                     LISTEN     2261/inetd
    tcp        0      0 *:ftp                   *:*                     LISTEN     23547/proftpd: (acc
    tcp        0      0 [URL="http://www.server.com:domain"]www.server.com:domain[/URL] *:*                     LISTEN     23526/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN     23526/named
    tcp        0      0 *:smtp                  *:*                     LISTEN     24473/master
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     23526/named
    tcp        0      0 *:50815                 *:*                     LISTEN     2303/rpc.statd
    tcp6       0      0 *:imaps                 *:*                     LISTEN     9027/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     8947/couriertcpd
    tcp6       0      0 *:pop3                  *:*                     LISTEN     8890/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     8980/couriertcpd
    tcp6       0      0 *:www                   *:*                     LISTEN     23410/apache2
    tcp6       0      0 *:domain                *:*                     LISTEN     23526/named
    tcp6       0      0 *:ssh                   *:*                     LISTEN     2284/sshd
    tcp6       0      0 *:smtp                  *:*                     LISTEN     24473/master
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     23526/named
    tcp6       0      0 *:https                 *:*                     LISTEN     23410/apache2
    tcp6       0    888 [URL="http://www.server.com:ssh"]www.server.com:ssh[/URL]    ::ffff:212.174.83:49929 VERBUNDEN  10121/sshd: andre [
    
     
  4. Till

    Till Administrator

    ISPConfig läuft und der normale apache läuft auch korrekt auf port 80 und 443.

    Poste mal die Audsgabe von:

    iptables -L
     
  5. Andre

    Andre New Member

    die "iptables -L"

    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    Chain FORWARD (policy ACCEPT)
    target prot opt source destination
    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
     
  6. Till

    Till Administrator

    Das ist auch in Ordnung.

    Wie versuchst Du denn, auf die Seiten und ISPConfig zuzugreifen? Ist ein Router oder eine Firewall dazwischen? Steht der Rechner in einem lokalen Netzwerk oder Rechenzentrum? Kannst Du Dichper Netzwerk auf dem Rechner ainloggen, z.B. mit SSH oder FTP?
     
  7. Andre

    Andre New Member

    Hallo Till

    ja der rechner seht hinter dem router der router hat ein switch und an diesem sind noch ein switch mit rechner und drucker angehängt.

    Keine firewall, ich habe laut hersteller genau den router von port 80 auf 8888 gesetzt und für den rechner port 80 freigegeben, zusätzlich habe ich port 443 aktiviert und jetzt noch port 81

    Alles ohne erfolg

    Der router hat DHCP und dem rechner eine IP zugewissen, dies habe ich in die Interfaces geschrieben und "restart" alles ohne fehler.

    SSH zugriff funltioniert.WinSCP auch mit interner IP
     
  8. Andre

    Andre New Member

    Hallo

    ich habe mal versucht Ubuntu 7.04 zu installieren
    Code:
    [B]Index of /[/B]
    Apache/2.2.3 (Ubuntu) PHP/5.2.1 mod_ssl/2.2.3 OpenSSL/0.9.8c Server at IP.IP.IP.IP Port 80
    da läuft alles normal nur der zugriff auf Port 81 geht nicht, vielleicht sollte ich es mal ohne https installieren, ich habe den router neu gestartet (kommplett neu) die festplatten gewechselt (reihenfolge), den port 81 auf dem router eigetragen, wie komme ich an den port 81 ran. der müsste doch immer laufen!

    Kann ich irgenwo die fehlermeldungen anschauen um das Problem zu beheben.
     
  9. Till

    Till Administrator

    Poste bitte mal die Ausgabe vin:

    netstat -tap

    und iptables -L

    von Deinem neuen Ubuntu Rechner. Port 81 hat nichts mit dem apache 2.2.3 zu tun, auf port 81 läuft ein eigener apache 1.3.x nur für das Controlpanel.
     
  10. Andre

    Andre New Member

    Das sieht gut aus:
    Code:
    Aktive Internetverbindungen (Server und stehende Verbindungen)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN     11105/mysqld
    tcp        0      0 *:www                   *:*                     LISTEN     22212/apache2
    tcp        0      0 *:81                    *:*                     LISTEN     22182/ispconfig_htt
    tcp        0      0 *:ftp                   *:*                     LISTEN     22395/proftpd: (acc
    tcp        0      0 server.domain.com:domain *:*                     LISTEN     22362/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN     22362/named
    tcp        0      0 *:smtp                  *:*                     LISTEN     25573/master
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     22362/named
    tcp        0      0 *:https                 *:*                     LISTEN     22212/apache2
    tcp6       0      0 *:imaps                 *:*                     LISTEN     7516/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     7416/couriertcpd
    tcp6       0      0 *:pop3                  *:*                     LISTEN     7349/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     7459/couriertcpd
    tcp6       0      0 *:domain                *:*                     LISTEN     22362/named
    tcp6       0      0 *:ssh                   *:*                     LISTEN     4035/sshd
    tcp6       0      0 *:smtp                  *:*                     LISTEN     25573/master
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     22362/named
    tcp6       0    984 server.domain.com:ssh    ::ffff:212.174.83:49193 VERBUNDEN  11639/sshd: andre [
    
    Code:
    Chain INPUT (policy DROP)
    target     prot opt source               destination
    DROP       tcp  --  anywhere             127.0.0.0/8
    ACCEPT     0    --  anywhere             anywhere            state RELATED,ESTABLISHED
    ACCEPT     0    --  anywhere             anywhere
    DROP       0    --  BASE-ADDRESS.MCAST.NET/4  anywhere
    PUB_IN     0    --  anywhere             anywhere
    PUB_IN     0    --  anywhere             anywhere
    PUB_IN     0    --  anywhere             anywhere
    PUB_IN     0    --  anywhere             anywhere
    DROP       0    --  anywhere             anywhere
    Chain FORWARD (policy DROP)
    target     prot opt source               destination
    ACCEPT     0    --  anywhere             anywhere            state RELATED,ESTABLISHED
    DROP       0    --  anywhere             anywhere
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    PUB_OUT    0    --  anywhere             anywhere
    PUB_OUT    0    --  anywhere             anywhere
    PUB_OUT    0    --  anywhere             anywhere
    PUB_OUT    0    --  anywhere             anywhere
    Chain INT_IN (0 references)
    target     prot opt source               destination
    ACCEPT     icmp --  anywhere             anywhere
    DROP       0    --  anywhere             anywhere
    Chain INT_OUT (0 references)
    target     prot opt source               destination
    ACCEPT     icmp --  anywhere             anywhere
    ACCEPT     0    --  anywhere             anywhere
     
    Chain PAROLE (10 references)
    target     prot opt source               destination
    ACCEPT     0    --  anywhere             anywhere
    Chain PUB_IN (4 references)
    target     prot opt source               destination
    ACCEPT     icmp --  anywhere             anywhere            icmp destination-unreachable
    ACCEPT     icmp --  anywhere             anywhere            icmp echo-reply
    ACCEPT     icmp --  anywhere             anywhere            icmp time-exceeded
    ACCEPT     icmp --  anywhere             anywhere            icmp echo-request
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:ftp
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:ssh
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:smtp
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:domain
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:www
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:81
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:pop3
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:imap2
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:https
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:webmin
    ACCEPT     udp  --  anywhere             anywhere            udp dpt:domain
    DROP       icmp --  anywhere             anywhere
    DROP       0    --  anywhere             anywhere
    Chain PUB_OUT (4 references)
    target     prot opt source               destination
    ACCEPT     0    --  anywhere             anywhere
    
    in der default ns1 steht server.domain.com kann ich nicht per ssh die server IP eingeben!
     
  11. Till

    Till Administrator

    Die Ausgabe oben sind alle OK und ISPConfig läuft definitv. Wenn Du über einen router zugreifst, solltest Du mal dessen Einstellungen durchgehen, an dem ISPConfig setup liegt es nicht.

    [​IMG]
    Was meinst Du damit?
     
  12. Andre

    Andre New Member

    Hallo Till

    ich dachte einfach ich könne eine änderung von hand vornehmen z.b. die ns default.

    Ich habe den router gewechselt und einen neuen router genommen von einem anderen modell, ohne erfolg es geht nicht, aber die meldung von:
    tail /root/ispconfig/httpd/logs/error_log
    Code:
    [Wed Apr 30 20:12:39 2008] [notice] Apache configured -- resuming normal operati                                       ons
    [Wed Apr 30 20:12:39 2008] [notice] Accept mutex: sysvsem (Default: sysvsem)
    
    und wenn ich es ohne https also http eigebe so kommt
    Code:
    [Wed Apr 30 20:12:39 2008] [notice] Apache configured -- resuming normal operati                                       ons
    [Wed Apr 30 20:12:39 2008] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Thu May  1 18:31:39 2008] [error] mod_ssl: SSL handshake failed: HTTP spoken on                                        HTTPS port; trying to send HTML error page (OpenSSL library error follows)
    [Thu May  1 18:31:39 2008] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GE                                       T_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]
    
    also kommt eine weitere Meldung, er sollte also funktionieren.
    Kannst du damit etwas anfangen ansonsten werde ich mal das ganze ohne ssl also http installieren
     
  13. Till

    Till Administrator

    Die erste Meldung bedeutet, dass der apache normal gestartet ist und dass keine Anfrage eingetroffen ist.

    Die 2. Meldung meisnt, dass Du per http auf einen https server zugegriffen hast.

    Was steht denn im normalen access log oder ssl log des Servers, wenn Du per https zugreifst?
     
  14. Andre

    Andre New Member

    die access_log mit IP.IP.IP.IP:81
    Code:
    212.174.83.12 - - [01/May/2008:18:31:39 +0200] "GET /mod_ssl:error:HTTP-request HTTP/1.0" 400 459
    
    ssl_engine_log mi IP.IP.IP.IP:81
    Code:
    [01/May/2008 20:50:38 22249] [info]  Connection to child 0 established (server [URL="http://www.itsitemap.li:81"]server.domaincom:81[/URL], client 212.174.83.12)
    [01/May/2008 20:50:38 22249] [info]  Seeding PRNG with 1160 bytes of entropy
    [01/May/2008 20:50:38 22249] [info]  Connection: Client IP: 212.174.83.12, Protocol: TLSv1, Cipher: AES128-SHA (128/128 bits)
    [01/May/2008 20:50:38 22249] [info]  Connection to child 0 closed with standard shutdown (server [URL="http://www.itsitemap.li:81"]server.domain.com:81[/URL], client 212.174.83.12)
    
    mit server.domain.com kommt kein log eintrag
     
  15. Andre

    Andre New Member

    Hallo

    Danke für die Hilfe, nun geht es einfach die SSL nach der Neuinstallation wenn SSL nicht geht nochmals ein geben:
    Code:
    http://www.howtoforge.com/forums/showpost.php?p=358&postcount=4
    und schon läufts und ist mit Port 81 erreichbar!

    :D
     

Diese Seite empfehlen