DNS funktionskontrolle

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von vikozo, 21. Dez. 2012.

  1. vikozo

    vikozo Member

    guten Tag

    beim Internet provider habe ich einen festen NS eintrag, der aber einen fehler ausgibt.

    Wie kann ich kontrollieren das der DNS Dienst korrekt auf die anfrage reagiert?

    vielen Dank für ein feedback
    vincent
     
  2. Till

    Till Administrator

    Du kannst Deinen Server wie folgt abfragen:

    dig @localhost deinedomain.tld

    Fehler zum DNS Server findest Du so:

    grep named /var/log/syslog
     
  3. vikozo

    vikozo Member

    Till
    vielen dank werde ich testen. Die IP Adresse alleine funktioniert ja - und ich lande auf der apache default page.
    Also sollte ja auch der ns1 erreichbar sein. soviel zu meiner logik

    gruss
    vincent
     
  4. Till

    Till Administrator

    Das ist so nicht ganz richtig, denn wenn Du die IP im Browser aufrufst wird port 80 bzw 443 verwendet. Die Fehlermeldung oben bezieht sich aber darauf dass der Nameserver nicht auf Port 53 erreicht werden konnte.

    Du kannst Dir Deinen Server vereinfacht als Hochhaus vorstellen, die IP ist die Adresse (Straße und Hausnummer) in der das Haus steht. Die Ports sind dann die unterschiedlichen Wohnungen. Was Du gesagt hast ist dass Herr Meier in Wohnung 53 da sein muss nur weil Frau Müller in Wohnung 80 da ist. Du siehst also dass sich das nicht so verallgemeinern lässt :)

    Un dann kommt noch hinzu ob Du den entspechenden Port für DNS überhaupt vom Router zum Server weitergeleitet hast.
     
  5. vikozo

    vikozo Member

    nun vom Router zum Server sind alle Port offen in beide Richtungen.
    Die Firewall von ISPConfig ist nicht eingeschaltet.
    gruss
    vincent
     
  6. vikozo

    vikozo Member

    das sind so die letzten Infos mit fehler
     
  7. vikozo

    vikozo Member

    Nachdem ich die ganze File neu von Hand geschrieben habe konnte sie gelesen werden - die von ISPConfig erstellte verursachte fehler.
     
  8. vikozo

    vikozo Member

    bei einer zweiten domaine hab ich ein problem das das
    nicht übereinstimmt was unter
    in IPconfig habe ich andere IP Adressen welche korrekt in der datei pri. eingetragen sind aber mit dem Dig befehlt werden lokale Private IP Adressen ausgegeben.
    mit freundlichem gruss
    Vincent
     
  9. Till

    Till Administrator

    Starte mal bind neu und schau dann ob es Fehlermeldungen im /var/log/syslog von "named" gibt.
     
  10. vikozo

    vikozo Member

    sogar den ganzen Server gebootet nach 22 Tagen
    ergibt vor allem
    was mich nun noch verunsichert.
    unter /etc/bind# ls
    habe ich diverse files unter anderem
    pri.kozo.ch (was ich als Primäre DNS Zone Datei interpretiere)
    aber auch
    pir.ns1.kozo.ch (da ist aber nur ein Teil von dem enthalten was in pri.kozo.ch enthalten ist)

    ach ja . meine Homepage www.kozo.ch war lange erreichbar - jetzt aber auch nicht mehr
     
  11. Till

    Till Administrator

    Poste bitte mal die Datei /etc/bind/pri.kozo.ch.

    Die Datei pir.ns1.kozo.ch ist wahrscheinlich bei einem Konfigurationsversuch oder so entstanden, möglicherweise hattest Du mal den ns1 Eintrag als Zone erstellt und nicht die Domain.
     
  12. vikozo

    vikozo Member

    nachdem die datei pri.kozo.ch
    nicht der gleiche inhalt hat wie das was in ISPConfig eingegeben ist habe ich die datei in Bind gelöscht
    wie lange dauert es bis eine datei von ISPconfig ins Bind directory geschrieben wird?
    gruss
    vincent
     
  13. Till

    Till Administrator

    Bitte keine config Dateien manuell löschen, das bring garnichts denn sie wird dadurch nicht neu geschrieben.

    Ändere mal etwas an der Zone, z.B. setze die TTL um eine Sekunde rauf. Dann sollte es etwa 1 Minute dauern bis die Datei neu geschrieben wird.
     
  14. vikozo

    vikozo Member

    Die Datei wurde neu geschrieben:
    der inhalt meiner
    pri.kozo.ch
     
  15. Till

    Till Administrator

    Da sind einige Records falsch in ISPConfig eingetragen. Jede vollständige Domain muss im DNS mit einem Punkt enden. Wenn der punkt fehlt, dann behandelt bind den Eintrag als subdomain und hängt die Zone an. Aus "kozo.ch" wird also "kozo.ch.kozo.ch"

    Also z.B.:

    kozo.ch.

    und nicht

    kozo.ch

    oder:

    vkocher.wombat.ch.

    und nicht

    vkocher.wombat.ch
     
  16. vikozo

    vikozo Member

    ist das Peinlich, das ein kleiner Punkt soviel schaden und verzweiflung anrichten kann. ;)
    Till vielen Dank der Tipp war korrekt und jetzt funktioniert es. :)

    frage zum mx Record (für die Emails)
    muss ich einen A Record machen der mail.kozo.ch. auf die IP adresse bindet
    und einen MX Record (hostname: )mail (Mailserver hostname:)mail.kozo.ch.

    oder genügt der mx record?

    mit freundlichem gruss
    vincent
     
  17. Till

    Till Administrator

    Du benötigst einen A und einen MX record wenn Du mail.kozo.ch als MX nehmen möchtest.

    Du kannst aber durchaus auch einfach kozo.ch als MX Ziel nehmen, denn dafür ist bereits ein A-Record da.

    Meistens wird aber mail.kozo.ch genommen, da es klarer ist und oft ist der Mailserver ja auch nicht der gleiche Server wie der Webserver.
     
  18. Brainfood

    Brainfood Member

    Auch wenn Till deine Probleme lösen konnte...

    DNS Checks:

    schnell geht es immer mit einem

    Code:
    dig ANY domain.tld
    
    Abfrage des lokalen oder spezifisch entfernten DNS Resolvers:
    
    dig @localhost domain.tld
    dig @remoteip domain.tld
    
    DNSSEC:
    
    dig +dnssec @ns1.chaosdns.de iana.org
    ausführliche Tests bekommst du z.B. unter:

    DNSCheck
    intoDNS: checks DNS and mail servers health
    Pingdom Tools

    Wenn du mit Fail2ban DNS "absicherst" musste aufpassen, da ab mehreren DENY Anfragen schnell solche "legitimen" Testserver weggeblockt werden können

    3 der geläufigsten Fehler sind:

    fehlerhafte HINFO Einträge ("" nicht sauber gesetzt)
    fehlerhafte Subdomain Einträge (PUNKT, ohne PUNKT Unachtsamkeit)
    SOA zwischen NS1/NS2 net im sync

    BIND Configcheck:

    named-checkconf
     
    Zuletzt bearbeitet: 11. Jan. 2013
  19. vikozo

    vikozo Member

    Danke für dein Feedback
    ja ich bin froh das Till helfen konnte und ja es war die Punkt sache die mir Sorgen machte.
    Jetzt läuft es und ich bin weiter am Ausprobieren.

    mit freundlichem gruss
    Vincent
     

Diese Seite empfehlen