DNS hinzufügen

Dieses Thema im Forum "Server Administration" wurde erstellt von darkness_08, 24. Apr. 2016.

  1. darkness_08

    darkness_08 Member

    Hallo,
    bisher verwende ich eine Mirror-Setup ohne DNS zu verwenden (das läuft noch über ovh).
    Server2 ist mirror von Server1
    Jetzt möchte ich gerne ISPConfig als DNS verwenden. Server1 soll dann der ns1.domain werden und auf einen vserver soll dann ns2.domain laufen.
    Kann ich diesen dann einfach als MultiServer-Setup dem Server1 hinzufügen?
    Oder sollte ich den ns1 auch besser auf einen eigenen vserver aufsetzen?
     
  2. florian030

    florian030 Member

    Du setzt einen vServer auf, installierst darin alles was Du für ISPConfig und bind brauchst (Apache kannst Du genauso weglassen wie mail) und rufst da dann install.php im expert-mode auf und joinst dann dein mutliserver-setup.
    Wenn Du aber eh 2 Server hast, kannst Du doch auch auf beiden bind laufen lassen?
     
  3. darkness_08

    darkness_08 Member

    Danke.
    Die beiden Server sind letztendlich VServer auf dem gleichen Host. Sprich: IPs aus dem gleichen Subnetz. Mir war mal so als wenn die IPs der DNS unterschiedliche Subnetze sein sollten.
     
  4. florian030

    florian030 Member

    Sollten ja, müssen nein. Aber zwei DNS auf einem Hardware-Server... kann man machen, ist nur blöd, wenn der mal abschmiert ;)
     
  5. darkness_08

    darkness_08 Member

    Laut Handbuch stelle ich beim Slave DNS ist mirror von DNS1 ein. Bei mir wäre das Server1 der aber auch master für Web, Mail usw ist.
    Ist der Slave DNS dann trotzdem Mirror von Server1?
     
  6. florian030

    florian030 Member

    Ja, ist er. Wenn der Slave aber nur den Service DNS hat, dann wird dort auch nur Bind aktualisiert.
     
  7. darkness_08

    darkness_08 Member

    ah ok, danke.
     
  8. darkness_08

    darkness_08 Member

    Hm, leider klappt das hinzufügen des DNS zum Master nicht.
    Ich verwende Mysql mit SSL über den Port 3306.
    Ein
    Code:
    mysql -u root -p -h master.domain -D dbispconfig1
    klappt ohne Probleme
    Wenn ich aber ispconfig installierte kommt folgender Fehler:
    Code:
    Shall this server join an existing ISPConfig multiserver setup (y,n) [n]: y
    MySQL master server hostname []: master.domain
    MySQL master server root username [root]:
    MySQL master server root password []: GEHEIM
    MySQL master server database name [dbispconfig]: dbispconfig1
    Unable to connect to mysql server 
    Verwendet ISPConfig andere mysql-parameter zum verbinden?

    Fehlerlog auf dem Master:
    Code:
     [Warning] Access denied for user 'root'@'ns2.domain' (using password: YES)
     
    Zuletzt bearbeitet: 27. Apr. 2016
  9. robotto7831a

    robotto7831a Member

    Hast Du in den MySQL Berechtigungen den Benutzer root auch erlaubt, sich von ns2.domain anzumelden?
     
  10. darkness_08

    darkness_08 Member

    Ja, der eingangs erwähnte zugriff klappt ja entsprechend. von ns.domain auf master.domain
     
  11. robotto7831a

    robotto7831a Member

    Also entweder stimmt die Konfiguration für den Benutzer root nicht oder Du verwendest das falsche Passwort. Sonst würde die obige Fehlermeldung nicht kommen.
     
  12. darkness_08

    darkness_08 Member

    hm, vielleicht habe ich die berühmten Tomaten gerade auf den Augen.
    Manuell kann ich mich vom ns zum master auf die Datenbank ispconfig1 verbinden. Bei ispconfig sollen die gleichen Zugangsdaten nicht mehr funktionieren?
    Ich schaue noch mal alles Schritt für Schritt durch.
     
  13. darkness_08

    darkness_08 Member

    so, noch mal alles in Ruhe durchgegangen. Jetzt läuft es.
    Ich denke es lag am Passwort. Die hatte als Sonderzeichen ein ' enthalten. Bin mir nicht sicher, ob ispconfig dies als Sonderzeichen kennt bzw. behandelt. Aber mit einem anderem Passwort hat es geklappt.
    Danke für die Tipps.
     
  14. mzips

    mzips Member

    Kann sehr gut möglich sein gerade weil das Installscript auf php basiert wie oft hatte ich den fehler und im Passwort ein $ und rate mal wie lange ich Fehler gesucht habe........ genau Tage :D
     

Diese Seite empfehlen