DNS-Mischmasch

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Blackwolf, 24. Juli 2008.

  1. Blackwolf

    Blackwolf New Member

    Salve Boarders ...

    Ich hab ein putziges Problem ..... :)

    Gegeben ist:

    Isp-Config auf einem virtuellen Server bei Strato mit einer eigenen IP (85.214.xxx.yyy) und dem hostname "h123456.stratoserver.net".

    Dort liegen mittlerweile drei Domains:

    www.somedomain.de
    www.someotherdomain.de
    www.someotherotherdomain.de

    ... die sich diese IP sharen ...

    In www.someotherotherdomain.de läuft u.a. ein Newsletter-mailer (PHPList).

    Wenn ich nun (die Einstellungen in PHPList sind korrekt) Newsletter über den SMTP-Server "mail.someotherotherdomain.de" (wie in ISP-Config angegeben) verschicke, dann stehen im Envelope der Mail auch die korrekten Emailadressen von www.someotherotherdomain.de.

    Soweit so gut ...

    Der SMTP-Server wird aber im Mailheader mit der IP des virtuellen Servers aufgelöst und .... mit dem Namen von
    www.somedomain.de. :confused:

    Code:
    [Mailheader ...]
    ...
    Received: from [B]h123456.stratoserver.net[/B] ([COLOR=Red][B]www.somedomain.de[/B][/COLOR] [[B]85.214.xxx.yyy[/B]]) by mailin.webmailer.de (andre mi23) (RZmta 16.48) with ESMTP id 300dc0k6OCON7z for <[B][COLOR=SeaGreen]user@someotherotherdomain.de[/COLOR][/B]>; Thu, 24 Jul 2008 14:31:24 +0200 (MEST) (envelope-from: <[B][COLOR=Green]bounce@[/COLOR][COLOR=SeaGreen]someotherotherdomain.de[/COLOR][/B]>)
    
    Received: from [B][COLOR=SeaGreen]www.someotherotherdomain.de[/COLOR][/B] ([COLOR=Red][B]www.somedomain.de[/B][/COLOR] [[B]85.214.xxx.yyy[/B]]) by [B]h123456.stratoserver.net[/B] (Postfix) with ESMTP id 373213381F8 for [B][COLOR=SeaGreen][COLOR=Black]<[/COLOR]user@someotherotherdomain.de[/COLOR][/B]>; Thu, 24 Jul 2008 14:31:24 +0200 (CEST)
    
    Woran kann das liegen, das der SMTP durch eine andere Domain aufgelöst wird und nicht durch die, die versendet?

    Und ... wo kann ich dem DNS sagen, das er's richtig auflösen soll?

    Greetz ...

    Blackwolf
     
  2. Till

    Till Administrator

    Eine IP hat immer nur einen reveerse record, d.H. die IP löst immer nur zu dem Hostnamen des Servers auf. Das ist ganz normal und kann auch nicht geändert werden, jeder Mailserver meldet sich nur mit seinem Hostnamen, auch wenn über ihn emails für verschiedene Domains versnd werden.
     
  3. Blackwolf

    Blackwolf New Member

    Hi Till,...

    das mit dem Hostnamen (h123456.stratoserver.net) ist mir schon verständlich ... aber wieso nimmt er parallel dazu eine andere domain (www.somedomain.de) als die, über die versendet wird (www.someotherotherdomain.de)?

    [Edit]
    Kann es sein, das ISPConfig die zuerst angelegte Domain (und das war www.somedomain.de) mit der IP im DNS assoziert bei einer shared-IP, weil es im völlig schnuppe ist, welche er angibt, da alle eh unter der selben IP laufen? Falls ja, kann man dieses "Ranking" irgendwo umstellen, das www.someotherotherdomain.de als erstes angezeigt wird?
    [/Edit]

    Greetz ...
    Blackwolf
     
    Zuletzt bearbeitet: 24. Juli 2008
  4. Till

    Till Administrator

    Was hast Du denn für eine Domain in der main.cf und in /etc/mailname stehen und was gibt der Befehl "hostname -f" zurück?
     
  5. Blackwolf

    Blackwolf New Member

    /etc/postfix/main.cf : myhostname = h123456.stratoserver.net

    ... keine direkte domain-Angabe (Einträge von ISPConfig).

    /etc/mailname: h123456.stratoserver.net

    hostname: h123456.stratoserver.net

    Das ist ja soweit auch ok,... aber mich ärgert die "falsche" Domain (siehe Edit im letzten post)

    Greetz ...

    Blackwolf
     
  6. Till

    Till Administrator

    Hast Du mehr als eine IP?
     
  7. Blackwolf

    Blackwolf New Member

    Nö,... nur die eine und die ist bei ISP-CONFIG als "shared" eingetragen.

    Greetz
    Blackwolf
     
  8. Till

    Till Administrator

    Dann weiß ich es so auch nicht. ISPConfig konfiguriert nichts in Bezug auf IP's und mail domains bzw. welche Mail Domain beim senden verwendet wird. Hast Du vielleicht irgendwie den Empfänger Account weitergeleitet oder etwas in der transports Datei umgebogen?
     
  9. Blackwolf

    Blackwolf New Member

    Ich hab jetzt mal ein nslookup gemacht:

    Code:
    nslookup 85.214.xxx.yyy
    
    Server:         85.214.aaa.bbb
    Address:        85.214.aaa.bbb#53
    
    Non-authoritative answer:
    yyy.xxx.214.85.in-addr.arpa     name = [COLOR=Red][B][URL="http://www.somedomain.de/"]somedomain.de[/URL][/B][/COLOR].
    
    Authoritative answers can be found from:
    
    
    ... und da wird der domainname, nicht der hostname zurückgegeben ... *grübel

    Greetz ...
    Blackwolf
     
  10. Blackwolf

    Blackwolf New Member

    zum ersteren: .... ich habe die domain von www.someotherotherdomain.de verwendet in den Emails, den smtp-server mail.someotherotherdomain.de

    und zum zweiteren: ... welche Datei bitte?

    Greetz ...
    Blackwolf
     
  11. Till

    Till Administrator

    Wenn Du die Datei nicht kennst, dann wohl eher nicht :) Der Pfad der datei ist normalerweise /etc/postfix/transport
     
  12. Blackwolf

    Blackwolf New Member

    Ich hab eben nachgesehen ....

    In /etc/postfix ist keine "transport" .... ich hab den Rechner nach dem "Perfect-Setup" von Falco (Debian Etch) und dann mit ISP-Config aufgesetzt .... nix nachkompiliert und/oder selber zerstückelt ...

    ... bitte haut mich nich' .... :)

    Greetz ...
    Blackwolf
     
  13. Till

    Till Administrator

    Wenn Du keine transport Datei hast, dann ist das ok.
     

Diese Seite empfehlen