DNS Probleme

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von nightshift, 5. Jan. 2010.

  1. nightshift

    nightshift New Member

    Ich habe auch DNS Probleme. Habe gestern meinen Server neu aufgesetzt und dabei auf meine Debiany Lenny anhand eurer Anleitung bei Howtoforge die aktuelle ispconfig 3 Variante installiert.

    Dann habe ich noch PHP 5.3.1 und MYSQL 5.1.41 von Dotdeb gezogen und installiert. Genau wie vor dem aufsetzen lief es auch jetzt.

    So das Problem ist aber der DNS Kack mal wieder.
    Gestern habe ich das das ganze gemacht und heute kommt wieder kaum jemand auf meine Websites raus. Ich selbst komme noch rauf genau wie einige andere auch.

    Problem ist das inzwischen mein LiveZilla Support Chat mich selbst auch nicht mehr connecten lässt. Daher vermute ich das so langsam auch bei mir der Server nicht mehr erreichbar ist da Unitymedia wohl wie ich gelesen hat sehr langsame DNS hat.

    So dig für meine eigene Domain die ich mit ispconfig veralte:
    ks305618:~# dig @localhost ufp-rollenspiel.net

    ; <<>> DiG 9.5.1-P3 <<>> @localhost ufp-rollenspiel.net
    ; (1 server found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 13457
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;ufp-rollenspiel.net. IN A

    ;; Query time: 5 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue Jan 5 14:26:22 2010
    ;; MSG SIZE rcvd: 37



    Habe folgendes bei ispconfig gestern mit den Wizard eingegeben

    SOA ufp-rollenspiel.net.
    NS. ns.ufp-rollenspiel.net
    Mail: info.ufp-rollenspiel.net
    Die ganzen Werte wie TLLL, Retry etc stehen auf Standard.

    Records sind demzurfolge Automatisch angelegt

    A mail 91.121.220.175
    A ufp-rollenspiel.net. 91.121.220.175
    A www 91.121.220.175
    MX ufp.rollenspiel.net. mail.ufp-rollenspiel.net.
    NS ufp-rollenspiel.net bs.ufp-rollenspiel.net.
    NS ufp-rollenspiel.net. ns.kimsufi.com.

    Beim Hoster OVH sind folgende Daten eingetragen (unverändert, vor dem Server neu aufsetzten ging es damit doch auch noch !)

    DNS Server
    1 ns.ufp-rollenspiel.net
    2 ns.kimsufi.com


    DNS Zine
    .ufp.rollenspiel.net NS dns14.ovh.net
    .ufp-rollenspiel.net NS ns.14.ovh.net
    .ufp-rollenspiel.net A 91.121.220.175
    *.ufp-rollenspiel.net A 91.121.220.175


    www.checkdns.net brachte mit dem Quicheck folgendes

    Got DNS list for 'ufp-rollenspiel.net' from I.GTLD-SERVERS.net Found NS record: ns.kimsufi.com[213.186.33.199], was resolved to IP address by I.GTLD-SERVERS.net Found NS record: ns.ufp-rollenspiel.net[91.121.220.175], was resolved to IP address by I.GTLD-SERVERS.net Domain has 2 DNS server(s)
    CheckDNS.NET is verifying if NS are alive DNS server ns.kimsufi.com[213.186.33.199] is alive, but not authoritative for domain 'ufp-rollenspiel.net' and didn't return SOA Error fetching SOA from ns.ufp-rollenspiel.net [91.121.220.175]: Connection reset. Probably DNS server is offline. 0 server(s) are alive No DNS servers alive, tests stopped
     
  2. Till

    Till Administrator

    Die Einstellungen im DNS sind ok. Vermutlich läuft garkein lokaler DNS Server. Poste mal die Ausgabe von:

    netstat -tap
     
  3. fuxifux

    fuxifux Member

    Kann es sein, dass es sich nur um einen Tippfehler handelt?

    Du hast ein paarmal nach dem '.net' nochmal einen '.' drin....
     
  4. nightshift

    nightshift New Member

    Der Punkt wurde automatisch angefügt.



    Nachdem man mitgeteilt hat das BIND und myDNS nicht gut zusammen arbeiten und es dann zu kompliziert sein sollte hat man mir geraten BIND zu deinstallieren. Da ich heute auch noch Probleme hatte SQL wieder zum laufen bekommen habe ich den Server wieder neu aufgesetzt und danach BIND9 deinstallliert.

    Nun habe ich also nurnoch myDNS auf dem Server. Dort habe ich folgende Werte hinterlegt ( mit ispconfig erzeugt):

    http://www.screencast.com/users/nightshi…7f-cbdfccef436b

    An der Konfig beim Hoster (siehe Video habe ich nichts verändert da es angeblich richtig sei)

    http://www.screencast.com/users/nightshi…42-af80f78cb1c9


    Ein neuer DSN Check zeigt folgendes....:

    http://www.intodns.com/ufp-rollenspiel.net




    dig auf dem Server selbst gibz derzeit folgendes aus:

    ks305618:~# dig ufp-rollenspiel.net

    ; <<>> DiG 9.5.1-P3 <<>> ufp-rollenspiel.net
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 54627
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    ;; WARNING: recursion requested but not available

    ;; QUESTION SECTION:
    ;ufp-rollenspiel.net. IN A

    ;; Query time: 1 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue Jan 5 19:44:24 2010
    ;; MSG SIZE rcvd: 37

    ks305618:~#

    Da stimmt doch wieder was nicht wegen dem WARNING recursion ....

    Hat da jemand eine Idee ?



    PS: Derzeit geht eh nichts da nach einem neustart mit dem Befehl reboot garnichts mehr geht. Nicht mal mehr der mechanische Neustart geht. Jetzt muss ich eh erstmal auf einen Techniker warten.

    Ganz schön nervig...das ganze.
     
  5. Till

    Till Administrator

    Und der muss auch da sein. das gilt übrigens genause für BIND Server wie für MyDNS.

    Wenn Du Bind mit drauf hattest, ist es natürlich klar, dass da nichts lief. Bind ist inkompatibel mit ispconfig 3 und darf niemals zusammen mit mydns installiert sein.

    Wenn Du möchtest dass ich Dir helfen kann, poste bitte das um was ich Dich gebeten habe.
     
  6. nightshift

    nightshift New Member

    Ich habe es jetzt mit der fertigen Distrubution vom Hoster hinbekommen.
    Muss dann denke ich mal irgendwo bei der Installations-Anleitung von Howto-Forge etwas falsch gemacht haben.

    Aber Danke für die Infos bisher.


    Nachdem gestern mein Server dann noch einige andere Probleme hatte z.B. nach einem Neustart nicht mal mehr per SSH erreichbar war habe ich den halt neu installiert. Daher konnte ich zumindest vorher auch leider deinen Befehl netstat -tap nicht mehr ausführen.
     

Diese Seite empfehlen