DNS Server als OFFLINE markiert

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von mare, 31. März 2011.

  1. mare

    mare Member

    Ich habe folgendes Multiserversetup aufgebaut :

    1x Master + BIND als Hidden DNS (wird auf die 4 Public Server gepusht)
    3x WEB+DB+FTP
    1x Mail

    Als ich bei den ersten Versuchen alles auf einer Maschine hatte war alles ok.
    Jetzt meldet ISP_CONFIG im Monitor dass der DNS Server (localhost) offline wäre.

    Bind läuft und beantwortet auch Anfragen. Im Quellcode steht beim DNS ein TCP Test auf Port 53. Ein Telnet auf den Port funktioniert.
    Wo kann ich nachschauen, warum ISPconfig der Meinung ist, das Server wäre offline ?
     
  2. Till

    Till Administrator

    Stell sicher dass der DNS Server auch an localhost erreichbar ist un nidcht nur auf einer anderen IP.
     
  3. mare

    mare Member

    Hallo,
    Danke für die schnelle Antwort.
    Der Server antwortet auch auf Anfrage auf localhost.

    Code:
    root@control:~# netstat -an | grep ":53"
    tcp        0      0 192.168.216.201:53        0.0.0.0:*               LISTEN
    tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN
    tcp6       0      0 :::53                   :::*                    LISTEN
    udp        0      0 192.168.216.201:53        0.0.0.0:*
    udp        0      0 127.0.0.1:53            0.0.0.0:*
    udp6       0      0 :::53                   :::*
    root@control:~#
    
     
  4. Till

    Till Administrator

    Schau mal ob localhost richtig in der /etc/hosts für IP 127.0.0.1 definiert ist.
     
  5. mare

    mare Member

    Code:
    root@control:~# grep local /etc/hosts
    127.0.0.1       localhost
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    
    root@control:~# grep 127 /etc/hosts 
    127.0.0.1       localhost
    
    Code:
     dig google.de @localhost
    
    ; <<>> DiG 9.7.3 <<>> google.de @localhost
    google.de.              300     IN      A       209.85.143.104
    google.de.              300     IN      A       209.85.143.99
    .
    .
    .
    .
    ;; Query time: 654 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Mar 31 14:38:54 2011
    ;; MSG SIZE  rcvd: 173
    
    
     
  6. mare

    mare Member

    Die Abfrage läuft auch sauber :

    Code:
    tcpdump -i lo port 53
    
    14:45:02.192601 IP localhost.60336 > localhost.domain: Flags [S], seq 1622520591, win 32792, options [mss 16396,sackOK,TS val 24585069 ecr 0,nop,wscale 6], length 0
    14:45:02.192638 IP localhost.domain > localhost.60336: Flags [S.], seq 1609848092, ack 1622520592, win 32768, options [mss 16396,sackOK,TS val 24585069 ecr 24585069,nop,wscale 6], length 0
    14:45:02.192661 IP localhost.60336 > localhost.domain: Flags [.], ack 1, win 513, options [nop,nop,TS val 24585069 ecr 24585069], length 0
    14:45:02.193270 IP localhost.60336 > localhost.domain: Flags [P.], seq 1:19, ack 1, win 513, options [nop,nop,TS val 24585069 ecr 24585069], length 1821536 update+ [b2&3=0x2f20] [21584a] [18516q] [12081n] [11824au][|domain]
    14:45:02.193288 IP localhost.domain > localhost.60336: Flags [.], ack 19, win 512, options [nop,nop,TS val 24585069 ecr 24585069], length 0
    14:45:04.195850 IP localhost.60336 > localhost.domain: Flags [F.], seq 19, ack 1, win 513, options [nop,nop,TS val 24585569 ecr 24585069], length 0
    14:45:04.196511 IP localhost.domain > localhost.60336: Flags [F.], seq 1, ack 20, win 512, options [nop,nop,TS val 24585570 ecr 24585569], length 0
    14:45:04.196565 IP localhost.60336 > localhost.domain: Flags [.], ack 2, win 513, options [nop,nop,TS val 24585570 ecr 24585570], length 0
    
    
     
  7. Till

    Till Administrator

    ISPConfig checkt einfach nur, ob es eine Verbindung zu Port 53 TCP auf localhost herstellen kann. Ist das nicht möglich, wird der Dienst als offline angezeigt.
     
  8. mare

    mare Member

    Wenn "telnet localhost 53" eine Verbindung aufmacht kann ich aber auch nicht mehr viel tun oder ?
     
  9. Till

    Till Administrator

    Und Du bist sicher dass Du den richtigen Server gecheckt hast? bzw. das dns auf ellen servern die nicht dns server sind in ispconfig deaktiviert ist?
     
  10. mare

    mare Member

    Ja, das DNS läuft nur auf dem Masterserver selbst und ist auch nur dort hinterlegt. Die Fehlermeldung kommt ja auch für den Masterserver. Bei den anderen Server gibt es keinen DNS Dienst.
     
  11. mare

    mare Member

    Ich nochmal ;-)

    Wenn ich :

    - Einen anderen Dienst auf dem Server aktiviere (WEB/DB usw.) wird dessen Status korrekt übers Monitoring erkannt.

    - Ich die Funktion _checkTcp aus dem Source extrahiere und per Hand startet wird der DNS Server als online erkannt.

    hmm....


    EDIT:
    Kann es sein, das es daran liegt, das der DNS Server auf die Eingabe
    --> fwrite($fp, "GET / HTTP/1.0\r\n\r\n"); keine Antwort liefert.

    Ich habe den DNS-Test jetzt auf _CheckUdp umgestellt da läuft es !

    System: Debian Squeeze + SVN ISPConfig
     
  12. Till

    Till Administrator

    Welche ISPConfig Version verwendest Du denn, Stable oder SVN? Bei mir läuft das Monitoring unter stable 3.0.3.2 bze 3.0.3.3 RC1 einwandfrei und wir haben auch keine diesbezüglichen Bugreports erhalten.
     
  13. mare

    mare Member

    System: Debian Squeeze + SVN ISPConfig
     
  14. Till

    Till Administrator

    Hab gerade mal das SVN Log gecheckt. Oliver hatte letzten Samstag den TCP Check erweitert und wohl nicht daran gedacht, dass die Funktion nicht nur zum testen des apache eingesetzt wird. Ich habe den BIND Test jetzt auf UDP umgestellt.
     
  15. mare

    mare Member

    Ok, habe ich bei mir lokal auch schon so gelöst gehabt.

    BTW: im mail.log sieht ein "HTTP 1/0 GET /" auch irgendwie komisch aus :)
     
  16. Till

    Till Administrator

    Danke für den Hinweis. Ich hab ihm geschrieben dass er sich seine letzten Änderungen nochmal ansieht.
     

Diese Seite empfehlen